No display blanking after "Screen Energy Saving" interval expires?

Opensuse 13.1 fresh install on a Mac Pro (mid 2009) with 24 inch Apple Cinema Display. nouveau driver. Running KDE.

I can’t get the screen to blank after the powersave interval. This used to work on the same hardware under 12.3, also using nouveau, so it’s not a hardware incapability. Of course, I can use a blank screensaver, but that doesn’t turn off the monitor backlight like true blanking does, it just displays a black screen at full power.

xset q says that dpms is enabled but xset dpms force off does nothing. If I xset dpms 1 1 1, ssh from a different machine, set DISPLAY, and check xset q, it will tell me that the monitor is OFF; but no, it’s on. I can do whatever I want with the Screen Energy Saving setting under Power Management in “configure desktop”, and it ignores me. I’ve even waited overnight, the screen stays lit indefinitely.

Other than that, everything seems to work fine with the nouveau driver. (Oddly enough, the driver ONLY works if I compile it as a module; if I compile it built-in, it won’t boot, spraying endless PAGE_NOT_PRESENT messages from the driver. Whatever.)

I’ve tried this with the standard 13.1 desktop kernel (3.11.10-7), and a 3.14.1 kernel, and both act identically.

Any ideas? I have no real interest in going to the nvidia driver, and I’d rather not try it because my experience with installing / deinstalling it has not been positive in the past. If there’s no known fix, is there a way to manually tell the driver to turn off the display so that I could roll my own powersave? (I tried the old vbetool that’s no longer in the distribution; it sort-of worked, powering down the display, but when powering back up all sorts of glitches were present, such as a missing hardware cursor.)

(The main reason I care about this is that the display is quite expensive, runs warm after a few hours, and there’s no on/off switch. As it stands now it would be running at full power 24x7 and I’d rather avoid the heat and energy wastage!)

Almost certainly an issue with the nouveau driver.

What is reported from

grep -i DPMS /var/log/Xorg.0.log
dmesg|grep drm

Not sure I can offer any solution to this, but you may want to search for existing bugs and/or report if necessary

grep of Xorg log says:
Initializing built-in extension DPMS
(II) NOUVEAU(0): DPMS Capabilities: OFF
(==) NOUVEAU(0): DPMS Enabled
The EDID supported features byte is 0x26 which would seem to match the Capabilities: OFF line.

There’s nothing about dpms in dmesg, and the drm related output is uninteresting. (drm 1.1.0, initialized nouveau.)

The following command may provide more info than dmesg these days?

journalctl -xb --no-pager|grep drm

journalctl and dmesg report identically re drm, ie nothing interesting. Also, don’t know if this matters, but dbus-daemon is reporting no kernel backlight interface found, even though I have backlight support enabled for nouveau. That might be something different though.

I think this might be nouveau bug 76483. That report suggests a solution and I might play with it; I’ve already burned the weekend fooling with my new 13.1 install, I might as well put of doing Real Work for another day or two!

It seems that the strangeness may go deeper than just the nouveau driver.

I did try installing the closed-source nvidia driver, and now I do indeed get a blank (powered-down) screen after the appropriate timeout. (Yay!) BUT, one second later, the backlight comes back on! (Boo, Hiss) even though the screen stays black. Even more interesting, it repeats this little exercise a couple times, apparently after another display-off timeout elapses. During this whole time, xset q (from a remote login) says that X thinks that the display is Off. Which it sorta is, but not really.

So I might as well go back to the nouveau driver and use a blank screensaver, since it won’t be any worse than what is going on with the nvidia driver.

Neither dmesg nor the Xorg.0.log have anything to report on this, it all looks perfectly normal in the logs.

Does this result in turning the display back-lighting off properly?

xset dpms force off

xset dpms force off does nothing with the nouveau driver.

With nvidia it does blank the display properly, for one second. Then the screen stays dark but the backlight comes back on. It’s very noticeable on the Cinema display. It’s the same behavior as seen with the powersave timeout.

Just in case anyone happens across the same issue, this was indeed a nouveau bug, #76483, and it’s just been fixed in the source. With luck the fix may hit kernel 3.16.

Going to the nvidia blob driver didn’t help because this Apple LCD display is apparently braindead and sends a retrain request upon DPMS off! which immediately turns the display back on. So you get a flash but no display-off. The display blanks properly under OS/X so I don’t think this is faulty hardware, I think it’s mis-designed hardware.

Good to know. Thanks for the update.