No display after selecting 3D acceleration

Hi. I made a mistake by selecting the 3D Acceleration/Desktop Effects & reboot. After reboot, I can see the openSUSE green screen with the progress bar moving from left to right. Display goes blank when the progress bar reached about 75% & shortly after that I can hear the welcome tune. At the blank screen, I can get into command prompt by repeating alt-ctrl-backspace a few times.

Although I can’t login normally, I can still login under fail safe mode. Under Control Center, 3D Acceleration & Desktop Effects are no longer checked, so I can’t un-check them to undo my mistake (hope this make sense). I tried checking & unchecking both options & reboot but to no avail. I still can’t get into SUSE normally.

What can I do to undo 3D Acceleration & Desktop Effects so that I can get into SUSE normally ?


First, to get back into your video control panel, boot into the CLI (Command Line Terminal), or the black screen with the white text. There, enter your username and password to login. Then, enter the command su and then enter your root password when prompted to do so. This will log you in a SuperUser (root). Once your logged in as a SuperUser, issue the command sax2. This may take a few seconds to load Sax2, but when it does, you will be presented with the configuration panel for Sax2. Here, you can uncheck the 3D Acceleration box. Once you have unchecked the 3D Acceleration box, press OK and then Save in the prompt to save your changes. This will drop you back to the CLI: now issue the command exit. This will log you out of the root permissions. Finally, issue the command startx to start the X-Server and boot into your graphical desktop.

As for your question about why it happens: do you know which driver you installed, and do you know what your graphics card make and model is? If you need to find out, open a terminal (or if you are in the CLI), login as root with the su command and then issue the command hwinfo --gfxcard. This will give you all the information on your graphics card. Use the Model section of the readout to find your graphics card model.

I hope that helps. :slight_smile:

Unseen Ghost, I logged in safe mode, followed your instructions & got the SAX2 config panel. However, 3D is already unchecked. I repeated the process via normal login & of course I get the blank screen again. I entered ctrl-alt-backspace many times until I get the command prompt. Again the XAX2 config panel says 3D is already unchecked.

I am using ATI Redeon 7500E (RV 200) & SUSE detected it correctly. I had no problems using SUSE until I checked 3D.

Any ideas ? Thanks

Just so I’m on the same page, are you able to get into a graphical desktop, even if it is through your failsafe? I only ask because it will be much easier to install the driver for ATI cards through the graphical method, rather than the terminal method.

Yes, I am able to get into graphical desktop via safe mode. Funny thing is that 3D option & desktop effects are already unchecked. Previously before I played around with the 3D/desktop effects, I could use SUSE flawlessly.

HWINFO on the video card as follows. SUSE correctly detected the card as “ATI RV200 QW”.

Looking forward in your reply. Many thanks.

14: PCI(AGP) 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_1002_5157
Unique ID: VCu0.fPl59+BnBR8
Parent ID: vSkL.uvrveDpO5n6
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI RV200 QW”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x5157 “RV200 QW”
SubVendor: pci 0x17af “Hightech Information System Ltd.”
SubDevice: pci 0x2002
Memory Range: 0xe0000000-0xe7ffffff (rw,prefetchable)
I/O Ports: 0x9000-0x9fff (rw)
Memory Range: 0xed000000-0xed00ffff (rw,non-prefetchable)
Memory Range: 0xec000000-0xec01ffff (ro,prefetchable,disabled)
IRQ: 5 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00005157sv000017AFsd00002002bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: radeon
Options: norenderaccel
Driver Info #1:
XFree86 v4 Server Module: radeon
3D Support: yes
Extensions: dri
Options: norenderaccel
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #25 (PCI bridge)

Update - I found this link ATI - openSUSE & followed it step by step via 1-click install under safe mode. To my surprise, the install went smoothly. After installation is complete, I unchecked 3D acceleration to be sure & rebooted.

Sad to say problem remained the same ie no display after the startup progress bar reached about 75% under normal startup.

Sigh, would appreciate any ideas :frowning:

Okay, the driver was going to be the next step I suggested, so, even though it didn’t solve the problem, you are already a step ahead of what I was going to suggest. Once you installed the driver, you need to configure it so it will work properly with your corresponding graphics card. To do that, since you already have installed the driver and rebooted is to boot into your CLI. If you are on your graphical desktop, open a terminal window and issue the command init 3. This will close the X-Server and load the CLI. Please remember that all unsaved or open windows will be terminated. Once you are in the CLI, login as a normal user with your username and password and then login as root with the su command and your root password. Next, issue the command sax2 -r (notice the -r this time) and wait for Sax2 to load again. Once it loads, check to make sure the resolution and all are fine and then hit the OK button and then Save in the prompt. Now that we configured Sax2, we need to restart the X-Server. To do this, issue the command exit to remove the root permissions (or you will login as root when the server restarts) and then issue startx. Once this is all done, your graphics card (on the software-side) and Xorg will be configured with the ATI driver.

My other question is: do you have any desktop enhancers such as Compiz installed, or are you simply running the normal desktop. Also, which Desktop Environment are you running: Gnome, KDE3 or KDE4? I’m sorry this is taking so long without any result yet: just trying to remove any simple errors before going further. So, to that, thank you for your patience.

Hope this will fix it. :slight_smile:

Hi Unseen Ghost. What I will do is to boot into safe mode (since I can’t boot into normal mode) & enter into CLI. Then I will follow your steps. Pls let me know if this is incorrect. I will get on it when I am home tonight (it’s 8am now in SYD).

My desktop envir is GNOME as I’ve read somewhere that GNOME is simpler/better for dummies like me & SUSE has decided to go down this path. I don’t think I have installed KDE3/4. I think 4 is experimental & I will be nuts to play with it with my current level of expertise (or lack of it).

I so grateful for your help. Without help from those like yourself, I would have given this venture up.

I wrote this in a different thread. You are not the only one to experience this problem. Hope it helps:

This might help some. It’s an easy work-around in graphic mode.

  1. Get out of Gnome by pressing ctrl+alt+backspace. You may have to hold them down.
  2. At the login screen select a smaller window manager, not kde or gnome. Failsafe gnome doesn’t work either.
  3. Put in your name and password to get into the new desktop.
  4. Right click and open a file manager, and go to your home folder.
  5. Enable hidden files. Burrow down through .gconfig and apps til you find compiz.

Here’s what I did. I sent the compiz file to the trash.

Whether this is legit or not, after a necessary reboot to sort out nautilus, I found my system seems to be working as before, and the compiz file had regenerated itself, and I vowed never to try desktop effects again.
Reply With Quote

Hmmm…this is interesting. My whole issue came after I enabled 3D & desktop effects. I will try your way tonight & will post results.


Worked for me after a great deal of frustration with earlier attempts. Hope it works as easily for you.

Bustere, yeah I hope this works too. I am sure there is a workaround waiting to be discovered. Problem is something that works for one may not work for another. Have used SUSE (that is until I had this problem) for a week & it is great. My wife complains the time I spent on the darn machine but a man gotta have his habits !


Guys, I am giving up. This is too much for an accountant. I will reinstall my machine & the first thing I do is to use proper ATI driver & never enable 3D & desktop effects.

Keeping my fingers crossed this time.

Many thanks for your help.