No Display after 42.2 > 42.3 Upgrade

Downloaded 42.3 ISO to bootable USB stick. Upgrade performed flawlessly until the final operation configuring Grub2 …

Execution of command ""/usr/sbin/grub2-install","--target=i386pc","--force","--skip-fs-probe","/dev/sda"]]" failied

However i found the post here that says this is not a problem as system boots normally after the upgrade … which i can confirm!!

But, after displaying Grub menu and boot splash screen the system finishes with Black Displays (mouse pointer is visible and operational)… I have dual boot box with three displays … they all worked fine with 42.2 and windows but will not display following 42.3 upgrade. Windows still works however.

I have tried “Advanced options for 42.3” with same result …

nVidia under 42.2

Can somebody help me with this please.


Okay … so if i select “Advanced Options for 42.3” and choose the previous Kernel version (4.4.104-18-44-default) then the GUI is displayed on the monitors!!

However, choosing the new kernel just produces a black screen with a live mouse pointer.

Can somebody lead me from here?


Graphics card info:

hwinfo --gfxcard
20: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.IHvBfGXgDoC
  Parent ID: vSkL.hCwIhm6dY1F
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GK106 [GeForce GTX 650 Ti]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x11c6 "GK106 [GeForce GTX 650 Ti]"
  SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
  SubDevice: pci 0x3554 
  Revision: 0xa1
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable,disabled)
  IRQ: 35 (26214 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd000011C6sv00001458sd00003554bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"                                                                                                                                       
  Driver Info #1:                                                                                                                                                                   
    Driver Status: nvidia_drm is active                                                                                                                                             
    Driver Activation Cmd: "modprobe nvidia_drm"                                                                                                                                    
  Driver Info #2:                                                                                                                                                                   
    Driver Status: nvidia is active                                                                                                                                                 
    Driver Activation Cmd: "modprobe nvidia"                                                                                                                                        
  Config Status: cfg=no, avail=yes, need=no, active=unknown                                                                                                                         
  Attached to: #8 (PCI bridge)                                                                                                                                                      
Primary display adapter: #20 


Boot system under old kernel > yast > software > search ‘nvidia’ > force upgrade to later version of drivers available.

384.11-3.1 (Installed)
390.48-6.1 (available)

Reboot using latest kernel!