No desktop on boot

Yesterday I I rebooted ny PC and failed to get a desktop. I discovered that someone else, running 13.2, had had the same problem and had posted about this in this forum. It appeared to be the same problem and the solution was simple, so I tried the same thing. However, I have got myself into problems.

The problem that the OP in this thread had was an error on the nvidia driver. S/he was advised to reinstall certain modules. I attempted the same, using the LEAP 42.1 repos rather than the 13.2 ones (naturally), but then hit this bug, that the metadata for the repo is wrong. I therefore cannot reinstall.

I was advised to remove the driver completely, just to get the desktop. However, Whenever I try to remove the module nvidia-gfxG04-kmp-pv Yast attempts to install nvidia-gfxG04-kmp-default. It can’t do this because it can’t access the repository.

I am now stuck. How can I proceed?

If you mark all nvidia packages for removal at the same time, it should not want to install that any more.

Or run:

sudo rpm -e x11-video-nvidiaG04 nvidia-gfxG04-kmp-default nvidia-glG04 nvidia-computeG04

Instead of waiting until the repo is fixed, you could also download and install the packages manually after you removed the current ones:

Download the 4 G04 packages (x11-video-nvidiaG04 nvidia-gfxG04-kmp-default nvidia-glG04 nvidia-computeG04), and then run:

sudo rpm -i x11-video-nvidiaG04-361.42-21.1.x86_64.rpm nvidia-gfxG04-kmp-default-361.42_k4.1.12_1-21.1.x86_64.rpm nvidia-glG04-361.42-21.1.x86_64.rpm nvidia-computeG04-361.42-21.1.x86_64.rpm

Or just copy/paste this command, this will download and install them:

sudo rpm -i
zypper if nvidia
Loading repository data...
Reading installed packages...

package 'nvidia' not found.
sidro@home:~> zypper if x11-video-nvidiaG04
Loading repository data...
Reading installed packages...

Information for package x11-video-nvidiaG04:
Repository: nVidia Graphics Drivers
Name: x11-video-nvidiaG04
Version: 367.18-25.1
Arch: x86_64
Vendor: obs://
Installed: Yes
Status: out-of-date (version 361.42-21.1 installed)
Installed Size: 174.6 MiB
Summary: NVIDIA graphics driver for GeForce 400 series and newer
  NVIDIA graphics driver for GeForce 400 series and newer

Zypper report

Name: x11-video-nvidiaG04
Version: 367.18-25.1

as last driver.
But repo don’t have that version. Repo version 361.42-21.1 .

What is wrong ?

Nothing is wrong.

As explained, the packages in the nvidia repo have been reverted to the older version 361.42 because of the problems with the new packages.
You already have the new ones (367.18) installed though. so “zypper info” shows that version.

Revert all nvidia packages to the 361.42 versions from the repo, and your problem should be fixed.

I.e. uninstall all nvidia packages, and then install the driver again from the repo, as I already wrote.

I have installed version
Status: out-of-date (version 361.42-21.1 installed)
Version: 367.18-25.1

What you say it is wrong.

zypper up
Loading repository data...
Reading installed packages...

The following 19 package updates will NOT be installed:
  ethtool gstreamer-0_10-plugin-esd gstreamer-0_10-plugin-gnomevfs iputils libpcap1 librtmp1 libxml++-2_6-2 netcat-openbsd net-tools openslp python-beautifulsoup steam tcpdump
  telnet traceroute vlan wget xinetd youtube-dl

The following 4 packages are going to be upgraded:
  nvidia-computeG04 nvidia-gfxG04-kmp-default nvidia-glG04 x11-video-nvidiaG04

4 packages to upgrade.
Overall download size: 84.4 MiB. Already cached: 0 B. After the operation, additional 10.9 MiB will be used.
Continue? [y/n/? shows all options] (y): d

The following 19 package updates will NOT be installed:
  ethtool                         4.5-62.1             x86_64  network:utilities  obs://     
  gstreamer-0_10-plugin-esd       0.10.31-89.2         x86_64  packman                    
  gstreamer-0_10-plugin-gnomevfs  0.10.36-16.1         x86_64  packman                    
  iputils                         s20160308-70.1       x86_64  network:utilities  obs://     
  libpcap1                        1.7.3-61.1           x86_64  network:utilities  obs://     
  librtmp1                        2.4+git20150115-3.1  x86_64  games:tools        obs://           
  libxml++-2_6-2                  2.40.1-3.1           x86_64  packman                    
  netcat-openbsd                  1.89-108.1           x86_64  network:utilities  obs://     
  net-tools                       1.60-815.1           x86_64  network:utilities  obs://     
  openslp                         2.0.0-414.1          x86_64  network:utilities  obs://     
  python-beautifulsoup            3.2.1-23.2           noarch  network:utilities  obs://
  steam                          x86_64  games:tools        obs://           
  tcpdump                         4.7.4-42.1           x86_64  network:utilities  obs://     
  telnet                          1.2-325.1            x86_64  network:utilities  obs://     
  traceroute                      2.0.21-13.1          x86_64  network:utilities  obs://     
  vlan                            1.9-265.1            x86_64  network:utilities  obs://     
  wget                            1.18-80.1            x86_64  network:utilities  obs://     
  xinetd                          2.3.15-210.1         x86_64  network:utilities  obs://     
  youtube-dl                      2016.06.03-329.1     noarch  packman                    

The following 4 packages are going to be upgraded:
  nvidia-computeG04          361.42-21.1 -> 367.18-25.1                      x86_64  nVidia Graphics Drivers  obs://
  nvidia-gfxG04-kmp-default  361.42_k4.1.12_1-21.1 -> 367.18_k4.1.12_1-25.1  x86_64  nVidia Graphics Drivers  obs://
  nvidia-glG04               361.42-21.1 -> 367.18-25.1                      x86_64  nVidia Graphics Drivers  obs://
  x11-video-nvidiaG04        361.42-21.1 -> 367.18-25.1                      x86_64  nVidia Graphics Drivers  obs://

4 packages to upgrade.
Overall download size: 84.4 MiB. Already cached: 0 B. After the operation, additional 10.9 MiB will be used.
Continue? [y/n/? shows all options] (y): y
Retrieving package nvidia-gfxG04-kmp-default-367.18_k4.1.12_1-25.1.x86_64                                                                      (1/4),   5.8 MiB ( 65.8 MiB unpacked)
Retrieving: nvidia-gfxG04-kmp-default-367.18_k4.1.12_1-25.1.x86_64.rpm ......................................................................................................[error]
File './x86_64/nvidia-gfxG04-kmp-default-367.18_k4.1.12_1-25.1.x86_64.rpm' not found on medium ''

Abort, retry, ignore? [a/r/i/? shows all options] (a): 

Unfortunately the machine with the error is not the machine which I’m running my browser on! But I managed to transfer the commands over via Dropbox. I then realised I didn’t know how to copy and paste commands from a file in command mode, so I had to type the commands. I managed to get the install command right after it failed due to three(!) typos.

However, I still don’t have a desktop after the nividia drivers have been reinstalled.

Any further suggestions?

The problem was that it tells me that various things that I tried to install conflict with nvidia-glG04-367.18-25.1.x86_64.

How do I get rid of this?

All right.
I mixed up your output.

But as I wrote already, the driver in the repo has been reverted to 361.42 (have a look at, but the repo’s metadata is outdated and still lists 367.18 (which is not there).
IOW, the nvidia repo is broken currently, you/we have to wait until NVidia fix that.

Again, uninstall the driver completely and you should get a desktop.

You should uninstall nvidia-glG04-367.18 as well and replace it with 361.42 (I did include it in my posts), the nvidia packages all have to be the same version of course.

I perhaps should have said. I did try to uninstall nvidia-glG04 but various other things are dependent on it, so it won’t uninstall. I’m beginning to have bad feelings about this.

Nothing should depend on nvidia-glG04 directly.

But maybe you don’t have some Mesa packages installed?
Verify that Mesa-libGL1, Mesa-libEGL1 and Mesa-libLES2-2 are installed, and maybe you need the -32bit variants too.

Or use YaST or zypper to uninstall all nvidia packages, they should install missing dependencies automatically.

sudo zypper rm nvidia-gfxG04-kmp-default x11-video-nvidiaG04 nvidia-computeG04 nvidia-glG04

If you want/need further help, you’d have to post the dependency problems though.

OTOH, you could just ignore the dependencies, if you reinstall the driver immediately before rebooting:

sudo rpm -e --nodeps nvidia-gfxG04-kmp-default x11-video-nvidiaG04 nvidia-computeG04 nvidia-glG04

If you have removed the nvidia drivers you need to un-blacklist nouveau.

Is there a nvidia file in /etc/modprobe.d
which is blacklisting nouveau?

If so, delete it and then run mkinitrd and reboot.

The blacklist file that is contained in the nvidia packages will be removed when you uninstall the nvidia packages.

So unless you created another one yourself, there’s no further action necessary.

I don’t have time at the moment to try these, so here are the dependencies for you to think about: is needed by lincairo-32bit, libdirecttfb, libstgl is needed by libcairo2-32bit, libGLU1-32bit, libgstgl-1_0-0-32bit, gstreamer-plugins-bad-32bit is needed by libdirectfb-1_7-1-32bit (64bit) is needed by libdirectfb-1_7-1-1, gstreamer-plugins-bad-1

(I’ve omitted version numbers for readability and speed of typing)

Does this help thinking about a workaround?

As I suspected.
Install the packages Mesa-libGL1-32bit, Mesa-libEGL1-32bit, and Mesa-libGLESv2-2-32bit and you should be able to uninstall nvidia-glG04.

The 32bit libraries are not installed (and not needed) by default. You probably installed some 32bit applications after installing the nvidia driver, and as nvidia-glG04 contains nvidia’s replacements for this (also the 32bit versions for 32bit software), so the Mesa libs didn’t get installed and the dependencies are not satisfied if you remove nividia-glG04.

Thanks. I did this, then tried to uninstall nvidia-GL04. It failed because (64bit) was still needed, so I took a guess at what else to install. After this I uninstalled nvidia-GL04 successfully. I then installed the versions of the packages you specified earlier. This came up with various modules that could not be installed because such and such was missing, but there was also a message to say this wasn’t necessarily an error.

After completion, I rebooted - but still no desktop.

So is there some other diagnostic I could run?

Can’t do any harm to provide this information:

sudo rpm -e --nodeps nvidia-gfxG04-kmp-default x11-video-nvidiaG04 nvidia-computeG04 nvidia-glG04

gives the output and the error messages

sudo rpm -i

gives the output and the error messages

Adding my name to the users affected by this bug. Leap 42.1. Identical symptoms. Black screen on boot. Required dropping to CLI.

I followed instructions to use zypper to remove nvidia packages. Several 32 bit applications - including mplayer, gstreamer components and Steam - were forced to be deleted.

Upon reboot, system reverted to Nouveau2 driver.

You need to install the Mesa 32bit libraries for 32bit applications: Mesa-libGl1-32bit, Mesa-libEGL1-32bit, Mesa-libGLESv2-2-32bit

The nvidia 64bit packages do include the 32bit versions…
So if you installed those applications after you installed the nvidia driver, they won’t pull in Mesa’s 32bit packages.
If you install them without the nvidia drivers present, the necessary Mesa packages will be installed automatically too.

But MPlayer is available as 64bit version, why did you have the 32bit one?

You should be able to install the nvidia driver again though.
The repo has been fixed meanwhile, and the bug in the packages should be fixed as well.