No desktop graphics after update from 13.2


I’ve installed Leap today quite unintentionally. I’ve probably added some repo I was unaware of (I’m not too savy regarding operatng systems) and, after an update that looked like the usual ones (only invloving a lot more files), I’ve discovered I had a completely new login screen and distro (I hope I’m using the term correctly).

Unfortunately I couldn’t login to this new distro and some error regarding kde4 (missing?) was returned to me.
I restarted the system and I only got some command line screen (a pink one!), but not the usual desktop manager with icons and menus and everything.
Starting applications from this command line is possible. I have not found out how to close them though, since the top line of the window, the one containing the little x, is missing and alt-F4 doesn’t seem to work.

Loggin as administrator also works.

Wireless doesn’t work, probably because of kdewallet, but hopefully I’ll be able to connect through a line.

I understand Leap is using plasma 5 (which I’m anxious to try but I could live without it perfectly fine as well).

Is there any solution to my problem, be it fixing the Leap or reversing to the 13.2, other deleting and reinstalling everything?

Thank you.


First have to know exactly what you did and exactly what repos you are subscribed to and why you think you run Leap???

zypper lr -d will list the repos

You should avoid logging into a GUI as root, you can damge your system. But at this point you probably can not do too much more damage then already done :open_mouth:


It says Suse Leap in the grub menu.

The repos, i’ll list the names only, as i’m writing on phone:

  2. Games
  3. devel:languages:R: patched
  4. devel:languages: haskell
  5. devel:languages: pascal
  6. (Packman)
  7. games
  8. home: Ximi1970: openSUSE:Extra
  9. home: dmacvicar
  10. openSUSE13.1
  11. opensuse: Leap:42.1
  12. repo-debug
  13. repo-debug-update
  14. repo-debug-update-non-oss
  15. repo-non-oss
  16. repo-oss
  17. repo-source
  18. repo-update
  19. repo-update-non-oss

All except nos 10, 12, 13, 14, 17 are enabled.
I probablu added the leap repo as requested for the instalation of some graphical theme (maybe), for I sure had no idea what Leap was until today.

Networking: I’ve connected the Pc to the phone for USB tethering, but i don’t know what command I must 3nter to enable networking (tethering on the phone is enabled).

Thank you.

Does booting with ‘nomodest’ in the grub advanced menu help ? I think to do this, when the grub menu appears, one presses ‘e’ and then navigates to the appropriate boot line in the text presentation of grub, add ‘nomodest’ to the end, and then press the appropriate key (guidance on bottom of that grub page) to boot.

My understanding is setting nomodest will disable the kernels automatic mode setting for graphics, and a lower functionality graphic driver will boot instead (it varies dependant on your PC graphic hardware) and that may get you to a stable desktop such that you can figure out the problem. If/when you reach a stable desktop, if it were me, I would disable special desktop effects as a start (in kde5/plasma5, assuming you installed that), and then try a reboot without nomodeset.

Hello oldcpu

I’ve tried starting with nomodset ( I’ve found it on the recovery entries), but I got the same result: a pink/violet console screen in the top left corner of the display.

I’ll define my problem more exactly: the KDE graphical interface is missing on startup.

I’ve managed to start something similar to the 13.2 GUI with the command *plasma-desktop *but it seems corrupt: the program windows are missing the top line with the closed button on it, kde-wallet doesn’t start when trying to connect to wi-fi, *shutdown *button not working etc.
The pink/violet console screen remains on after this GUI appears.

*YAST *starts from the command line, but with a different GUI. I haven’t tried zypper yet, but I’m expecting it’ll work.

I’ll get a LAN cable later and try to update packages (i hope this is the right thing to do) , but I’m not sure what should I do regarding the suse repos.

If connecting through LAN won’t work, is it possible to repair the installation from an USB and keep all my programs and configuration?

Thank you.

Sounds like you are logged into twm, a fallback window manager.

Logout (click somewhere on the desktop) and you should get back to the Login screen.
You should be able to select KDE or “Plasma 5” there.
Does KDE start then?

Hi wolfi323

Logging out from command line worked. I got to the login screen with the small lizard inside the lightbulb.

I’ve selected *plasma desktop *from the small controls button in the bottom left corner of the screen, tried to log in and received the message:

*could not start kdeinit4, check your installation

*I’ve tried all the other options in that little control menu at the login, none worked: some return the kdeinit4 error, at least one of them gives me the pink screen.

Does it look like no plasma or kde thing is installed on my computer?

Thank you.

Ok. that indicates that you indeed “upgraded” to Leap.

I’ve selected *plasma desktop *from the small controls button in the bottom left corner of the screen, tried to log in and received the message:

*could not start kdeinit4, check your installation

This likely indicates an incomplete upgrade.
And that’s no surprise. The standard updater is not designed to upgrade to a different openSUSE version.

You should remove/disable all non-Leap repos, and run “zypper dup” (or boot from an installation medium and select “Upgrade” in the boot menu).
This should also fix your system.

The opposite should also work: remove the Leap repos (and readd back the 13.2 ones if necessary), and run “zypper dup” should switch you back to a (hopefully working) 13.2 system.

For further advise, please post your detailed repo list though.
The one you posted is useless, as it only contains names which could mean anything.

zypper lr -d

Problem solved.

Got to a LAN line, removed the repos of the distros except 13.2 (I used suse wiki for that) and upgraded with zypper.

Everything’s back to normal, except for the fact that I’ve lost the widgets I’ve had on the 13.2.

I’m left with the Leap wallpaper though :smiley:
It looks like oneday I’ll have to Leap if only for that :slight_smile:

Thank you all.