No CUPS daemon

When I start Yast -> Hardware -> Printer, I immediately get a dialog asking me to ‘Restart local running CUPS daemon’; I clidk 'Yes" and the dialog waits for 30 seconds for the daemon to stabilize. This is followed by another error dialog stating that ‘no local running CUPS daemon is accessible’. Another dialog then appears suggesting that I run ‘lpstat -h localhost -r’ to see if there’s a local cupsd accessible. Running this gives:

lpstat -h localhost -r
lpstat: Unable to connect to server

There is a cupsd running, however:

ps -A | grep cupsd
4542 ?        00:00:00 cupsd

The firewall has cupsd activated as an allowed local service.

I’ve never run across this problem in the past. I’ll note that I installed opensuse without a printer connected, and am now trying to add it.

This is an i7 64-bit machine; printer is an Epson cx7800 multipurpose machine (USB) which has worked flawlessly under several versions of opensuse, from 10.1 through 11.1 on my old 32-bit machine.

So far, I’ve tried reinstalling all of the CUPS packages; various combinations of printer on/printer off/hot plugging; many reboots. But the problem isn’t budging.

Any help would be appreciated.

Note: also noticed that Yast -> Hardware -> Hardware Information shows the printer correctly identified as a USB Stylus CX7800 device. The problem seems to lie in the configuration tool or with the way CUPS is set up.

Never mind - fixed the problem.

I saw some messages in the cups error log indicating that cups wasn’t able to listen via ipv6. I had turned this off in Network Settings, but apparently cups needs it. Odd, since it successfully reports that it is able to listen via ivp4. But turning ipv6 back on got printing working again.

Maybe what’s happening is that you have the line:

::1             localhost ipv6-localhost ipv6-loopback

in /etc/hosts so lpstat is trying to use IPv6 to contact CUPS. (A lot of apps are IPv6 ready.) If you comment out that line and disable IPv6 in CUPS that should also work.

Good to know. For now, I’m just leaving ivp6 on. I turned it off to see if I got any speed improvements, but I’m not seeing anything noticeable.

Hi, I have just had the same problem trying to set up two new machines. Strange because I never had this problem before. I have noticed in the past a very significant drop in speed with ipv6 enabled so have it turned off on other machines and did the same with the two new installations but then found I couldn’t install a printer.
Having read this thread I turned it on and now cupsd can at least build database.
So thanks for the posting but no thanks to Opensuse for failing to explain that these changes have been made.