No connection, what so ever

Hi all,

I do have some problems with my NIC. It is installed according to suse, so i went to configure my NIC and connection for internet. But it didn’t work. My question is, how do i solve this?

NOTE: I have no connection to internet whatsoever! If you want to know why, read on.

What did i do?:

  • Google (your best friend, so they say): no result
  • SUSE WIKI: Some usefull tutorials but with no internet connection, pretty hard to do, well for a newbie that is.
  • Manually configured using YaST (no networkmanager): result: no internet connection
  • Manually configured using Knetworkmanager: no internet connection. (networkmanager seems to lose my settings after saving!)

What do i have?:

  • Opensuse 11.1
  • ICIDU wireless NIC with an atheros chipset (AR5005G, although suse is saying AR2413G in hardware information)

Modules installed:

  • ath5k (kernel driver)

What does your network look like?

  • Linksys router
  • WPA2 (personal) encryption
    (if possible MAC filtering)

I’d love some help with this. Some tutorials are very usefull but without a connection, hard to follow.

Thanks in advance.

Did you read these 2 links:
My wireless doesn’t work - a primer on what I should do next - openSUSE Forums
Getting Your Wireless to Work - openSUSE Forums

I read the second one but that didn’t work. Somehow networkmanager doesn’t save my settings :-S.

I’m reading the first article now :slight_smile:

Read the second once again, especially the third Posting.

Ok, i’m done now. From what i understand is there is a APIPA adress assigned to my networkcard, but how do i change this? I didn’t see it in network manager nor YaST.

This is what i get:

!!! CND0210W: APIPA IP address detected on network card wlan0
!!! CND0140E: No default gateway set on your system

Where do i find these settings? I tried it with networkmanager and YaST but still no result :frowning:

Read the next few lines following the output you cited here.

I read the information but i don’t have network devices, only settings. Although i can configure my device in YaST, still it is a little unclear where to fill out the addresses such as DHCP, Subnet mask and the default gateway.

I do not know how i did it but i’m finally online rotfl!rotfl!rotfl!

I ajusted the router settings and my guess is the SSID. Anyway, thanks for the help. Now i’m connected and eager to learn more and maybe to help others someday ;-).

well done;enjoy OpenSuse;

some folks find it helpful to keep a notepad by the computer and jot down “wizard fixes”; for future recall!