No calibre available???

I have regularly used calibre for ebooks but after upgrade to 15.4 there is no calibre available. It seems to be there for Tumbleweed and for Leap15.3. Why is that? Will it be available again at some stage?

You can look at the discussion in Bug 1198299

Thank you, nrickert and Sauerland. I had a look at this calibre4 - it seems to require that you add approx 15 more repositories. I find it strange that there is no official version since I thought this is a very common software. But then I am no developer and I don’t understand enough about this building up of software with all its dependencies. I am reluctant to use that version which adds all these repositories because I see problems coming up later. Does anyone know if there will there be an official version in the not too distant future? It seems to be no problem with Tumbleweed.

Did you check out the Flatpak version of calibre?

I confess (and I am embarrassed to admit) I tried out Flatpak for the first time today, to install ‘freefilesync’ (not in any of the zypper accessible repos) and also ‘signal’ (which while available wanted to add over 1/2 dozen additional repositories).

If you use FlatPak, you will have to add a repos to it. There are instructions here:

Once you have that repos added to FlatPak, you can install ‘calibre’ easily (I suspect) with either FlatPak from the command line, or using ‘Discover’ package manager (where I think < not sure > Discover comes with kde).

My very fuzzy understanding is FlatPak sets up a container in which applications can much easier be installed across multiple GNU/Linux distributions.

… and for all who know more than me on this topic (as I concede I am only learning here) feel free to chime in and correct the above. Your chiming in to correct is appreciated to fix my lagging knowledge.

Thank you, oldcpu, so far I avoided flatpack or similar packages but may be it is time to have a closer look.

From the calibre website

Download for Linux

The latest release of calibre is 6.1.0. What’s new.

Please do not use your distribution provided calibre package, as those are often buggy/outdated. Instead use the Binary install described below.
Binary install

calibre has a binary install that includes private versions of all its dependencies. It runs on 32-bit and 64-bit Intel compatible machines. To install or upgrade, simply copy paste the following command into a terminal and press Enter:

sudo -v && wget -nv -O- | sudo sh /dev/stdin

While you wait for the download to complete, please consider contributing to support the development of calibre.

I have followed the above instructions for years, and it always works. Don’t forget the last item.

Thank you, crmrhm, this worked well. Cheers

I did this in order to see what it was doing

**aldebaran:/tmp #** wget  
--2022-10-16 20:55:59-- 
Resolving (, 2001:41d0:800:2764:: 
Connecting to (||:443... connected. 
HTTP request sent, awaiting response... 200 OK 
Length: 33493 (33K) [application/x-sh] 
Saving to: ''             100%=================================================>]  32.71K  --.-KB/s    in 0.04s    

2022-10-16 20:55:59 (922 KB/s) - '' saved [33493/33493] 

**aldebaran:/tmp #** chmod +x ./ 

**aldebaran:/tmp #** ./          
Using python executable: /usr/bin/python3 
WARNING: Your current umask disallows reading of files by some users, this can cause system breakage when running the ins
taller because of bugs in common system utilities.  
Should the installer (f)ix the umask, (i)gnore it or (a)bort [f/i/a Default is abort]:  
The system umask is unsuitable, aborting 
**aldebaran:/tmp #**

I’m not sure if it is I have something misconfigured, but the warning seems a bit scaring.

I installed it but before I was using calibre-server launched from a script at boot time, but the flatpak version seem not to install calibre-server, you just have to open the gui and launch the server from it. I’m looking for a way to launch calibre server without gui

I do not know cailbre, but when you install something with flatpak, it is installed by the user for the user in the users disk space (within his/her home directory), you didn’t need the root password didn’t you?. Thus of course there is no system service to be started at boot. That should not be a surprise.

No, you can install it user or system wide

I doubt that flatpak is intelligent enough to know about how the system works and configure systemd, etc. And that is contrary to what Flatpak is for:

It is advertised as offering a sandbox environment in which users can run application software in isolation from the rest of the system

When you install flatpak you have two ways of setting it up, it is in the opensuse wiki, user level and system level, maybe if you setup the user level you have the sandbox environment and in the system level you haven’t, but the two ways exist.
Anyway I wouldn’t need changes to systemd, not even installing it system wide, as far as I know a daemon can be run by any user, you just have to launch it without a GUI, yo can do in your local crontab or even in the system crontab specifying the user who runs the daemon.

I would not call that a daemon, but basically your are right. A user can start a background program e.g. with cron