"no bootable device found" Toshiba Satellite

The Toshiba Satellite laptop series seem to have the problem, that their UEFI does not regard an openSUSE partition as bootable. To start my openSUSE session I therefor first need to insert an installation cd, “upgrade” my system and then reboot. The “upgrade” seems to do something with the partition that shows the UEFI that it is bootable. When I just restart, without this process, I get the message “no bootable device found” and I have to turn of the machine.
Since the upgrade clearly does something with the partition, is it possible to make this change durable and without “upgrading” every time?

There was a long running thread from last year, about problems with UEFI on a particular Toshiba. Yours might have the same problem.

I’ll note that the message says “no bootable device” rather than “no bootable partition”.

1: Do you have Windows or other system installed? (I’m guessing not, or it would boot Windows every time).

2: Can you boot the system with recovery media (or the install media in repair mode)?

3: If you can, then I am interested in:

The partitioning

# parted -l

What’s on the EFI partition. It probably contains a directory “/EFI/opensuse”. A list if files there could be useful. It possibly also contains a directory “/EFI/Boot” (maybe different capitalization). A list of what is there would also be useful.

Well First are you trying to multi boot ie Windows and Linux

If this is EFI bios then the install media should be booted in EFI mode ( note you may need to select this in the BIOS boot menu F12 maybe but depends, check owners manual)

This should install grub2-efi as the boot program and the EFI boot partition (small FAT partition) should be marked to mount as /boot/efi

Afterwords the efi boot partition should have a opensuse directory

Also the opensuse boot should be listed in the BIOS boot menu as an option. And you should be able to set it as default

It is probably best to turn secure boot off in the BIOS to avoid that complication

Note if you tried for a MBR/DOS partitions format on a drive that has had GPT it can lead to odd problems unless you first at least wipe the first track

Some EFI BIOS seem to want to only boot to Windows there is a way to trick it if this is the situation

This not a Multi Boot, however it used to be. At that time, I booted into Windows first, selected “openSUSE device”, and then only could reboot into grub. What probably is missing is the mounting point for openSUSE, since it does not load the grub menu, which would make sense because I can recover the system after an “upgrade” from an openSUSE Installer. The Toshiba Bios is very restrictive, so I don’t have many options there. Secure boot has aleays been turned off.

The partitioning is as follows:

Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags
 1      1049kB  165MB   164MB   fat16           primary  boot
 2      165MB   2319MB  2155MB  linux-swap(v1)  primary
 3      2319MB  23.8GB  21.5GB  btrfs           primary
 4      23.8GB  1000GB  976GB   btrfs           primary

Thanks for posting that.

Your EFI partition will be “/dev/sda1”.

If you can boot from recovery media again, then try:

# mount /dev/sda1 /mnt
# ls -R /mnt

That should list what is in the EFI partition.

My guess is that you will find:


and a bunch of files in the “/EFI/opensuse” directory.

And probably nothing else.

So try:

# mkdir /mnt/EFI/Boot

If that directory already exists and not empty, list its content (post here), and ignore the rest of this comment until I have had time to see what is there.

If that directory does not already exist, then create it as shown. And then:

# cd /mnt/EFI/Boot
# cp -p ../opensuse/* .

That copies the opensuse directory to the Boot directory.


If there is a file “shim.efi”, then

# mv shim.efi bootx64.efi

Otherwise (no shim.efi),

# mv grubx64.efi bootx64.efi 

and then check whether that makes your system bootable.

That worked beautifully! Thank you for your help.

I’m glad it worked.

What is happening, is that apparently Toshiba has an incomplete implementation of UEFI. They are fixated on booting devices rather than operating systems.

What those changes did, is set you system up so that when there is no configured UEFI operating system, an attempt to boot the device will work.

If there are update to grub2-efi, you may have to repeat that copy from the “opensuse” subdirectory to the “Boot” subdirectory. And follow that with the same renaming.