No boot without nomodeset in kernel params

I have an HP ProBook 4720s that has an onboard Intel vcard and a distinct ATI Radeon HD 7550M.
Until 2 weeks ago I was using OpenSUSE Leap 42.1 64-bit (upgraded from openSUSE 13.2). Everything worked fine (can’t remember if I had additional kernel params at boot).

I did a fresh install of OpenSUSE Leap 42.2 64-bit and the boot sequence stops right after entering the LUKS password.
With nomodeset in the kernel params everything works fine except the recovery from suspend to RAM - the screen never lights up and I must do a hard reboot (which I don’t like given that the system is installed on a SSD). When booting with nomodeset I see the error “No UMS support in radeon module” and this might be the cause of the improper suspend recovery.
If I remove the “nomodeset”, the boot stops after message “[drm:cpt_irq_handler [i915]] *ERROR PCI transcoder a FIFO underrun”. Ctrl+ Alt+F1 or F2 doesn’t do anything - I just have a blinking cursor on a new line and that’s it.

I’m not using UEFI and I have most of the partitions encripted with LUKS. I’m also using KDE (KDE Plasma 5.8.3, KDE framworks 5.26.0, Qt version 5.9.1, kernel 4.4.49-16-default).
One kernel param I added was mem=17G - to make sure it supports 16GB RAM (found the fix on HP forum)

video-related section from xorg log is here

Some additional information:
With or without nomodeset in kernel params at boot time, the errors are displayed before the password popup for LUKS. I disabled the mei and mei_me modules per but it didn’t fix the suspend recovery issue (system booted with nomodeset in kernel params). After KDE login the ATI video card runs hot and I can hear the fan running full speed (not sure if it’s related). Somehow the ATI video card is heavily used/ gets hot even if I only have Firefox, one instance of Dolphin, one instance of Visual Studio Code and one Konsole.

$hwinfo --gfxcard
root’s password:
09: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: _Znp.qTfIAMnfqxD
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Device Name: “64”
Model: “Intel 3rd Gen Core processor Graphics Controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x0166 “3rd Gen Core processor Graphics Controller”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x17f4
Revision: 0x09
Memory Range: 0xd0000000-0xd03fffff (rw,non-prefetchable)
Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
I/O Ports: 0x4000-0x403f (rw)
IRQ: 10 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00008086d00000166sv0000103Csd000017F4bc03sc00i00”
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: “modprobe i915”
Config Status: cfg=no, avail=yes, need=no, active=unknown

21: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: VCu0.HK01eKAEHX3
Parent ID: vSkL.1srPvP0E61F
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “Hewlett-Packard Company Radeon HD 7650M”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x6841 “Thames [Radeon HD 7550M/7570M/7650M]”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x17f4 “Radeon HD 7650M”
Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable,disabled)
Memory Range: 0xd0900000-0xd091ffff (rw,non-prefetchable,disabled)
I/O Ports: 0x3000-0x3fff (rw,disabled)
Memory Range: 0xd0920000-0xd093ffff (ro,non-prefetchable,disabled)
IRQ: 10 (no events)
Module Alias: “pci:v00001002d00006841sv0000103Csd000017F4bc03sc00i00”
Driver Info #0:
Driver Status: radeon is not active
Driver Activation Cmd: “modprobe radeon”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #8 (PCI bridge)

Primary display adapter: #9

Your hwinfo output shows hybrid graphics (AMD/Intel), so will need input from users who are familiar with this graphics setup.

This thread may be of interest to you…

I’ve looked again at the suspend problem.
With nomodeset, The framebuffer or the vesa driver is loaded and the suspend doesn’t work.
Without nomodeset and without splash=silent both intel and radeon drivers are loaded and the suspend does work.

In the resolution list returned by vbeinfo commend there is also the current panel resolution which is 1600x900. I also tried different kernel params like i915.modeset=1, modeset=1, vga=normal, nofb, video=vesafb:off, i915.modeset=0, acpi_backlight=vendor - none allowed the boot process to succeed.
At one time I added debug=all and the boot process stopped after identifying the thermal zones.

I’m not sure what’s not working here and what could be the proper kernel parameter for successful boot but right now I’m stuck with 2 options:

  1. boot in text mode (remove the splash=silent and nomodeset params)
  2. configure XServer as discussed in the previous-mentioned topic - i haven’t tried if DRI3 setting would work with the current server; an upgrade as suggested in the topic might break vmware workstation and it’s a risk I don’t want to take.