No boot with kernel 6.2

@suse_rasputin add the version to the multiversion.kernels section in /etc/zypp/zypp.conf.

1 Like

Malcoms tip can also be found by typing “how to lock the kernel” into the forum search:

As usual - boot without “quiet” and with “plymouth.enable=0” on kernel command line. It may provide some information what happens.

1 Like

Here we go:

…while dmesg of successfull boot with kernel 6.1.12 looks like this

uname -a
Linux dell2TW062021 6.1.12-1-default #1 SMP PREEMPT_DYNAMIC Wed Feb 15 05:31:41 UTC 2023 (373f017) x86_64 x86_64 x86_64 GNU/Linux

so the line in zypp.conf looks now like

multiversion.kernels = latest,latest-1,running,6.1.12-1-default

will that keep kernel 6.1.12 for future zypper dups with new 6.2 kernels? :slight_smile:

@suse_rasputin You need to use the full version number from zypper se -si kernel-default

1 Like
zypper se -si kernel-default
Loading repository data...
Reading installed packages...

S  | Name           | Type    | Version    | Arch   | Repository
i+ | kernel-default | package | 6.1.12-1.1 | x86_64 | (System Packages)
i+ | kernel-default | package | 6.2.1-1.1  | x86_64 | openSUSE-Tumbleweed-Oss

so now it reads

multiversion.kernels = latest,latest-1,running,6.1.12-1.1

Correct now? :slight_smile:

@suse_rasputin yes, that looks better.

1 Like

…I found that MESA-dri-nouveau was still installed (but not xf86-nouveau), removed the MESA thing and rebooted, didn’t change much

btw. the system is really, really hung up at this point, power button not working, only way to interact is REISUB…

Other point: Is it possible to make the working 6.1.12 kernel the default for booting?

@suse_rasputin sure, via YaST Bootloader, last tab on right, change in the drop down.

1 Like

Not sure if this helps anything but Arch has the same Problem with 6.2
Only when dualbooting and only if the Bootloader is not from Arch. I can’t explain more as I am not a tech person. Just search for “Arch 6.2 boot problem”. Also Brodie Robertson on Youtube has a short video about it (latest Video as of March 8)

I don’t know if openSUSE did the same with Kernel 6.2

Still no new 6.2 kernel in TW here. Am I the only one with related problems (with NVIDIA graphics and no UEFI/secure boot)?

May be (at least only one having this particular combination that triggers thus problem). Have you opened bug report?

@suse_rasputin as a Tumbleweed user you should be following the Factory Mailing list, new details there today…

1 Like

Nope, just a dumb user here…

I don’t get it, lockdown patches or what?!? :slight_smile:

So the 6.2.1 kernel didn’t work for you, introduction of lockdown patches, secure boot, legacy boot, but the previous kernel works, kernel 6.2.2 removes the lockdown patches, so should be the same as the 6.1.12.

Once 6.2.2 rolls around and still not working (so any lockdown patching is not the issue), then can create a bug report…

many thanks, malcolm, let’s wait’n see…

Kernel 6.2.2 installed via zypper dup, rebooted, system hangs on the absolute same time in very early boot, waiting some minutes doesn’t help.