no boot when IDE drives plugged

Hi all,

I assembled the PC myself,
and it did run without any problems under openSUSE 12.1 and 12.3, and win7,
for about one and a half years - without the IDE drives plugged.

During that time it had a PCI card plugged - a SCSI adapter ADAPTEC AHA2940U2W -
which connected a CD-writer attached by the SCSI bus.
No problem.

For that PC I once selected the motherboard ASUS P8H67-V (capable of UEFI booting),
for a reason.

This motherboard still/or again had an IDE bus,
which I in fact intended to use for the IDE devices now just plugged:
Yamaha CRW 3200E, and
NEC DVD_RW ND-4570A

Until they were moved to this PC these devices worked very well under openSUSE 12.3
in an old PentiumIII PC.

OK, I plug the DVD / CD drives to the IDE connector on the ASUS P8H67-V motherboard.

No boot at all. Using any live Linux.

If I disconnect the only CD writer on the SCSI bus, a Yamaha 2100:

GParted i486 (downloaded 2014-04-24) - boots.

Windows7 - boots.

openSUSE 12.2 x86_64 live CD - doesn’t boot.

PartedMagic downloaded 2012-05-14 - doesn’t boot.

But worst:

openSUSE 13.1 64bit installer DVD doesn’t boot.

Means, I am not able to install openSUSE 13.1 on this PC
in its current configuration,
although IDE drives aren’t something exotic.

Thanks for any hints
Mike

More tests:

ubuntu-14.04-desktop-amd64.iso - doesn’t boot.

I’m not sad about that, since KDE is looking and feeling so much better -
even with all gimicks like transparency disabled.

Parted Magic 2013-02-28 (Default settings 32) - boots.

Parted Magic 2013-02-28 64 (bit) - doesn’t boot.

openSUSE-Factory-NET-x86_64-Build0176-Media.iso (openSUSE 13.2) - doesn’t boot.

openSUSE-Factory-NET-i586-Build0178-Media.iso (openSUSE 13.2) - doesn’t boot.

Currently I’m downloading Ubuntu 14-04 32bit.
I don’t really want to install it,
neither for the desktop (see above),
nor since my target PC has 8 GB of RAM.

But …

As I recall there are some BIOS setting that may effect booting on IDE based drives. Check and play with any you might find

You did not say if a BIOS or EFI BIOS machine?. I’m guessing EFI but 1.5 years old it may be either.

I only have two IDE drives in the house.

One of those is in an external drive enclosure, so it is seen as a USB drive. The other is in an older 32-bit computer.

That older 32bit computer has only the one IDE drive (no SATA drive). It is running opensuse 13.1, installed with the 32-bit DVD. I don’t think there is a specific IDE problem with opensuse. It is more likely a problem with the particular hardware combination, though I don’t know what the problem might be.

Hi gogalthorp !

It’s an EFI BIOS, able of UEFI booting.
But still I don’t intend to UEFI boot and still prefer legacy GRUB.
That’s more simple than GRUB2, and my hard disk only has 2 TB.

Yes, I looked into the BIOS settings, but didn’t find anything about the IDE bus / drives.

I do not need to boot from those IDE drives -
these are a CD writer, and a DVD writer.

I currently boot all those live Linuxes that I tried from a SATA DVD-ROM device.

Once I tried to boot from the NEC DVD writer, attached by IDE - the behaviour
and the results are pretty much the same.
The device itself works fine, and the results seem to be the same.

Windows7 boots from the internal hard disk,
that was just cloned from the old hard disk that failed.
I cloned using dd.

All I want is that the system boots and doesn’t hang.

I doubt that 13.1 would work when installed on that hard disk,
if the live system that runs from an USB stick hangs.

Still I would like to use the two drives, especially the Yamaha.
It is the very only drive I ever had that reliably could burn audio CD’s
that I could use in my car.

I think it’s amazing, that some more recent Linux systems boot,
like the GParted (i486),
and the newer Parted Magic - but that one only for 32bit !

Wait, I’ll just try something:
boot from the newer Parted Magic CD
put into the NEC drive that is attached by IDE.

It is reading:

Loading /pmagic/bzImage… ok
Loading /pmagic/initrd.img…

Then a hundred messages or more.
Then:

‘Setting up system devices…’

and then the system hangs.

Another try with the same CD in the SATA DVD-ROM drive.

No, that’s not true, same result.

Power off again.
Power on with CD in SATA DVD-ROM drive.

Menu comes up.
Select 32 (32bit probably).

Now the system hangs at a different point:
last messages:

  3.369949] scsi 4:0:0:0: CD-ROM _NEC DVD_RW ND-4570A 1.02 PQ: 0 ANSI: 5
  3.371671] sr1: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cddatray
  3.371936] sr 4:0:0:0: Attached scsi CD-ROM sr1

  3.372157] ACPI: Invalid Power Resource to register!
  3.373089] scsi 4:0:1:0: CD-ROM YAMAHA CRW3200E 1.0d PQ: 0 ANSI: 2

I typed this by hand.

Maybe I need to check my cables.

Thanks for your reply
Mike

Hi nrickert !

That seems to resemble the old PC that I just dismissed.

The two IDE drives were plugged in that old pentium III PC and worked fine.

Yes, I had openSUSE 12.3 (32 bit) running on that old PC.

I was lucky with that, and as well disk burning worked fine on that old system.

OK.

Maybe the cable(s), see previous post.

I’ll check and report back.

Thanks for your reply
Mike

Hi all,

I replaced the IDE cable by a new IDE cable, literally,
it is the IDE cable that came with the motherboard,
that still was in its original packing.
Power supply is good.

I even removed the ADAPTEC SCSI controler from the PC.

Despite all this, things didn’t really improve.

I could boot Parted Magic with failsafe settings, which seem to be:
acpi=off vga=normal nopcmcia noscsi nogpm nosmart no-iscsi nolapic.

I could boot GParted with ide=nodma (and quiet and nosplash options removed).

Normal booting wasn’t possible with the IDE drives plugged.

I unplugged the IDE drives for now.

I need the PC and will try again later.

I will check in a few days if an update of the BIOS helps.

Thanks for your comments!
Mike

IDE drives can change the boot sequence. Maybe check that. I’ve never heard of this problem before so just guessing.

It occurs to me, that it is typical for IDE drives to need setting jumpers.

An IDE interface usually has a primary channel and a secondary channel. The jumpers select which. If both IDE drives are using the same interface, then you have to make sure that one is set to primary and the other to secondary. Otherwise you will have conflicts.

There is usually some fine print on the physical drive indicating the appropriate jumper settings. And there is often a spare jumper inserted where it does nothing, that you can take out and put into the appropriate place.

Hi gogalthorp!

Yes, drives can change the boot sequence.
But these IDE drives are no hard disks.
And they didn’t have any discs inserted (CDs or DVDs),
so Linux just couldn’t find any drive there,
and couldn’t mount anything.

Yes, the problem is a bit strange.
Maybe the BIOS.

Thanks for your comment!
Mike

Hi nrickert!

I did it in a simple way:
I took out the drives with the (old) IDE cable out of my old Pentium III PC,
where they worked fine, and built in the drives into the core i5 PC,
and connected them again with the (old) IDE cable.
No change in configuration, compared to the old PC.

And yes, I once set the jumpers, and there had been no need to change them now:
the NEC DVD writer/burner is configured as IDE-master, the YAMAHA CRW
by means of the jumpers is configured as IDE-slave.

Many thanks for your comments!
Mike

If they have jumpers, try setting one as master, the other as slave.

If that doesn’t work, leave jumpers as you just set them, but switch the drives’ positions on the cable.

If that doesn’t work, change jumpers on the one set as master to slave, and set the other to master.

If that doesn’t work, again switch positions on the cable.

If that doesn’t work, you can curse, if you wish, then look for a different solution to the problem.

Hi again!

Made a BIOS update.

Afterwards things even seem to look worse.

Still, windows7 boots, and I can see the drives there, having meaningful names.

Bad news:

After I managed to boot the openSUSE 13.1 64bit DVD installer with the boot option ‘ide=nodma’
installation hangs after gigabytes of downloads in one of the last steps before re-boot,
while attempting (translated):
‘Dependencies of the Kernel modules are updated (or resolved?)’.
I even can not move the mouse cursor at that point anymore.
That system obviously crashed.

Does anybody know how I could save all those GBs of downloads
instead of just attempting another re-installation and download all again ?
It seems, all those repos downloaded were good, and the software still is around on the hard disk.

Thanks
Mike

Hi, Mike:

Offhand, without doing a lot of time hunting through pages of old notes, I can’t think of a quick answer. But, I think someone here might be able to help (I hope?).

From time to time, I have experienced such lock-ups during the downloads while installing, also. As I result, I no longer allow any updating to take place during the install process, and I have never run into the problem since that way.

I do all the updating after the first successfull boot into the desktop. To avoid any problems, such as the graphics problems some run into, I run the Advanced Options -> Recovery when the installer does that first boot. Then, I do all the updates, reboot with the recovery option, and install any special drivers I am aware of (as in, if the machine has an nVidia card, I install the driver for it) before booting in normal mode.

This practice has saved me a lot of headaches on a lot of machines.

I know it is a little late to help you here, unless you decide to start again. If you start again, skip the updates until afterwards.

Hi Gerry!

When I have a stable connection to the internet I prefer to even include the updates repo for installation,
which with the newer versions of the installer is made easier, but which as well had been possible with
the older versions of the installer, when clicking that separate media should be included.
The advantage of this is that up-to-date repos are installed right from the start - the online update then
usually doesn’t find a single package that should be updated.
The disadvantage, of course, is that 2 GB or more have to be loaded from the internet during the installation itself.

The crash happend *after *the installation of the software was fully completed,
i.e. at the point where the installer prepares for the reboot before the second part of the installation.

I saw this having switched to ‘Details’ view with respect to what is shown on the screen during the installation.

I saw that message
‘Dependencies of the Kernel modules are updated (or resolved?)’,
and that 46% of that has been done before progress stopped
and the mouse cursor did freeze - even before the reboot …

But even if it would have worked, a crash during the reboot would very likely have resulted,
if I would not have been at the PC in that moment to enter that ‘ide=nodma’ boot parameter
for the reboot as well.

Having made a BIOS update first, trying some things that you suggested

is still pending.

Best wishes
Mike

From the other thread
http://forums.opensuse.org/showthread.php/497618-How-to-disable-nosplash-and-quiet-as-boot-options

Hi lwfinger!

I purchased the ASUS P8H67-V motherboard (EFI BIOS) in April 2012,
and finally assembled the PC a few months later.
So the hardware - apart from the IDE drives - is rather new.

The point you make is interesting, but I think it’s the other way round:
the BIOS messages at power on say that both drives are communicating in
‘UDMA Mode2’.

Maybe ASUS wanted too much,
or maybe at least one of the drives has problems running in that mode.

Both drives worked very well in an old Pentium III PC,
with an old intel motherboard designed for Pentium II.
I’d rather guess that this old system didn’t yet know about ‘UDMA Mode2’ …

However, I don’t know, and I even don’t know a way how to test that.

Best wishes
Mike

Hi again!

OK, I’m doing my homework.
The first step, although my heart is bleeding:
I removed the YAMAHA 3200E from the IDE bus.
The PC is booting from the openSUSE installer DVD.
That is not the result I wanted.

Second step:

YAMAHA 3200E alone on the IDE bus,
configured as IDE-master by the jumpers
at the drive.

The PC doesn’t boot from the openSUSE installer DVD.

Sh…!

That result is telling.

Seems that I only can use the YAMAHA 3200E CD writer
in the old (and very slow and loud) Pentium III PC,
in order to be able to burn readable audio CDs using k3b.

I do not like this result, but it seems that I will have to accept it.

Many thanks
Mike

Did you try switching its cable position (I am guessing you are using an IDE cable with 2 drive connections on it besides the connector to the controller?) to see what happens?

Hi Gerry!

As I wrote I tried a more simple configuration,
having the YAMAHA drive as the only drive on the IDE bus
(instead of 2 drives).
The YAMAHA drive was configured as IDE-master by means of the jumpers.

With that simple configuration of the hardware (only that IDE drive plugged)
booting Linux (or the openSUSE 13.1 installer DVD) failed.

The YAMAHA drive was at the end of the cable (the last connector/plug).

Thanks again
Mike