No Boot/No Failsafe OpenSuse 11

I recently updated some drivers, the proprietary fglrx and some wlan dirvers. Since a reboot from KDE3 I cannot access anything anymore.
fglrx was stable in KDE3 and soso in KDE 4.2
now after the GRUB boot menu I get no screen outbut - the boot runs until activation of firewall or so - and then nothing - even in failsafe.:’(
failsafe worked once - then i tried to fix the problem like before on the cmd with:

sax2 -r -m 0=radeonhd

but that just made failsafe unusable and not even possible to get into the shell with CTRL + ALT + F1 anymore

How can I fix my system without loosing all the configs and Data - especially Kontact - I have the home partition seperate I just dont know how the repair modes from the DVD work…
Can you help me out please???

Boot to level 3 like this:

at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3

At the CLI login use your user name and password to login, then switch to su and enter root password.


SaX2 -r -m 0=fglrx

ATI - openSUSE

this way to init 3 was working
but the sax2 command had no positive effect
tried radeonhd again aswell but no change…:’(

Does anyone know what to do? Can I just install
again and keep
and then everything works? most settings should be in /home anyway right??

You can re-install and keep /home (do not format)
But it’s not necessary.

Did you try switching to vesa, do as above but use this:

sax2 -r -m 0=vesa

i tried this now and i got a funny screen with purple, blue and green… dont know if this is because the screen is connected via hdmi…

Have you tried a vga adaptor?

dont have one sorry - is there anything i should know when repairing / reinstalling stuff - things i definetly need to backup apart from my personal files…
how does the access to /home work if new users etc…

Re-installing and keeping /home will leave all your user files in place. But I would try getting your system back.
Please explain what ati graphics card this is, was it working previously with the ati driver? What changes did you make that made it stop working. If you had the ati driver installed previously was it done via the repo or, manually?

Ok here it goes :wink:
-just copied my ebuyer details:
2 x Samsung SpinPoint F1 HD103UJ 1TB Hard Drive SATAII 32MB Cache - OEM 143288 Warehouse Invoiced Track
1 x Intel Core 2 Duo E7300 2.66GHz Socket 775 (1066FSB) 3MB L2 Cache Retail Boxed Processor 150186 Warehouse
1 x ASUS P5Q SE/R iP45 Socket 775 8 channel audio ATX Motherboard 150283
1 x OCZ 4GB (2x2GB) DDR2 800Mhz/PC2-6400 GOLD XTC Memory Kit CL5(5-5-5-18) 146049 Warehouse Invoiced Track
1 x Arctic Power 700W PSU - With PCI-E, 4x SATA, 20+4, ATX12V, 8pin +12V Connectors - Retail Boxed 124927 Warehouse Invoiced
1 x Asus HD 3850 Pro OC Gear Edition 512MB DDR3 Dual DVI HDTV Out PCI-E Graphics Card 144185 Warehouse Invoiced

On the day I decided to switch from KDE4.2 back to KDE3 - as the system was more stable in general and the display driver did not always crash once u start a video and use fullscreen. that worked fine and i was using kde3 after reboot.
then i noticed during an system update that my internet was slow - throughput 1mbit although we have a 14mbit line - so i tested with different pc and different routersetup - no change on the desktop pc - in windows i get full WLAN speed but under Suse it always went to 1mbit
Still I finished updates - also an fglrx update from the official AMD/ATI repo directory (was happy that they finally refreshed it) also some other things were updated via YAST with “update if newer” condition
finished fine
then i did some research on what is wrong with the wlan and tried updating the realtek driver - rtl8180/rtl8185 - which i tried with 1-click install from - but they all failed due to a kernel condition - so they were not installed
then i thought it might be due to ifplug and tried knetworkmanager for the wlan - did not want to connect eventhough settings were right - had similar problems on the eee with 10.3 before put usually a reboot helped knetworkmanager to connect so i tried a reboot - and since then i have this problem of an unusable system

that is all i can think of which would be relevant^^

ah i forgot - fglrx was working fine before - 3d worked under kde 3 and 4 - just in 4 it usually crashed with vlc dvd playback and some other video things - also webcam often did not work then

radeonhd worked before - only 2d though

now nothing

Maybe you missed a part of updates? For example: kernel-source.

But, lets start at the begining: When you boot, do you see a grub boot menu? If yes do this:
Remove all boot arguments from the default 11.1 boot and just type the number: 3

At the login, proceed with username and password, then switch to su.

Now type: yast

In here you can try re-installing video drivers, but perhaps run online updates first. Check kernel-source matches kernel also.

i do see grub
if i am in yast - it is gonna be cmd line based right? is it similar to the GUI version

for refernce:
OpenSuse 11.1 -

It’s CLI to login, the 3 means level 3
YaST is basic keyboard navigated, just try, you’ll get the hang of it

when done and back at cli type : reboot

thanks - this is a good way to learn more about linux :wink:
i am in yast now and i will try the updates
thanks so far:)

apparently eventhough i set it in yast correctly i dont get wlan in level3

  • the bad thing is i misplaced my 10m patch cable… - so i have to find a way to get internet…

i did a verify system and the dependencies are fine…
now i checked the fglrx - and it seems there are 2 versions installed atm:
x11-video-fglrxG01 - 8.593-14.1 - x86_64
x11-video-fglrxG02 - 8.640-15.1 - x86_64

dont know how that happened but might this be the source of the problem and i just remove the older version??

cannot wait to read your reply - :wink:

If you have no internet you will need to download the driver from ATI. But you will need to delete current drivers and disable the repo for it, just to be safe.

Put the driver in your /home/username
Any live cd will let you do this. Personally I use knoppix for things like this, and a pen drive also or other media (cd) with the driver on.

From level 3 cli as su

Enter the command sh ./ati-driver-installer-packageversion* to launch the ATI
Proprietary Linux driver installer.
The ATI Proprietary Linux Driver Setup dialog box is displayed.

Accept licence

Select Automatic and click Continue. The ATI Proprietary Linux Driver is now
installed, and the Installation Complete Dialog box will be displayed.

Click Exit to close the ATI Proprietary Linux Driver Installer.
Launch the Terminal Application/Window and run:
For versions of X.Org newer than 7, /usr/bin/aticonfig --initial to configure the
driver for your ATI product.

Or you go back to YaST and try to get the eth0 working.

Thanks Mate :smiley: happy
I am writing this from my “again-working” Desktop 11.1 Suse :wink:
you showed me all the Basics to fix it on the CLI!!! Cheers
In the end the problem was that ATI seperated their fglrx into 2 branches now - in the update - with propably missing dependecy regulations it installed G01 for radeon 9800 and up and G02 now for the HD 2000 and up series - this created the conflict…
After a reboot into lvl3 the wlan settings came into action and the cli yast got internet - therefore I removed the G01 and updated the G02
after a reboot the radeonhd worked fine and with a quick
sax2 -r -m 0=fglrx
the 3d support was on stage again :wink:

Thanks again Mate - I saw you are not too far and if it happens that you go a little more east than maybe I can say thanks with a Pint^^
Details via PM if interested :wink:

First time ever I really experienced the well known and good Community Support - otherwise I would have done the “Windows-Way” → reinstall - thanks for convincing me that the problem can be fixed!!!

Happy I was of some help to you friend. Keep us in mind if you run in to problems again. A Pint eh! Nice of you to offer, only I can’t drink any more. But take care and hope to see you around.

A Pint eh! Nice of you to offer, only I can’t drink any more. But take care and hope to see you around.

I will sure keep you in mind^^
Too bad that you cannot drink anymore - well maybe I will bump into you when we do a trip to Lake District this year^^ - I love it there, especially Derwent Waters (if i recall correctly) with all that orange “grass” :slight_smile:

Greetings - Rajmund