No boot Leap 42.1 after install alongside W10


Got a new laptop lately and since it has W10 installed i want to use Leap 42.1 alongside it. Thing is with the secure boot and uefi thing i can’t boot Leap after installation.
I disabled Secure boot in the bios but it didn’t work either, and in the boot options if i put the dvd rom in #1, W10 will always boot first even if i have a dvd in the drive.
Do i need to create a new path in the bios for the grub or in the installation process i missed something.

The laptop is a Asus X552MJ, if this helps.

Thanks to all for the help.

If you hit the F12 key during boot, does it give you a menu with boot options?

You need to turn off fast boot in W10, and you need to make sure when you exit W10 that you do a full shutdown, not a hibernate or a hybrid-hibernate.

In W10, open the Control Panel and select Icons View.

On the left panel, select Choose what the power buttons do

Click on Change settings that are currently unavailable

At the bottom you will see Shutdown settings

Uncheck the box for Turn on fast startup (recommended)

Click on Save changes

Also, check that the boot flag is set to the boot partition and not to the Windows partition.

Oooops! I left out a step.


In W10, open the Control Panel and select Icons View.

You need to click on the Power Options icon, then continue with the rest of the steps.:shame:

F12 does nothing. ESQ key is the boot selection screen, F2 bios and F9 is recovery.

I did all the steps you mentioned above, so i´m going to try later in the day to install Leap and see if Grub appears, about checking the boot flag to boot partition instead of Windows Partition, where do i do that? I used “msconfig” for the boot settings and there’s nothing there to check. Sorry, not a Windows user in years…


Unfortunately the BIOS/EFI keys are not standard so each manufacturer does its own selections.

Always read the motherboard or computers docs to know what keys do what.

Never had any problem in entering bios or use boot menu, only GRUB after installation did not appear.
Already managed to make it work.

Thanks for the help :slight_smile:

Already made it, i have openSUSE installed alongside W10.

Thanks for the help.