No boot into GUI and can't get it going

So after a long time of trying to troubleshoot I am at a loss of what to do. After switching to Windows I tried to boot back into opensuse 42.2 again only to find out that it would not start the GUI. I use plasma 5.8 if i’m not mistaking.
I remember trying to configure my quadro K1100m, I thought it was fine, but it appears not.
So when I boot I get the console, when I try to start plasma using plasmashell (non elevated or with su permission) will return:

QXcbConnection: Could not connect to display
Aborted (core dumped)

So I used /sbin/lspci -nnk | grep VGA -A2 to check whether my gpus were present and what they were using as drivers:

00:02.0 VGA compatible controller [0300]: Intel bla bla [8086:0416](rev 06)
Subsytem: Lenovo device [17aa:221e]
Kernel driver in use: i915
01:00.0 VGAS compatible controller [0300]: Nvidia corporation [GK107GLM] [10de:0ff6](rev a1)
Subsytem: Lenovo device [17aa:221e]
Kernel modules: nouveau, nvidia_drm, nvidia

Now I am especially wondering about the last part because it just doesnt seem right to have 3 drivers installed?

Now what would be the best course of action to regain acces to my graphical user interface? Also what steps should I take to understand this process better? The provided nvidia instructions havent helped me much.
Thanks in advance for helping!


If so. Looks like maybe a Optimus setup ie Intel+NVIDIA GPUs. This takes special setup

It is indeed a laptop with a Intel and Nvidia combination, specifcally a Lenovo W541 with a i7-4700MQ and a Nvidia quadro K1100M
So I’ve tried the install guide but it doesnt help, it still gives the same errors.
When I try the check optirun --status it returns:

Bumblebee status: Read (3.2.1). X inactive. Discrete videocards is on.

I’ve taken the liberty of launching yast and screenshotting what nvidia related packages there are installed on my laptop:
Maybe it would be right to deinstall some of these packages?

Can you change the GPU in use via UEFI/BIOS?? Most Notebooks can’t.

In any case need to get a Optimus expert on this I don’t own the hardware here.

So I’ve decided that because I have just installed the system a week ago, it would be just easiest to install it from scratch.
I have adjusted so many things trying to fix it I am afraid my gui will not “just” recover.
I will now setup my setup properly from scratch and I will do some more snapshots I suppose:)
Thanks for the help!