No bluetooth on SONY VAIO Fit 15

Hi!

Well… my bluetooth don’t works. I have tried many ways to make it work, but nothing. So, sorry for the inconvenience, I hope you can help me.

Wel… I tried enabled my bluetooth by konsole. hciconfig -a hci0, but my hcitool scan show me Scaning… Scaning… and nothing. (as root)

I had this problem in openSUSE 12.3 and now, in openSUSE 13.1 ß1.

lsusb

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 03eb:8813 Atmel Corp. 
Bus 001 Device 004: ID 0489:e062 Foxconn / Hon Hai 
Bus 001 Device 005: ID 5986:0543 Acer, Inc 
Bus 003 Device 003: ID 04f3:0103 Elan Microelectronics Corp. ActiveJet K-2024 Multimedia Keyboard
Bus 003 Device 004: ID 0458:003a KYE Systems Corp. (Mouse Systems) NetScroll+ Mini Traveler / Genius NetScroll 120

systemctl status bluetooth.service

bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since vie 2013-09-27 18:34:43 PET; 51min ago
     Docs: man:bluetoothd(8)
 Main PID: 6298 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─6298 /usr/lib/bluetooth/bluetoothd

sep 27 18:34:43 kaede.site bluetoothd[6298]: Bluetooth daemon 5.8
sep 27 18:34:43 kaede.site systemd[1]: Started Bluetooth service.
sep 27 18:34:43 kaede.site bluetoothd[6298]: Starting SDP server
sep 27 18:34:43 kaede.site bluetoothd[6298]: Bluetooth management interface 1.3 initialized

hwinfo |grep blue

  E: RFKILL_NAME=sony-bluetooth
  E: RFKILL_TYPE=bluetooth
  P: /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0
  E: DEVPATH=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0
  E: SUBSYSTEM=bluetooth
  E: SYSTEMD_ALIAS=/sys/subsystem/bluetooth/devices/hci0
  E: SYSTEMD_WANTS=bluetooth.target
  P: /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/rfkill4
  E: DEVPATH=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/rfkill4
  E: RFKILL_TYPE=bluetooth
/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0
/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/rfkill4
  bluetooth 392580 23 bnep,btusb, Live 0xffffffffa0a73000
  rfkill 26487 5 bluetooth,cfg80211,nfc,sony_laptop, Live 0xffffffffa01f8000

dmesg|grep -i blue

    4.951238] Bluetooth: Core ver 2.16
    4.951254] Bluetooth: HCI device and connection manager initialized
    4.951262] Bluetooth: HCI socket layer initialized
    4.951264] Bluetooth: L2CAP socket layer initialized
    4.951269] Bluetooth: SCO socket layer initialized
    6.622605] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    6.622609] Bluetooth: BNEP filters: protocol multicast
    6.622618] Bluetooth: BNEP socket layer initialized

hciconfig -a hci0

hci0:   Type: BR/EDR  Bus: USB
        BD Address: B8:76:3F:B2:71:CC  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING PSCAN 
        RX bytes:1410 acl:0 sco:0 events:64 errors:0
        TX bytes:1055 acl:0 sco:0 commands:63 errors:0
        Features: 0xff 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
        Link policy: RSWITCH HOLD SNIFF 
        Link mode: SLAVE ACCEPT 
        Name: 'kaede.site'
        Class: 0x00010c
        Service Classes: Unspecified
        Device Class: Computer, Laptop
        HCI Version: 4.0 (0x6)  Revision: 0x0
        LMP Version: 4.0 (0x6)  Subversion: 0x210b
        Manufacturer: Broadcom Corporation (15)

Make sure that you have installed the bluez, bluez-firmware, bluez-hcidump and bluez-test packages.

Then restart your laptop and rerun the scan.

Follow Up

If your using the cfg80211 version of the driver, then cfg80211 needs to be
loaded:

modprobe cfg80211

Then:

insmod wl.ko

You also must install: |
|
rfkill

It’s a tool for enabling and disabling your wireless devices.

|

Of course, I have bluez

zypper se bluez

E | Nombre            | Resumen                                                        | Tipo    
--+-------------------+----------------------------------------------------------------+---------
i | bluez             | Pila Bluetooth para Linux                                      | paquete
  | bluez-cups        | Controlador CUPS para impresoras Bluetooh                      | paquete
  | bluez-devel       | Archivos necesarios para el desarrollo BlueZ                   | paquete
  | bluez-devel-32bit | Archivos necesarios para el desarrollo BlueZ                   | paquete
i | bluez-firmware    | Firmware de Bluetooth(TM)                                      | paquete
  | bluez-hcidump     | Herramienta de volcado HCI para depurar conexiones Bluetooh    | paquete
i | bluez-test        | Herramientas para el ensayo de diversas funciones de Bluetooth | paquete
i | python-pybluez    | A Python Bluetooth wrapper                                     | paquete 

All was installed except “bluez-hcidump” because exist a conflict.

Well, with rfkill:

rfkill list

0: sony-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: nfc0: NFC
        Soft blocked: no
        Hard blocked: no
2: sony-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
4: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Follow Up

I’m not sure if you are using KDE4 or GNOME. I would also check Configure Desktop → Startup and Shutdown → Service Manager.
Select Bluetooth, click on Use and then Start and Apply buttons.

Restart your laptop and check your bluetooth.

In addition, install the “spicctrl” package.

spicctrl - Control LCD Brightness and Bluetooth Power on Sony Vaio Laptops

spicctrl is a utility that uses the Sony Programmable I/O Control device (****), which is part of most Sony Vaio laptops, to perform several functions, such as changing the display brightness, controlling Bluetooth power, or reporting battery status.

Thanks for responding.

I use “Konsole” so, my D.E is KDE 4.11.1.

In the 12.3 (x86_64) when I go to KDE Settings > Bluetooth.

This screen show me a Bluetooth active (even the icon in the taskbar). But don’t works.

In the 13.1 ß1 when I go to KDE Settings > Bluetooth.

This screen show me a Blueetooth inactive (the message “Bluetooth device not found”).

# spicctrl -a
Sony Vaio **** control program version 1.8, Feb 7, 2005

/dev/sonypi: No such file or directory

This program is very old, maybe is only for old vaio laptops.

Man. That is an old package. It could be for older Sony Laptops.

To load the module use:

sudo modprobe sonypi

According to what you’ve provided you have a bluetoothd daemon. Have you tried:

systemctl stop bluetooth.service

Then:

systemctl restart bluetooth.service

I would open Yast → System → System Services. Is there a reference to Bluetooth. If there is start it.
Next switch to Yast → System → /etc/sysconfig Editor. Click on Hardware> Bluetooth ->START_BLUETOOTHD and type in yes. Click on OK buttons.

There’s more:

Navigate to /etc/blutooth/main.conf and rfcomm.conf. The files require some editing for your particular bluetooth hardware.

While you are in Windows check if the network adapter was switched off with the explicit function key provided by the laptop manufacturer.

Also in openSUSE check if it is blocked by the Firewall.

| Run the following command in the terminal as root:
|

hciconfig hci0 reset

It should turn ON the bluetooth.

Also when you are using the laptop, try to turn it OFF and ON, using the hardware switch. Usually done with Fn + Some function key depending on your laptop.

The click on Configure Desktop → Bluetooth. Is anything showing up>
If this doesn’t work than install Blueman package. You can search and find it on the openSUSE website.
|

I also have the SONY VAIO FIT 15.

I got bluetooth working (kind off)
Symptoms: It look like it’s working but no pairing whatsoever
solution: Install firmware (deb package) http://wielki.tk/vostro/debs/bt-bcm43142-onereic_0.0+20111116somerville2_amd64.deb
(you can try by conveting with alien)

sometimes doesn’t work even with this package. But manual loading the firmware helps.

brcm_patchram_plus_usb --patchram /lib/firmware/BCM43142A0_001.001.011.0028.0036.hcd hci0

let me know if this helps you!

**
Thanks**, I tried with your method (with alien) and:

  • Me: # brcm_patchram_plus_usb --patchram /lib/firmware/BCM43142A0_001.001.011.0028.0036.hcd hci0
  • Me: # hciconfig hci0 reset
  • Me: # service bluetooth restart
  • The bluetooth was activated.
  • I could scan device (my smartphone by example).
  • I could synchronize my laptop with my smartphone. GREAT!

< BUT >

    • When I tried to send a file to my smartphone, ERROR.
    • Try again, nothing… Then I reboot the laptop.
    • Again: - Me: # brcm_patchram_plus_usb --patchram /lib/firmware/BCM43142A0_001.001.011.0028.0036.hcd hci0
      … waiting… nothing. I press CTRL + C (cancel)
    • Me: # hciconfig hci0 reset
      Error, time exceeded.
    • I reboot again.
      My mouse and keyboard (USB) don’t works, but the native keyboard and touchpad of the laptop works, so, I shutdown the system.
    • I turn on the laptop, the keyboard and mouse (USB) works again. I repeat the procedure for the bluetooth, and…
      It is the same as the 1-5

So, I uninstalled the rpm, disabled the bluetooth service and the calm in my laptop has returned. Maybe this firmware is not compatible with my bluetooth chip.

PD. I tried this procedure with a new installation of openSUSE 13.1 (x86_64) with all updates stables.

Maybe this one:

5.10. KDE and Bluetooth

The Bluetooth stack is provided by Bluez 5 (a major, backwards-incompatbile version), a necessary upgrade for GNOME desktop and some other components of the base system. Unfortunately, the KDE workspace only supports Bluez version 4 in its currently-released versions.

Therefore, the openSUSE KDE community team offers an unofficial Bluedevil package providing at least basic functionality such as device pairing or support for bluetooth mice; Some other features are known not to work jet, like file transfer.

For the moment, bugs should not be filed against Bluetooth support in KDE as the Bluez 5 port of Bluedevil is still ongoing.

Release-Notes for 13.1 on your disk:
[file:///usr/share/doc/release-notes/openSUSE/RELEASE-NOTES.en.html](file:///usr/share/doc/release-notes/openSUSE/RELEASE-NOTES.en.html)

The online version finally has been updated as well recently:
https://www.suse.com/releasenotes/x86_64/openSUSE/13.1/#sec.131.kdeandbt
:wink:

@wolfi323:
Thanks

Oh… then I can’t have Bluetooth in my laptop. ;_;

Thanks for the info.

Finally, I also give up, I bought a new intel card (this comes with the new VAIO FLIP), very easy to install

note: the intel 7269 is a AC wifi type protocol (this is the last one), also there is a intel 7269 with type N protocol, try to check that it says AC. (I bought the N whitout notice at 15USD, it is better to spend the other 15… my bad)

Amazon.com: Intel Network 7260.HMWG WiFi Wireless-AC 7260 H/T Dual Band 2x2 AC+Bluetooth HMC: Electronics

installation
https://www.youtube.com/watch?v=l5Mwsg5CWrA

Kernel 3.11.x works out of the box, nothing to install.

kanibal.-

PD: Also notice at the installation that the antenna has a very very poor design… to bad SONY.