No Battle for Wesnoth? :(

I was wondering that there is no package in 11.3 for installing the great game battle for wesnoth game? In the games repo there is only the games-data. Can anybody tell me where i can get these packages to install wesnoth on 11.3?

Fixing the 280MB monster…

Please have some patience. On my machine it wont compile and thats the reason why there is no package yet.

¿? There is a package.
The same day I updated to 1.8.3 and fixed the libpng 1.4 build problem.

PS. You know you can always ask in opensuse-packaging@ or to games repository maintainers if you have a problem, do you?

btw. i got it now from games repo. its finally there.

Sorry i know that. I was trying it on saturday, i didnt check the repository today coz i had no linux machine this morning. I was trying to explain why there is no package yet. Btw. thank you for fixing. You, the packagers and the maintainers are the guys who make us happy. Thats the reason why we will always stick with openSUSE!

i installed it and can start the game but i cannot klick on any buttons. whats wrong here?

What desktop are you using? I get this problem intermittently whenever I’m on my desktop computer that has the KDE Factory repo enabled, but is fine when running the stable KDE that comes with 11.3. It usually happens when I switch between programs.

i am using gnome.

Sorry, but works fine here with the default KDE installation from openSUSE 11.3. I can’t fix a problem I can’t reproduce.

Open a bug report in bugzilla so perhaps some other maintainer can reproduce it.

i am using !!!gnome!!! not KDE. and i dont want to switch to kde. its freaking me out

!!!Open a bug report in bugzilla so perhaps some other maintainer can reproduce it!!!?

Since users of Arch (FS#16809 : [wesnoth] mouse doesn’t work properly), Gentoo (Gentoo Bug 290695 - games-strategy/wesnoth-1.6.5 may not work with media-libs/libsdl-1.2.14 in windowed mode) and Debian (#565788 - Upgrading SDL breaks Wesnoth - Debian Bug report logs]( use its bugzillas, as I asked you to, relevant people gets notified of the problem:
Bug 894 – After SDL 1.2.14 update, wesnoth doesn’t accept mouse clicks in windowed mode

And now you have what (should be) a fix. Update libSDL-1_2-0 to the version from the games repository and report your results. It could take some time to be published, it should be 1.2.14-28.1 or higher.

Ok i tried to rebuild wesnoth from src.rpm file. After this the same error again. The game starts but its nothing more than a nice big space-eating screensaver with music. i cannot click on any buttons. Oh well this isn’t right. i can click on them but nothing happens.

Than i took the source and read the INSTALL file where it reads that there are problems with Sdl Version 1.2.14 and 1.2.13 is recommend. So i think this is the problem here, since opensuse 11.3 uses this version. I think to fix this there are two options. Option one is to downgrade to version 1.2.13. I don’t know whether this is possible without affecting the whole system and how this is possible. The Second Option is to wait until this is fixed. Maybe in the next Version 1.8.4 of Battle for Wesnoth, which is not realy an option for me.

I tried to recompile 1.8.4. here is the same error.

There is some kind of problem and my messages can’t be read? Once again,

Update libSDL-1_2-0 to the version from the games repository and report your results

ok now it works with this version of sdl. thank you very much.

Ok. So fix forwarded to openSUSE 11.4.

wesnoth is currently broken for 11.2 which i use on my ibm thinkpad r51 (cant update to 11.3 because of the kms bug for intel video cards). the reason is simply because there is a package wesnoth-1.8.4 but a package wesnoth-data-1.8.5.

can you fix this or put back the wesnoth-data-1.8.4 please?


Could take some time to get publushed, but done.