No background/tool bar etc

I’ve just reinstalled Opensuse 11.1 (with KDE 4.2) from a CD and when I log in the background is just black. There’s no tool bar at the bottom. Fortunately there’s a terminal from which I can run any program I like, but obviously that’s not really how I want to run my computer! When programs open there’s no window decoration.

So far I’ve tried: reinstallation, updating KDE with a 1-click installation, installing the correct driver for my graphics card (it’s a Radeon X1550, again using a 1-click installation). I’ve managed to install and run compiz. Even the cube works, although all the sides are black, which confuses me greatly.

Any suggestions? I’m running out of ideas of what the problem is and no luck from Google searches.

Solved it, although not sure how/why it worked. I changed the displaymanager setting in /etc/sysconfig (got to through yast) to kdm3, rather than kdm4.

I’m relieved it’s solved, but if anyone wants to offer words of wisdom as to why I’d be grateful to hear them, so I can avoid the same problems in the future.