No audio sound from video formats played

I am pretty sure this has something to do with either missing codecs or software issues. But I need a little help trying to narrow this down to exactly what it is. I have a little better than a beginner’s knowledge of Linux. I am running OpenSuse 11.0 using Gnome.

I am able to play audio formats using Banshee and Amarok just fine. Absolutely no problems there, sounds come through crystal clear. I can hear the login sound file as I log in so I know the OS itself has no problem with sound. But when I try to play a video in VLC (I have tried both just the VLC package and the VLC beta with Pulse Audio support package) and neither one seems to work as in that I hear no sound from the video that I am trying to play. Mostly I am trying to open mov, flv, mp4 and mpeg file types with the same result on every one. I tried using Totem movie player but that said I was missing codecs for some of the file types that I have already listed that it supports. I was told VLC should be able to work without additional codecs? Was I wrong on this assessment?

Can anyone tell me what could be causing this or what I may be missing? Has anyone else has a similar problem to this? Any and all help is appreciated.

I think I might have fixed my problem in VLC (using beta w/ Pulse Audio support) with the mpeg files. I changed a setting in gstreamer so that instead of looking using ALSA it uses ESD instead.After I tried playing it in VLC, the audio and video both worked fine. But I still can’t get it to play mov or mp4 files with audio. Might try and get back to the regular VLC and see it that works.

VLC typically comes with its own codecs, although I have experienced cases where an ffmpeg update will break VLC (I think it depends on how VLC has been built by the packager). VLC is packaged by two different packagers (videolan and packman) and when it comes to VLC dependencies it is best to obtain the dependencies from the same location as one obtains VLC (ie if one is using a Packman packaged VLC, then use Packman dependencies, or alternatively if one is using a Videolan packaged VLC then use videolan dependencies).

I was also told by a openSUSE-11.0 user on IRC #suse that VLC was broken for his PC for ac3 audio (purportedly for both Packman and videolan). My VLC worked for ac3, and I note he had 64-bit and I had 32-bit. But he refused to provide an extract of any videofile that was giving him problems, so I was not able to investigate the accuracy of his claims. With the correct tool (such as dvbcut) creating an extract is easy to do, but sometimes user’s have a specific approach in mind to solving a problem, and suggested deviations are not welcome.

There are updated libquicktimes available on Packman, but I do not know if the packman packaged VLC access the codecs embedded in those quicktime libraries. There is also the Packman packaged w32codec-all which provides many codecs for applications such as xine. I am not clear if VLC uses those codecs.

Some VLC users had discovered problems with “special desktop effects” with their VLC, and by switching the VLC video output module from “auto”/“xv”(xvideo) to “x11” they had more success. Others simply disabled their “special desktop effects”.

I’m a KDE user, so I don’t have experience switching Gnome video/audio modes. I do know some limited theory.

Reference your switching gstreamer to ESD, my limited understanding is for Gnome users, ESD typically interfaces to alsa modules/drivers, and provides an API for Gnome multimedia applications. GStreamer typically interfaces to ESD, and GStreamer provides necessary codecs for applications that use GStreamer. I did not think having GStreamer connect directly to alsa was a nominal configuration. However alsa (in addition to providing hardware drivers) also provides an API, so presumeably then before switching to the ESD API, your GStreamer was connected to the alsa API and presumably could work. I assume the ESD api is superior (more features ? ) to the alsa API ? I don’t know].

I had read that Pulse-Audio, on Gnome, is a replacement for ESD (in Gnome, at least thats the theory) so when you say you have Pulse-Audio support, I think by switching to ESD you are bypassing Pulse-Audio ?

In the case of KDE4, there is Phonon, but that’s not relevant to Gnome.

Anyway, I’m still trying to sort out the entire Pulse Audio/Phonon situation.
Sound-concepts - openSUSE
I think the documentation available for the openSUSE community (with specific guidance and with specific openSUSE implementation details) still needs some work. My sound concepts page is woefully weak, and it needs a practical guide (for openSUSE) linked to go with it.

While Linux distributions were provided guidance on how to implement Pulse Audio:
PerfectSetup - PulseAudio - Trac
I don’t know how much of that was followed on openSUSE.

Thank you so very much for your insight oldcpu. Before I switched AlSA to ESD, I checked all of my currently running processes and I think that an AlSA related process should have been running and it wasn’t. For some reason, it wasn’t even coming on even thought the package was installed. So I figured a change in the gstreamer was the answer. Apparently this has worked for me. Also, I think a lot of people are having problems with Pulse Audio. I not sure if Pulse Audio causes conflicts with other audio methods or if it is that the software itself is just buggy or that is because people are just missing files to make it work. But somehow I doubt the last one b/c Pulse Audio should have come with everything needed to work when you do an install of OpenSuse. From what I have read on these and other forums is that Pulse Audio and multimedia are the biggest problems so far with this newest version of OpenSuse. Hopefully, this can get straighted out soon at least for most people.