No Audio on Notebook After Runing Open SUSE Updater

I have never had a sound problem in years of using Linux, but it finally happened to me after patching my system. It was working fine before, but now I have no sound and no speaker icon in my system tray.

I ran this command

su -c ‘speaker-test -Dplug:front -c2 -l5 -twav’

, but did not hear anything.

Here is the output:

speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 16 to 16384
Period size range from 8 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
 1 - Front Right
Time per period = 2.737711
 0 - Front Left
 1 - Front Right
Time per period = 3.071437
 0 - Front Left
 1 - Front Right
Time per period = 2.901649
 0 - Front Left
 1 - Front Right
Time per period = 3.071864
 0 - Front Left
 1 - Front Right
Time per period = 3.071255

Very strange. I will think twice next time before updating my system. This is the first (and possibly the last) time I have ever tried using the automatic update program on my system.

There may very well be a bug in the latest updates.

Kernel updates have been known to break one’s audio. … You could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Failing that, we can try the slow “you post”, “I counter-post”, “you post”, “I counter-post” … etc … etc … method. In which case, we need more information to make a reasonable recommendation. Can you provide more information on your configuration?

Please, with your PC connected to the internet copy and paste the following into a gnome-terminal / konsole:

wget && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal/konsole and post the output here.
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Good luck!

Thanks for the links and the terminal commands OldCPU! And also for the hundreds or thousands of people you have helped out on these forums over the years. Novell should really be paying you after all the work you’ve done for them.

I have already tried to reconfigure my sound in Yast / Hardware / Sound. I think I exhausted everything there with no luck at all in even getting the test sound to play. Everything looks fine from there, I just don’t have any sound or any speaker in the system tray.

Hopefully I can fix the problem by using the stuff you posted, and I will let you know how it turns out.

Here is the url you requested:

tsalsa.txt - (beta)

Other requested data from terminal command:

user@linux-qmyg:~> rpm -qa | grep pulse
user@linux-qmyg:~> rpm -q libasound2
user@linux-qmyg:~> uname -a
Linux linux-qmyg #1 SMP 2008-07-13 20:48:28 +0200 i686 athlon i386 GNU/Linux
user@linux-qmyg:~> cat /etc/modprobe.d/sound

options snd slots=snd-atiixp
# hB6S.kOG9afxcOK0:MX6421
alias snd-card-0 snd-atiixp

Thanks again and I will go through the guide now.

somehow the remainder of the alsa was omitted. Can you post here again the output of:
rpm -qa | grep alsa

also, reference your mixer, I note this from tsalsa:
Amixer contents for card 0 [IXP] _____________________________________
amixer set ‘Master’,0 71%,71% on
amixer set ‘Headphone’,0 74%,74% on
amixer set ‘PCM’,0 0%,0% on
amixer set ‘Line’,0 0%,0% on Capture off
amixer set ‘CD’,0 0%,0% on Capture off
amixer set ‘Mic’,0 0%,Capture on
amixer set ‘Mic Boost (+20dB)’,0 off
amixer set ‘Video’,0 Capture off
amixer set ‘Phone’,0 Capture off
amixer set ‘IEC958’,0 off
amixer set ‘IEC958 Playback AC97-SPSA’,0 Mono: 0 0%
amixer set ‘PC Speaker’,0 0% on
amixer set ‘Aux’,0 Capture off
amixer set ‘Capture’,0 Capture 0 0%,Capture 0 0% on
amixer set ‘Mix’,0 Capture off
amixer set ‘Mix Mono’,0 Capture off
amixer set ‘External Amplifier’,0 on
Your PCM is at 0%. That means no sound. Try move it up to 75% or so.

Alsa data:


OK, I tried turning the volume setting up in Yast / Hardware / Sound and was able to play a test sound. I guess I just need to get my volume control icon back but I don’t see an option to do that.

Thanks again for the help!

If you are using kde, just type: kmix

(had to install kmix for this to work)

It’s still messed up, but I’m just going to leave it as is.

For example, I don’t hear the startup and log off sounds. Also, the volume control keeps going back to zero all by itself.

But I don’t use sound much, so I’m just going to leave it alone. Thanks again.

You may be able to fix that by placing the volume control at the level that you wish, and then in a konsole or gnome-terminal type:**su -c ‘alsactl store’**and that is supposed to store the current settings

Same problem=(…is it PCM not turned on? how can I?

here is my output…
tsalsa.txt - (beta)

Please, I do not understand your problem. You state “same problem”, but then in the tsalsa script, you note: “Problem: sound doesn’t work on upgrading the kernel; tried irqpoll pci=… option on boot option which worked fine for but won’t work for” That’s not the same problem.

Your PCM is turned ON, so I do not think that is your problem.

I also note from the script you have an ALC260, and there was an update to the ALC260 in the recently released 1.0.18rc3 alsa Search results for ALC260 - AlsaProject
But you have an Acer TravelMateC200, and that 1.0.18rc3 is for HP DC7600 which may not be applicable to your Acer.

Also, openSUSE-11.0 has a problem where the default autoprobe for sound does not work in all cases, and sometimes users have to apply a custom setting (such as “acer” or “auto” ) to the appropriate place in one’s /etc/modprobe.d/sound file.

Please, can you copy and paste (and provide the output of) the following into a gnome-terminal / konsole : rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundI need that output in order to make a good recommendation. Without it I am forced to speculate MUCH MUCH more than I like, and without it I may not be able to help. Can you provide that please?

Also, if you had installed the custom alsa-driver-kmp-default driver for the kernel, you may have to update that to a more current alsa driver for the kernel. Such a driver is now available, and instructions are here: Alsa-update - openSUSE
Note there are 6 !! zypper commands that must be sent. I can walk you through sending those, if necessary.

But first, please provide the information I requested. And second, we can try some changes to your /etc/modprobe.d/sound file.

Also, each time, when testing your sound, please test with:
su -c ‘speaker-test -Dplug:front -c2 -l5 -twav’

wow! it doesn’t happen that often to find people, so thorough and polite as you! :wink: thanks!

…the fact is that, I’ve already unistalled opensuse and got back to ubuntu! …here I expected to hear again…but…sorprise: there’s no audio here too from the speaker, whereas the master(line out) works fine!

I’m starting to think that I burnt my speaker…I was probably mislead by the fact that soon before the audio went away I was upgrading the pc, but the two thing weren’t probably linked!

ps.Linux is like zen…i’m so far away from my nirvana;) thanks anyway…i’ll let you know if i come up with something! Otherwise,thanks once again!