No audio on 11.2 (AC'97 / LXDE)


I’m a complete newbie to suse and linux, but am enjoying the journey so far :slight_smile: After a little thrashing around in the dark, I’ve managed to get my machine to boot directly into LXDE (which has sped up my old packard bell a lot!) and configured my wireless USB (which I had been advised was a major headache in linux!) and am feeling quite proud as a result.

Have however been unable to produce any sound at all so far. The /usr/sbin/ command gave me the following url:

Am using LXDE on opensuse 11.2, and the audio controller is AC’97 (on quite an old laptop). Any advice and solutions on this would be very very much appreciated :slight_smile:

I don’t see anything obvious there. Do you know what the “External Amplifier” setting does? Out of curiousity, what happens when you toggle it OFF ?

Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

I also note you have master volume @ 74%, master mono @ 74%, 3D controls at 0% or OFF, PCM at 74%, … what happens when you move those levels up to 95% for testing?

What are you using for a sound test?

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset,** try with your headset plugged in**, and also with your headset not plugged in (for speakers).

Copy and pasting the External Ampifier code gives the following message:

matt@linux-3duy:~> ‘External Amplifier’,0
If ‘External Amplifier,0’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf External Amplifier,0
matt@linux-3duy:~> Capabilities: pswitch pswitch-joined
If ‘Capabilities:’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf Capabilities:
matt@linux-3duy:~> Playback channels: Mono
If ‘Playback’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf Playback
matt@linux-3duy:~> Mono: Playback [on]

Is this the correct resopnse i should be getting?

Yes, that is correct. There is NO such command as you are selecting.

Take a look at your mixer settings. I’m not familiar with LXDE, but I suspect you can run ‘alsamixer’ and possible control it from there.

If not with ‘alsamixer’ then try ‘amixer’. To learn how to use ‘amixer’ type:

man amixer

Don’t bang your head too hard on the wall over this.

If you get stumped, post for help and I can try explain more in areas where you are puzzled.

run this command.


Please specify make and model of computer

I’ll have to get into and research LXDE to see if there is something specific, like KDE’s Personal Settings.

What will that give you specifically about the audio hardware, that is not already in the script output from the diagnostic that rogers1987 ran??

Please try the yast hardware sound we have the same sound card in one of the old pc, there is an option to select in the edit section for something like a buggy driver and then test your volume controls under the other tab. It might work for you.

Yeah. I have the same sound card to. It’s an Intel card. But first we need to see whats going on. Or at least I like to. See we need to find out if it’s user specific (non-root) or if it’s system wide. If it’s system wide, then we can jump into YaST.

To Jonathan _R.
I hear you. I think you are right and I also like to see the outcome. We will also benefit from this test being a holder of the same AC97 sound card.

Just to re-iterate, if you look at the script output:

you will see:

!!PCI Soundcards installed in the system

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)

In terms of the Title to this thread, which is “No audio on 11.2 (AC’97 / LXDE)” what does one need from “lspci” that is NOT provided there in the diagnostic script.

If you look again at the script, you will see:

!!DMI Information

Manufacturer:      NEC Computers International
Product Name:      Packard Bell EasyNote

again, what more is one looking for?

Of the sound tests I proposed above, typically at least one of the three will work. They should work in both the LXDE desktop and also in run level 3. If they do not work, we can go from there, but I have found many times new users will have codec problems, and then believe their overall sound is not working, when in fact their basic sound functionality test was not very good and it is just a codec problem.

There seem to be many types of AC’97. In the case of the OP, his is built in to the winmodem. There are many reasons why the sound could not be working. Is it system wide? The OP only specified LXDE.

Packard Bell was bought out by Compaq which was then bought out by Hewlett Packard. So the name doesn’t mean much, unless we want to date the computer. In which case the computer would be over 10 years old, which I doubt.

I have no doubts they will work, whether in KDE, LXDE, GNOME or whatnot. I was just going a different way. Having Googled it, this sound card does nothing but give everyone headaches. Silicon Integrated Systems - Google Search[SiS]+AC%2797+&btnG=Search

rogers1987, how are you doing?

I don’t know the exact details of your hardware behaviour wrt sound, so I can not say whether it will help to toggle that external amp setting. That is possibly a red herring.

But I do know that using the correct test for sound is important.

If you get sound by any means (such as startup sound, or the aplay test, or one of the speaker-tests) please advise. In that case it is likely a codec or a multimedia application problem that you have encountered, and openSUSE has its own unique way of very easily sorting that (easy only AFTER one has been given a brief explanation).

… but first, lets prove that basic sound functions.

Ok, so now I have tried turning off the external amplifier, setting master, mono, 3d and PCM at 95%,with and without a headset, and with and without root privileges, all to no avail. I have tried to edit the “buggy driver” value to one or two, but any value changes in this part of yast causes yast to crash and my task bar to disappear! >:(

I recommend you try toggling the external amplifier. ie try it with both settings.

I do not recommend playing with any ‘buggy driver’ value unless you have some specific advice. It could make things worse.

What is the output of typing the following:

rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a
cat /etc/modprobe.d/50-sound.conf

Please also confirm you tried all 3 sound tests that I recommended.

You could also try those tests from run level 3, ie type “3” in the grub menu so that “3” appears in the options line (no quotes) and log in to the ascii/text prompt after the boot, and then try those two speaker-test commands and also that aplay command, to see if they work there. The idea behind that is to remove the desktop as a blocking consideration.

I have tried all of the sound tests you recomended, which have also been unsuccessful.

The code gives the following response

matt@linux-3duy:~> rpm -qa ‘alsa
matt@linux-3duy:~> rpm -qa ‘pulse
matt@linux-3duy:~> rpm -q libasound2
matt@linux-3duy:~> uname -a
Linux linux-3duy #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux
matt@linux-3duy:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-intel8x0

1sCg.FE2ChIvEhe4:AC’97 Sound Controller

alias snd-card-0 snd-intel8x0

I Will try running the tests from level three and post results in a few minutes

Thanks for all your assistance

Have botted at run level 3 and the sound tests are still unsuccessful.

Also, loading with KDE has no effect.

Do you think an update of ALSA would be a possible answer?

I assume you tried with both regular user permissions, and with root permissions. And tried to speakers and also to headsets for both cases.

You could try an update to the latest alsa rpms, but I am skeptical they will work. Guidance is here: Alsa-update-snapshot - openSUSE
the zypper command may not work properly and you may need to download the alsa rpms to you hard drive and install them with "rpm -Uvh <application.rpm> <application.rpm> "
Then restart and test.

But sound should be working with no effort, so no matter how one cuts this, I view this as a bug, and IMHO you should write a bug report. There is guidance here for raising bug reports: Submitting Bug Reports - openSUSE Be certain to raise it against openSUSE-11.2 component “sound”. That bug report will get the attention of the SUSE-GmbH packager for sound who is also a developer of the alsa sound driver. If anyone can sort this, he can.

Please also run the script with no upload option and attach the file /tmp/alsa-info.txt to the bug report. You can run with no upload by typing:

/usr/sbin/ --no-upload

Are you certain this is not a hardware problem?