No Audio Input on OpenSUSE 12.1 KDE

Hi, I really not some help and quite lost when it comes to sound in Linux.

In the process of debugging why Skype did not hear my voice, following ‘no mic input in Skype’ thread](, I discovered my audio INPUT is not working at all. Here is what I know so far:

My capture devices are being recognized, there is one embedded sound chip with both front and back sound inputs. These look shown by ‘arecord -l’ which outputs:

**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 2: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

If I try to record sound using ‘arecord -vv -c 2 -f S16_LE -D hw:0,0 new.wav’ or ‘arecord -vv -c 2 -f S16_LE -D hw:0,2 new.wav’, nothing gets recorded.
Specifically, the .wav file gets created but it contains no sound at all, not even noise.

Just as a sanity check, aplay of anyother S16_LE file I had works perfectly. The Skype test call exhibits the same behavior. I hear the voice
being played back but not the recording of mine.

The is the same system that worked with OpenSUSE 11.2 64-bit last week except that I used to use Gnome and now am using KDE. When I installed 12.1
64-bit initially sound did not work at ALL (not even playback). After looking in the forum the simple solution was to remove PulseAudio except for the client
library and now sound OUTPUT works, so perhaps the fix was incomplete.

Any ideas how to solve this? Is there any other information you need to diagnose this?

Thanks in advance,

  • Itai

We need users who have removed pulse to help here. I try to support ‘default’ openSUSE configurations, and now all my testing is on PC’s with pulse still enabled. Hence a user who has removed pulse should help (as I have not tested/worked with a PC coming with pulse and then removing it).

What I can do is point you to the diagnostic information providing script:


please do NOT post its output here. It will needlessly clutter this thread. If you wish to share the diagnostic information with other users, then when running that diagnostic script select the SHARE / UPLOAD option and after it has uploaded the diagnostic information to an alsa paste site, post here the URL/web-address where that information is located.


Indeed, that scrips outputs quite a bit of data. Here is it:

Not that I know much about PulseAudio or ALSA but since removing PulseAudio solved my initial problem, that is my current state.
If there is anything I can do to help test, let me know.


Well removing pulse is a problem … It is for me. … I do NOT test without pulse. I’ve read many posts of users who claim removing pulse is a magical solution, but I don’t see them chiming in to help when it doesn’t work by doing so … at least not on this thread do I see them.

I have absolutely NO IDEA now as to what your setup may be having removed pulse. So I can not provide precise suggestions.

I can see your mixer is setup very strange and can only assume you know what you are doing there:

**!!Amixer output**

!!-------Mixer controls for card 0 [SB]

Card hw:0 'SB'/'HDA ATI SB at 0xfe7f4000 irq 16'
  Mixer name	: 'Realtek ALC888'
**Simple mixer control 'Front Mic',0**
  Front Left: Playback 25 [81%] [3.00dB] [on]
  Front Right: Playback 25 [81%] [3.00dB] [on]
**Simple mixer control 'Front Mic Boost',0**
  Front Left: 1 [33%] [10.00dB]
  Front Right: 1 [33%] [10.00dB]
**Simple mixer control 'Capture',0**
  Front Left: Capture 19 [61%] [12.00dB] [on]
  Front Right: Capture 19 [61%] [12.00dB] [on]
**Simple mixer control 'Capture',1**
  Front Left: Capture 0 [0%] -16.50dB] [off]
  Front Right: Capture 0 [0%] -16.50dB] [off]
**Simple mixer control 'Digital',0**
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]
**Simple mixer control 'Input Source',0**
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Front Mic'
**Simple mixer control 'Input Source',1**
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Rear Mic'
**Simple mixer control 'Rear Mic',0**
  Front Left: Playback 0 [0%] -34.50dB] [off]
  Front Right: Playback 0 [0%] -34.50dB] [off]
**Simple mixer control 'Rear Mic Boost',0**
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

Your capture levels and mic boost are uniformly low. If it were me trying to record I would have them set higher. In some cases they are simply switched OFF for capture. In some cases you have the mic set for front mic, in other cases the rear mic. What is your logic here ?

I also note its an ALC888 and I note in the diagnostic script dmesg

    9.990245] ALSA patch_realtek.c:1277 realtek: No valid SSID, checking pincfg 0x4005e601 for NID 0x1d
    9.990247] ALSA patch_realtek.c:1293 realtek: Enabling init ASM_ID=0xe601 CODEC_ID=10ec0888

which suggests alsa may be having difficulty identifying a valid model option (SSID) …

So if you think it is alsa that is misconfigured, then you could try adding a model option in the /etc/modprobe.d/50-sound.conf file … the HD-Audio-Models.txt file is on your PC, but to make this easier I will list the content from that file for you for the ALC888 :

  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  macmini3	Macmini 3,1
  mba21		Macbook Air 2,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  imac91	iMac 9,1
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m540r	Clevo M540R (6ch + digital)
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT
  auto		auto-config reading BIOS (default)

and each of those options could be tested one at a time, with a restart of alsa sound driver in between each attempt … For example if one were trying 3stack-dig the line to add would be:

options snd-hda-intel model=3stack-dig

followed by a restart of alsa and by testing …

Anyway, I’ll stop here and move back to lurk mode in this thread. One of forum experts who claim ‘no pulse is the solution to sound problems’ need to chime in here and help with your setup as they will know better than I what one is left with after pulse is removed.

Good luck.

Thank you for looking at this!

Removing pulse audio was magical to me because I had no idea why it did not work with it and I have no idea why it works with out :wink:
Even more puzzling, when I was running OpenSUSE 11.2 64-bits, I was using PulseAudio and it was working perfectly.

You say my mixer settings are strange… and you are probably right. I have truly no idea what these settings are, so there is no logic.
I did not edit them myself either, so I can only assume some application or setup did it at some point. Is there a way to reset this to
some sensible default? That might go a long way, particularly when you say some are set to OFF or uniformly low.

My system seems simple to me since I only have onboard audio (AMD 785 NB & 710 South-Bridge) and an ATI graphics card with
HDMI out (so nothing to do with Mic). Nothing on the list you includes appears to match.

Thanks again!

You should have controls for those settings. What mixer do you have with pulse removed ?

Did you try mixers such as alsamixer ? Did you try the command line amixer ?

Where are all our ‘remove pulse audio is best approach’ experts pitching in to help ? :frowning:

Is /dev/mixer missing?

@oldcpu, I really have no issues with pulse audio but I use GNOME… and with the pulse audio equalizer from packman it works fine for my old ears :wink:

Yes! You got it! /dev/mixer was missing and, yes, I am on KDE now. When PulseAudio was working on 11.2, I was on Gnome.

There are 3 mixers I found: alsamixer (text mode), alsamixergui (gui) and kmix (gui). This last one was recommended on other thread relating to my Gnome to KDE transition but not to removing PulseAudio :slight_smile:

Thanks everyone!