No audio in SMPlayer, but Audio present in Youtube

Hi all
I am experiencing a strange problem in recently installed openSUSE Leap 42.1. But audio is present in online youtube videos in firefox. I have tried all the Audio output driver options in smplayer.
How should I rectify this fault?
Please guide.

have pavucontrol installed? if not do so and see where the sound is set to go when you play. Also check setting in smplayer

Further to gogalthorp’s advice, … with pulse audio in GNU/Linux, one can control audio volume, and also audio device selection, on an application assignment basis.

For example, on a PC with multiple sound devices, one can simultaneous have sound from application-a going to sound card-0 and at the same time have sound from application-b going to sound-card-1. They can be playing different media files or the same media file. Now imagine that one has no speakers connected to sound-card-1. That would mean application-a has sound (with sound card-0 and its connected speakers) and application-b has no sound (with sound-card-1 as it has no speakers).

So you may ask, how does one control that assignment ?

By following gogalthorp’s advice, and install “pulse audio volume control” application (known as ‘pavucontrol’). With that, one can direct where the sound from an application is to be sent.

Have you tried playing a you tube video in smplayer if it give you audio?

Thanks to all of you. I got the sound working in smplayer.
Thanks &

Happy Diwali to all of you.

Could you please tell how did you solve it?

I, for example, have the same problem and can’t solve it.

By the way, just solved it. In my case I had to go to Options > Preferences and change the path of the Mplayer/mpv executable from “/usr/bin/mpv” to “/usr/bin/mplayer2”.

That solved the problem for me.