no audio in 11.1 beta5 running on VMware

I installed 11.1 b5 today on my Intel Mac mini on a virtual machine in vmware fusion. The good news is that I was able to get vmware tools fully operational, including drag and drop of files between host and guest. The bad news is I couldn’t enable sound, and this is the first problem of this type that I have encountered on a virtual machine. I tried three different music players (Amarok, Banshee and Rhythmbox) with downloaded codecs, but either no audio or “fast-forward” audio along with very fast playing. I also tried uTube videos, which gave me “fast-forward” audio and jerky video. I tried reinstalling 11.1 twice to check if something I added to the basic installation was causing the problem. The problem was there from the start.

Anyone else experience this problem? By the way, I have openSUSE 11.0 running on a VirtualBox vm on the same computer, as well as a PPC version on an Apple PowerBook. None of these have any audio/video problem.

Before messing with codec’s IMHO it is always best to see if you have basic sound.

Here is my “stock” reply to users having audio problems. … Some of it might be applicable to a virtual machine install (but likely not all):

Try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

To test if your sound is working, I recommend you try copy and pasting the following into a gnome-terminal or a kde konsole:speaker-test -Dplug:front -c2 -l5 -twavyou should hear a lady’s voice saying “front-left”, “front-right” five times. Note Linux is case sensitive.

If that does not work, try a shorter form version:speaker-test -c2 -l5 -twavIf you hear sound (ie if you hear the lady’s voice), then please post here, let us know this fact, and explain more as to what your sound problem might be.

If that does not work, and if you do not hear the lady’s voice, then we need more information to help solve your problem. To provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O && bash 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Once I have that information, I believe I may be able to provide helpful recommendation(s).

Thanks for the reply, oldcpu. I went through the diagnostics you suggested, including the audio troubleshooting guide. Nothing in the guide helped, and the two speaker tests produced no sound. One interesting thing was that in reconfiguring as per guide, listening to an mp4 in Amarok at least showed the song proceeding at normal speed (watching the elapsed time meter), although still no sound. The wget test you suggested recorded the information in this url.

The output to your script is as follows:
mylogin@linux-vegt:~> rpm -qa | grep alsa







mfox@linux-vegt:~> rpm -qa | grep pulse














mfox@linux-vegt:~> rpm -q libasound2


mfox@linux-vegt:~> uname -a

Linux linux-vegt #1 SMP 2008-11-11 15:15:33 +0100 i686 i686 i386 GNU/Linux

mfox@linux-vegt:~> cat /etc/modprobe.d/sound

options snd slots=snd-ens1371

LHB6.FGsk7T8RAT9:Creative Sound Blaster AudioPCI64V, AudioPCI128

alias snd-card-0 snd-ens1371

Does this tell you anything that can help me? I recognize the extra problem associated with this being a virtual machine. :\

You could try removing all your pulse audio applications.

Aside from that, then sorry, I can’t help.

I looked, but I have never used vmware, nor have I ever tried to run Linux in a virtual machine (I typically run WinXP in a virtual machine on a Linux host). So nothing obvious springs to mind.

My best advice is to quadruple check your mixer. Also try digital audio (which i see you have switched OFF).

I believe I fixed it, but what I did could be considered random. I went to the Sound Configuration panel and added a dummy soundcard. Why this worked I have no idea, but now I can play music. Thanks anyway, oldcpu; without your advice I wouldn’t have even known to check this sound config panel. :slight_smile:

Actually, it seems that I have to re-edit the sound configuration panel every time I reboot because the numerical value for the dummy ALSA soundcard is not retained. Deleting and then adding it again does the trick, but there’s clearly something wrong here.

You should be able to find out what the configuration is after entering this “dummy sound card”. When your sound is working what do you get from:
cat /etc/modprobe.d/sound
and also, from:lsmod | grep snd
What else can you tell us about this “dummy soundcard” ? Are you certain that a simple: su -c ‘rcalsasound restart’ #after rebooting, won’t do the trick ?

name@linux-vegt:~> cat /etc/modprobe.d/sound

options snd slots=snd-ens1371,snd-dummy

LHB6.FGsk7T8RAT9:Creative Sound Blaster AudioPCI64V, AudioPCI128

alias snd-card-0 snd-ens1371

uniq.unknown_key: Dummy soundcard

alias snd-card-1 snd-dummy

name@linux-vegt:~> lsmod | grep snd
snd_pcm_oss 47488 0
snd_mixer_oss 18560 1 snd_pcm_oss
snd_seq_midi 11264 0
snd_seq_midi_event 10880 1 snd_seq_midi
snd_seq 56512 2 snd_seq_midi,snd_seq_midi_event
snd_dummy 13824 0
snd_ens1371 26756 1
snd_rawmidi 26112 2 snd_seq_midi,snd_ens1371
snd_seq_device 11404 3 snd_seq_midi,snd_seq,snd_rawmidi
snd_ac97_codec 104356 1 snd_ens1371
ac97_bus 5760 1 snd_ac97_codec
snd_pcm 83076 4 snd_pcm_oss,snd_dummy,snd_ens1371,snd_ac97_codec
snd_timer 25352 2 snd_seq,snd_pcm
snd 61624 13 snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_seq,snd_dummy,snd_ens1371,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc 12296 1 snd_pcm
gameport 15372 1 snd_ens1371
soundcore 11080 1 snd

Yes, this did work and saves time from going back to the sound panel; thanks! Is there any way to automate this command so it does it automatically at startup?

I noticed another minor problem with 11.1 running on vmware, but I’ll make it a separate post.

Put the line:
rcalsasound restart
inside (at the end) of your /etc/init.d/boot.local file *

Yes please, this thread likely will only garner attention from those want to help sort a audio problem with vmware and openSUSE-11.1.*

I installed RC last night and unfortunately, I get the same problem - no sound without adding the dummy ALSA driver. Doing so brings back the sound, but there is one minor problem that wasn’t manifested in b5. If you quit an audio application (e.g., Rhythmbox or Banshee) while music is playing, you get a brief burst of noise before it quits. No big deal, but it shouldn’t happen.

try VLC media player VLC media player for openSUSE
it works perfectly under VNWare

Welcome to the forums.

Some remark: you reopened a thread from 2008. The problem raised in this post may no longer exist.

Still, we value your contribution. Welcome once again.