No audio from certain apps, gstreamer problem??

I mainly use KDE apps only, but a problem in Amarok is forcing me to look elsewhere. I’m not sure how long this issue has existed but I’m unable to play any sound from certain applications.

So far Rhythmbox, Exaile, Guayadeque, Firefox and Songbird don’t produce any sound. Amarok, Juk, SMPlayer and VLC are fine. As the apps with problems are mainly Gnome/GTK apps, I’m suspecting a gstreamer problem.

My desktop is 11.3 x64 with KDE 4.6 beta 1. I’ve tried all three phonon backends, although Xine is the only one that works with Amarok. Pulse wasn’t installed, I tried installing it but it didn’t even detect my SPDIF output, so no audio whatsoever. Hardware is ATI HD4200 onboard sound card through the SPDIF output. Gstreamer is installed.

Does anyone have any suggestions, where to start the troubleshooting. Is there any gstreamer config?

OK, I’ll give it one bump, and then it’s a reinstall :frowning:

Hi,

Use the script of jdmcdaniel3 to check what is missing. The post #40 is the latest version : MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

Check the PCM channel on your mixer settings.

Firefox and Amarok typically use the same backend, which is usually xine.

If Amarok has the xine backend selected, and if in KDE under KMENU > Configure Desktop > Multimedia > Backend you also have the xine backend selected, then likely your problem with firefox is

  • PCM volume dynamically set it set to 0 and you need to move it up (as noted by elski to test)
  • You are trying to play sound from more than one application at a time, and some other application than firefox was running 1st and it seized the audio device and refused to share it (in which case you need to either configure the ALSA API for each of the multiple applications to use the ALSA API and share audio (works only if your hardware allows this) or use/configure pulse audio to share audio (I can’t help there) or simply close the offending multimedia application
  • Your order of sound devices in KMENU > Configure Desktop > Multimedia does not match the order of sound devices in YaST > Hardware > Sound, nor match the order of sound devices one can read from running the diagnostic script “/usr/sbin/alsa-info.sh”.

Unless you have good reason to believe you completely messed up your audio configuration/openSUSE configuration, IMHO a re-install will not solve anything.

Thanks for all the replies.

What a fantastic idea for a script MMCHECK is! Every distro should have one.
Apart from anything else it’ll bring down the time it takes to configure new installs.

OK, I went through all the steps:

Had lots of apps using the VideoLan repo, removed most of them. Apart from libdvdcss, I couldn’t find any alternative repos for: libmpeg2convert0, libupnp4 and phonon-vlc, so I’ve kept them.
K3B is installed from KDE:Build, not packman and totem is missing. Apart from that, everything is OK.

Phonon backend is set to xine, and the playback device is set to SB [HDA ATI SB] VT1708S Digital SPDIF.
I do occaisionally get messages about failing over audio devices, but I think that has to do with me connecting to the PC over NX.

Restarted the PC and tried playing a track from Rythmbox on the console, immediately after booting up. No audio.
That was before any other audio app was opened, or remote sessions were started.

Amarok still works, test sounds in KDE System Settings still work, and other apps. Nothing from Rythmbox or Songbird.
I checked the PCM levels using alsamixer from the terminal - everything seems fine.

Is it possible that gstreamer cannot use the SPDIF output? The pulse audio problem had me wondering. I think I had the same issue in a variant of mplayer - the sound card was detected, but only the HDMI and Analog output.

Couple of points. If you have apps installed from VideoLan and they are not in Packman - consider this: If you had followed the multi-media guide those apps would never have been installed, so remove them.
Also: You say you are using kde development, OK - But it requires considerable experience to do this with good result and without issue, no, actually let me re-phrase that: You will almost certainly have issues.

If you handed that machine to me, guess what I would do. Re-install it, but not to kde beta.

Fair point, I’ll remove them. Phonon-VLC didn’t work for me anyway.

I accept that issues are likely by installing unreleased/testing software (though not many by the beta stages).
But I’m not experiencing any problems with the KDE apps. Quite the reverse, it’s the Gnome/GTK apps from the stable repos that aren’t working.

But you use KDE and have your login manager etc as kde:
looks like this: http://dl.dropbox.com/u/10573557/Session%20Login/console.login.png

Do you have gnome installed or just some of it’s apps?

Sorry, I might have caused some confusion in one of my posts above.

My PC is basically an HTPC, connected to a home cinema amp via DVI + SPDIF.
It’s been running various linux distros for a few years, opensuse since 11.3.
KDE4.6 since the recent beta release.

I connect to it day to day over NX from my netbook, but for the purposes of this testing (and to rule out NX, which brings with it it’s own multimedia issues), I’ve been using the main PC - ie using the console. I didn’t mean to give the impression of a console login.

I don’t install Gnome, and I tend not to use GTK apps. I do try, but for my own personal tastes GTK just looks like a toolkit designed my Mothercare.:shame:

So I could understand issues being introduced with phonon or amarok, but not rhythmbox and songbird.

I have no idea as to what that means … ie no idea as to what app the playback device is set.

Can you provide output address/URL provided from running (with PC connected to Internet):

/usr/sbin/alsa-info.sh

and select SHARE/UPLOAD and post here the output URL/web-site address provided from running that

Did you confirm that the order of sound devices in KMENU > Configure Desktop > Multimedia matches the order of sound devices in YaST > Hardware > Sound.

I also suggested you check the order of sound devices one can read from running the diagnostic script “/usr/sbin/alsa-info.sh”. but I can not tell you did so.

Reference using the xine backend, ensure you have xine-ui installed, and run xine, then rightclick on xine window and select ‘settings’ > ‘setup’ and under ‘gui’ select ‘master of the known universe’ for ‘experience level’. Close xine. Start xine again and rightclick on xine window and select ‘settings’ > ‘setup’ and select ‘audio’ and ‘audio driver to use’ and change it to ‘oss’ and then close xine and restart your desktop.

Ok, disregard my above posts. They are for KDE-4.4.4 at the newest. I have no idea what sort of breakage KDE-4.6 is likely to cause and I am not interested in debugging KDE-4.6.

Apologies for wasting your time with KDE-4.4.4 suggestions

I think KDE4.6 is a red herring. I had the same issue with KDE4.5, and as mentioned before - kde apps are working fine. I think KDE4.6 is mostly about PIM, akonadi and nepomuk integration anyway.

I’ll try the steps you mentioned, and post back.

Have you tried enabling pulse audio in Yast > Sound

FYI: The login pic was just to illustrate the login screen, ignore the console login info

I’ll try all the above when I get back home in a couple of hours. Thanks everyone for their help so far.

OK, first test revealed something strange. KDE System Settings plays the test sound (as usual), but YAST - Sound produces no test tone on either card. SBx00 Azalia (Intel HDA) or AMD Technologies Inc card. There’s none of the detailed output devices you get in the KDE Settings.
I’ll run the alsa script next.

Alsa info URL:

http://www.alsa-project.org/db/?f=7dd57fa37265fd9d514a96724263eb2238898da2

I’m working through some of the suggestions in the forum sticky, and speaker-test and sudo speaker-test produce nothing. Phonon still works fine, though.

I suppose that means its an alsa problem rather than gstreamer.

I see three possibilities (although there could be others).

1st - I note:

!!PCI Soundcards installed in the system
!!--------------------------------------

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]

Which means you need to ensure KMenu > Configure Desktop > Multimedia has same order, and YaST > Hardware > Sound same order.

2nd - I also note your hardware has a Codec: VIA VT1708S

There is a bug report on that hardware audio codec on bugzilla here: Access Denied

3rd - Your cutting edge KDE-4.6 has caused problems. Compared to KDE-4.4.4 it has very very VERY little testing with audio.

I really don’t think this is the problem. Audio within KDE just works. I suppose I could test it by booting to the console and doing speaker-test.

That’s exactly how they appear in YAST > Sound. In System Settings > Multimedia
they appear as HDA ATI SB VT1708S (SPDIF then Digital then Analog), followed by HDA ATI HDMI.
That seems to mirror the alsa-info.sh:


0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe6f4000 irq 16
1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe8e8000 irq 19

Interesting. I have the same motherboard as the person in the second last comment. They said they had sound, but has issues with mixers.