No audio from built-in CD and external sources

There is no audio output to the speakers when listening to, or while recording from Line-in. Enabling software sound playthrough in Audacity did not help. Audacity simply froze.
But I can make fine recordings from Line-in and play the recorded files.

Also no sound from cd-audio. KsCD begins playback, but no sound. Only VLC works with cd-audio.
Maybe some slider settings that I missed?

This is what I did so far:

Advanced Linux Sound Architecture Driver Version 1.0.20

00-00: CMI9880 : CMI9880 : playback 1 : capture 2
00-01: CMI9880 Digital : CMI9880 Digital : playback 1 : capture 1│

louis@linux-6ozx:~> cat /proc/asound/modules
0 snd_hda_intel

louis@linux-6ozx:~> cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf0100000 irq 16

louis@linux-6ozx:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel

u1Nb.Z0k+2ettRF8:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel
louis@linux-6ozx:~>

(Kernel 2.6.31.12-0.2-default i686 , KDE 4,3,5)

check your mixer settings. Its possible to add addition mixer controls in kmix via settings > configure channels.

A few possibilities come to my mind

  1. KsCD is looking at the wrong device or
  2. KsCD may have a wrong setting … there was a time when one needed to select a control in KsCD to configure it to use a digital connection , and I do not know if that is till the case , or
  3. KsCD is using a different output sound daemon/server from vlc, where the vlc one is configured properly the and KsCD one is not

I have not used KsCD in many years, so I do not think I can help with KsCD specifics.

I can only point you at this thread:

KsCD won’t play CDs in SATA drive - openSUSE Forums

All started with the missing sound from a Line-in device. Only then I noticed there was no cd-audio either (which is not a Sata-drive).

Meanwhile all channels enabled with Kmix. Several surround-channels, PCM, IEC 958 Default PCM, Digital, Capture, Capture 2 and two Input channels. No muting.