No Audio - Dell Inspiron 3442

I am a Dell Inspiron 3442 notebook owner. I have installed the openSUSE 13.2 XFCE version but I am having problems to configure the audio. I have installed PulseAudio and pavucontrol. I already tried to use YAST > Hardware > Sound. There, I am capable to hear a sound while clicking on Test button, but it does not work in any other place.

I tried:

zypper install alsa-firmware

The firmware was installed with success. Then, I restarted my system.

When trying:

speaker-test -Dplug:front -c2 -l5 -twav

or

speaker-test -c2 -l5 -twav

It does not work. I receive the output:

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

The following does not work too:

rcalsasound start

Gives as output:

If 'rcalsasound' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf rcalsasound

Then I tried;

cat /proc/asound/version

Output:

Advanced Linux Sound Architecture Driver Version k3.16.7-7-desktop.
tales@linux-vysd:~> cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel

tales@linux-vysd:~> cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xf7e14000 irq 62
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 61

Thank you, in advance.

This command:

head -n 1 /proc/asound/card0/codec*

Gives:

tales@linux-vysd:~> head -n 1 /proc/asound/card0/codec*
Codec: Intel Haswell HDMI

I can not find codec info at /usr/src/linux-3.16.7-7/Documentation/sound/alsa/ALSA-Configuration.txt. I was following: https://en.opensuse.org/SDB:Intel-HDA_sound_problems, but I could not solve it.

p.s.: while trying alsamixer nothing works there but ESC button. https://forums.opensuse.org/images/smiliesnew/sad.png

My alsamixer screen:

http://s3.postimg.org/tws2njste/Screenshot_000.jpg

F3, F4, F5, upArrow, downArrow, + or - are not working. I can not change levels. ESC, TAB, leftArrow and rightArrow are working.

To help you to help me, I executed the following commands:

http://s9.postimg.org/i6ep6fkku/Screenshot_001.jpg

tales@linux-vysd:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel
# 3hqH.XGhO0oJr5T7:Intel Corporation
alias snd-card-1 snd-hda-intel
# u1Nb.m0PW7HQrF99:Lynx Point-LP HD Audio Controller
alias snd-card-0 snd-hda-intel

/usr/sbin/alsa-info.sh gives the following address:

http://www.alsa-project.org/db/?f=3daff06c25814dc08220625e8f47c60a02ceab18