No audio CD playing under KDE4 in 11.1

Since I updated to 11.1, I cannot access any audio CD under kde4 (this is just one of a long list of problems with 11.1, as many others have pointed out here …)

I can play CD in kde3, but not with kde3 apps (i.e amarok 1.4) under kde4. The errors message is that the mrl /dev/sr0 cannot be accessed. The audio cd is not even visibile under sysinfo:/ (while sysinfo:/ shows the cd audio correctly under kde3).

I tried checking all my multemedia packages, updating, adding myself to the audio group, to no avail …

any idea? Thanks!

There is a bug in 11.1 that will likely take a month or more before it is fixed. That bug is related to permissions on CD/DVD drives.

Try adding your users to group “cdrom” and group “disk” and then restart your PC and try again.

This can be done by:

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”. Don’t forget after exiting YaST, you need to restart.

If that does not work, there are more suggestions here to work around this temporary problem: Solved : K3b Problem with Normal User on openSUSE 11.1 | Spirit of Change

thanks! As soon as I will be able to reboot the computer (i am in the middle of a long download right now), I will post the result …

ok, now i can play audio cds under kde4.

Thanks a lot indeed!

just a minor point: while now i can play audio cds with kscd under kde4, amarok still has no option to play audio cds …

any known way to fix this?

I recommend you start a new thread on this question.