No ATI drivers after installing new kernel

In order to get my external usb drive to shutdown when my computer is powered off, I have always had to add a patch to the kernel source, recompile and reinstall this new kernel. I just got finished doing this for openSUSE 11.0 and the compiling and installation went fine and the fix for my usb works. The only problem that I’m seeing now is that I can’t seem to get the ATI-fglrx drivers working. I tried reinstalling “ati-fglrxG01-kmp-default” and “x11-video-fglrxG01” from the repositories and running the commands “aticonfig --initial” and “sax2 -r” but this hasn’t helped.

In case it matters, the source that I used to compile my new kernel was “” from the openSUSE-11.0-Updates repository.

If I boot into my original kernel, everything works fine.

One other thing that may be of importance. I’m not even able to activate the Desktop effects. I get the following message.

Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.

Could anyone give me some pointers on how to fix this problem?

The kernel update was a mistake

As a result of the update you will need to reinstall the ati drivers. Though you could just keep using your custom kernel and remove the from grub


I checked the link you supplied and that was for kernel The kernel version that I’m having the issue with is

I already tried to reinstall the ATI drivers and that didn’t help. I didn’t remove them before reinstalling, I just did an “update” from yast install. Would removing the drivers completely and then reinstalling help?

Just two cents…when you have a cantankerous driver it is always best to remove it completely from the system rather then just try to reinstall.

What ATI card do you have? Without any error logs to review from X or messages it is kind of hard to offer any detailed assistance. However, although I am for using the repositories, ATI has been notoriously slack at their support for Linux. They are getting better, but IMHO they are behind Nvidia. Have you tried downloading their Linux driver from their web site and compiling it against your new kernel?

Drivers & Software


I guess I’ll try to remove them completely from my system and then reinstall. Do you know if I need to remove both “ati-fglrxG01-kmp-default” and “x11-video-fglrxG01”? I’m assuming that I need to remove both.

The card that is installed in my machine is the ATI Radeon X600. Up to this point I haven’t had any issues with the ATI drivers. Apparently installing the kernel that I compiled broke something:(

What advantage is there to downloading the driver from ATI’s site and compiling it against my new kernel? I really don’t understand how a different kernel effect the video driver. I don’t have much knowledge in this area.

Well I completely removed both “ati-fglrxG01-kmp-default” and “x11-video-fglrxG01”, rebooted and then reinstalled them from the repo’s and it appears that the driver still doesn’t work. This is what I get with fglrxinfo

gumper@linux-4ezw:~> fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3)

If I’m not mistaken the “Mesa” refers to the standard drivers.

I guess my next step is to try to download the files from ATI and install that way.

Whoppee!!! Installing the drivers downloaded from ATI’s site took care of it:)

i guess the same problem occured to me some days ago, i didnt have time to ask about it yet (and was not sure what caused it but now i guess i know)

I had ATI drivers installed and 3d worked (glxinfo was indicating name of my graphics card (radeon 3100) and those plenty lines of output info).

However, things changed after configuring PPPoE internet (in dsl) to be started with kinternet. Something was being installed (and i believe it was kernel)

I noticed 3d stopped working occasionaly when my ‘solar wind’ screensaver turned on in kinda 1frame-per-second mode.

I did check and it was saying ‘mesa’. As well as sysinfo tells ‘no 3d support’

Though i still have my screen resolution (was unable before initial installation of ATI drivers).

I followed troubleshooting guide, with removing old drivers and reinstalling them… I think 5 or 6 times. Installing it through all possible ways described, automatic and manual, and no one was a success.
I get Mesa and no 3d support all the time.

(and despite im having 1280x800 resolution sax in yast indicates 800x600, maybe that just different error — didnt bother to check that when i had everything working fine)

:\ My difference from Gumper’s case is that i was using ATI latest drivers from ATI site since beginning, so that cannot be a salvation. So now I at least know for sure what must be the problem yet dont know how to solve it.

There are two more points about manual installation, during compiling driver it does give me few warnings (not errors just warnings) in the proccess (how to log/get logs of that to post btw?), and when i do sax2 command in the prompt, it doesnt finish by itself but kinda waits for some input, however i have no clue what to type and how so i would simply finish it with Ctrl-C.

Do you have the dependencies the the installer needs?

System Requirements

Before attempting to install the ATI Catalyst™ Linux software suite, the following software must be installed:

* XOrg 6.8, 6.9, 7.0, 7.1, 7.2 or 7.3
* Linux Kernel 2.6 and above
* glibc version 2.2 or 2.3
* POSIX Shared Memory (/dev/shm) support is required for 3D applications

The ATI Catalyst™ Linux software suite no longer provides precompiled Kernel Modules; all installations require GCC compiler and kernel-headers or kernel-source in order to enable 2D and 3D acceleration.

For best performance and ease of use, AMD recommends the following:

* Kernel module build environment - should include the following:

Kernel source code: Either the Kernel Source or Kernel Headers packages

* The rpm utility should be installed and configured correctly on your system, if you intend to install via RPM packages

The following packages must be installed in order for the ATI Catalyst™ Linux driver to install and work properly:

* XFree86-Mesa-libGL
* libstdc++
* libgcc
* XFree86-libs
* fontconfig
* freetype
* zlib

I had the same issue with the sax2 -r command. It would go to a login screen. I didn’t enter anything but just let it finish. It would eventually go back to the desktop (after about 30 - 60 sec) and the sax2 window would appear. When I exited that it would ask me if I wanted to save before exiting and I did.

As Foresthill suggested, did you have all the dependencies?

Yes i have v.11 so everything does match, and before the very first drivers installation I had all required packages added according to the guide.

It is the same system where I had everything installed and worked perfectly, so that can’t be the point.

Where did you get the kernel source from and are you certain that it matched what was installed in your machine?

Sorry I can’t offer more help, I know how frustrating it is when something doesn’t work correctly.

Glad to hear that the ATI drivers worked. Reference your question, distribution kernels are tweaked specifically for that said distro. They have to include elements and drivers designed around lots of different hardware support into their kernel build. Sometimes their code does not support or interact with 100% reliability for a specific card. Generally speaking you do not have any problems.

Video cards are pretty cantankerous. ATI is only coding their video kernel driver to support their specific hardware. A manufacturer’s driver inserted into the Linux kernel is usually the best way to go because they are hooking their controls for their card. Same concept as in Windows…you load on the manufacturer’s driver for best operation.

I’ve just got kernel source updated (via yast), this time rpm command passed clearly (no warnings etc), however sax2 again says something like ‘your current configuration will not be read in’, then i wait for a while, press ctrl-c, reboot and no 3d :frowning: