No APCI Kernel. Automatic power down possible?

Is it possible to have automatic power down with the No APCI Kernel?

The only way I could get openSuSE 11.1 to install on an old MSI motherboard was using the no APCI option. As it’s my wife’s “new” computer I would be best if she didn’t have to power it down manually. Can it be done?

Do you mean ACPI=off
or noapic

Further to that, I’m not entirely sure I understand what it is you are asking. Sorry.

When it his run level zero there is nothing to do. You have to hit the power button to turn it off.

No message is sent to power off the computer.

“No ACPI support in kernel”

When you boot with Failsafe, is this still the case when selecting Shutdown?

No. I tested and it shuts down normally when failsafe is selected from the boot menu.

Now. See all the kernel arguments in the failsafe boot? Use one of those at a time with the default boot. Let me try and walk you thru:

First let’s see the info in /boot/grub/menu.lst:

su terminal and do:

cat /boot/grub/menu.lst

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.23-0.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.23-0.1-pae root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 resume=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part5 splash=silent showopts vga=0x367
initrd /boot/initrd-2.6.27.23-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.1 - 2.6.27.23-0.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.23-0.1-pae root=/dev/disk/by-id/ata-ST9160827AS_5RF16D1B-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x367
initrd /boot/initrd-2.6.27.23-0.1-pae

see the difference?

I would try apm=off first.

Anyway, to try, when you boot up and get the grub menu, you need to pause the timer by moving the down arrow. Now move to the default boot. Use your keyboard and type apm=off, the text will be added to the boot line. Then hit enter.

Keep trying different options and or combinations. See if you can find what works. If you do. You can add the argument permanently to menu.lst

First pasting this bit and am going to try booting as suggested next

linux-jaqn:/home/ann # cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Sun Jun 21 05:54:32 PDT 2009

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.23-0.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.23-0.1-pae root=/dev/disk/by-id/ata-ST3300831A_3NF15KV7-part2 acpi=off resume=/dev/disk/by-id/ata-ST3300831A_3NF15KV7-part1 splash=silent showopts
initrd /boot/initrd-2.6.27.23-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.1 - 2.6.27.23-0.1
root (hd0,1)
kernel /boot/vmlinuz-2.6.27.23-0.1-pae root=/dev/disk/by-id/ata-ST3300831A_3NF15KV7-part2 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe
initrd /boot/initrd-2.6.27.23-0.1-pae

###Don’t change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (fd0)
chainloader +1

FlameBait adjusted his/her AFDB on Monday 22 Jun 2009 04:36 to write:

> ###Don’t change this comment - YaST2 identifier: Original name:
> linux###
> title openSUSE 11.1 - 2.6.27.23-0.1
> root (hd0,1)
> kernel /boot/vmlinuz-2.6.27.23-0.1-pae
> root=/dev/disk/by-id/ata-ST3300831A_3NF15KV7-part2 acpi=off
> resume=/dev/disk/by-id/ata-ST3300831A_3NF15KV7-part1 splash=silent
> showopts
> initrd /boot/initrd-2.6.27.23-0.1-pae
>
> ###Don’t change this comment - YaST2 identifier: Original name:
> failsafe###
> title Failsafe – openSUSE 11.1 - 2.6.27.23-0.1
> root (hd0,1)
> kernel /boot/vmlinuz-2.6.27.23-0.1-pae
> root=/dev/disk/by-id/ata-ST3300831A_3NF15KV7-part2 showopts ide=nodma
> apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off
> highres=off processor.max_cstate=1 x11failsafe
> initrd /boot/initrd-2.6.27.23-0.1-pae

at boot just add the different options from the failsafe to the normal boot
one at a time every boot till it works, when you are at the grub screen just
start typing it will be echoed on the text line on the screen this way it
will only last for thet boot .

I would start with apm=off if that don`t work then try one of he others.

HTH

PS. There are loads of other options for the acpi= as well but we will leave
that for now.


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

well

apm=no was no joy.

I wonder If I am screwing up by having plug and play aware OS set to OFF in Bios? Usually OFF is how you have it set for Linux.

FlameBait adjusted his/her AFDB on Monday 22 Jun 2009 08:36 to write:

>
> well
>
> apm=no was no joy.
>
> I wonder If I am screwing up by having plug and play aware OS set to
> OFF in Bios? Usually OFF is how you have it set for Linux.
>
>

No harm in changing it, if the machine baulks then just change back.

Did you say that you can shutdown as root?

In a console or terminal as root type:

shutdown -h now

If that works then it is a config prob
:

Yast>System>/etc/sysconfig editor>desktop>Display
Manager>DISPLAY_MANAGER_SHUTDOWN set to all.

This is normally set to root by default.

HTH

Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

No a shutdown -h now as root doesn’t work. Tried that one already heheheh

Went through the list of the failsafe stuff and none of them by themselves led to the system shutting down as it does when they all get used once. I hope I didn’t make any typos but I had a printed copy of my /boot/grub/menu.lst to work from so I don’t think I did.

PNP aware OS set to yes didn’t help so it’s back to no.

So you need to try some combinations - even try adding

noapic and or acpi=off

or keep all the failsafe except the x11failsafe

Very good
I am going to try and get some much needed sleep and go at it again “in the day light as they say”

Thanks

No worries, I take it you are in North America?

Night Night/lol!

FlameBait adjusted his/her AFDB on Monday 22 Jun 2009 10:36 to write:

>
> Very good
> I am going to try and get some much needed sleep and go at it again “in
> the day light as they say”
>
> Thanks
>
>

when you are back if you cannot get it to work and if you have the kernel
source installed have a look in the documentation under:

kernel-parameters

Or view online

IIRC the

acpi=noirq

Helped some people.

There are a rook of different params for ACPI and others that might help
unfortunately I will be away in an hour till the weekend without this here
interwebble so cannot post till then.

HTH

Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

baskitcaise adjusted his/her AFDB on Monday 22 Jun 2009 12:11 to write:

Oh Oh OH!! … pick me… pick me, waving hand

There is another param

noapic

that might help, note that is not NOACPI it is NOAPIC

IIRC I had to use that a while ago on one of my older machines to get the
shutdown to work.

Now I must be off…


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

noapic
Yep, I already suggested that @baskitcaise

caf4926 adjusted his/her AFDB on Monday 22 Jun 2009 14:16 to write:

>
> caf4926;2002696 Wrote:
>> So you need to try some combinations - even try adding
>>
>> noapic and or acpi=off
>>
>> or keep all the failsafe except the x11failsafe
>
> noapic
> Yep, I already suggested that @baskitcaise
>
>

well does show that I am keen…

waiting for my lift to come and take me away from the ratrace for a few
days, mmmm… Mountains, clear skies, fresh air, no phones, computers,
tv`s. Blisss and it will probably pour down till Fri.


Mark
Caveat emptor
Nullus in verba
Nil illegitimi carborundum

Weather is lookin’ good for you. Enjoy!