No access to Yast from kde on tumbleweed


After updating Tumbleweed, it is not possible to use Kde’s Yast. Do not accept the root password anymore (Permission denied), the password is correct.
The error occurs when I launch yast from the icon in the K menu. The Authentication window appears but the password is not accepted.
From konsole as root, I run the command # usr / bin / xdg-su -c / sbin / yast2 so that Yast starts without problems.

Does anyone have any idea what’s going on.



I’m pretty sure that I saw a bug report about that, yesterday.

If I recall correctly, it is due to a problem in pam_kwallet, and if you uninstall pam_kwallet the problem will go away. Uninstalling pam_kwallet was suggested as a temporary workaround until the problem is fixed.

As a cross check, I just tried running Yast from the KDE menu.

It works fine for me on Tumbleweed, just updated to 20210227. However, I do not have pam_kwallet installed here.

Note: I experimented with pam_kwallet back with Leap 15.0 and with Tumbleweed at around the same time. Initially, it seemed good. But then reports started to come in of problems with “su”, “sudo” and other commands. So I uninstalled pam_kwallet, and I have kept it uninstalled since then.

Yast opened for me but software management didn’t
I ran updates from the konsole and it’s all good again

2021-03-02 22:27:20|install|google-chrome-stable|89.0.4389.72-1|x86_64||google-chrome|7954d344506f7f144ecfa6c873bd897a1501f3769580be44bdea14493d34cc25|2021-03-02 22:27:20|install|libyui-ncurses-pkg15|4.0.1-1.1|x86_64||repo-oss|eb51954459a406f24cdeb9db17be076a1593e10e297add64a9f494014e78472c|
2021-03-02 22:27:20|install|libyui-qt15|4.0.3-1.1|x86_64||repo-oss|fc17abb9a349c4e03e6ddba5c2edee9d3ae73912ba005bf64894d060287e5e29|
2021-03-02 22:27:20|install|libyui-qt-pkg15|4.0.1-1.1|x86_64||repo-oss|9833ea6bbc5ce86076882868bb7c332a8315bd698651e1d8a50af2fb3d80a738|
2021-03-02 22:27:20|install|libyui-qt-graph15|4.0.1-1.1|x86_64||repo-oss

Thanks to nrickert.

I removed the pam_kwallet and everything went back to normal.


I’m glad to have helped.