No 3d Support or graphics accelleration


I’ve recently started using VMware Workstation 10 on my Opensuse Installation. I have received a VM from my school that I use. However, when I start the VM I get a couple error messages. The first one states “No 3D support is available from the host.” and the second says “Hardware graphics acceleration is not available.”, and tells me to update my OpenGL drivers.

I assume this has to do with the fact that my laptop is running bumblebee in order for the Nvidia Optimus card to switch. Has anyone got 3D support and hardware acceleration working in VMware Workstation 10 on an Optimus laptop?

Thanks for anything!


I had exactly the same issue. Got a Lenovo W530 with Optimus. With Bumblebee installed, 3d worked ok with Wine, but NOT with VMWARE.

Here is what worked for me:

  1. Added the following repo:
  2. Using Yast -> Software Mangement->view->Repositories
    Switch system packages to this new repository
    (reboot was needed to pick up changes)
  3. Using a text editor, added the following line to the .vmx file for the virtual machine: = “TRUE”

Once I did the above, I no longer get the “no 3d support” message from VMWare. I DO get a warning about “GPU may cause issues”, but 3d support seems to work.
So far, no other side effects have surfaced.
Note that this is the 32 bit Suse 13.1. I Have not yet tried this on a 64 bit system.



I’ll give this a try! Thank you!