no 2d acceleration on radeonhd driver

I have a AGP Radeon HD3650 RV635. I’ve tried using the ATI Catalyst 9.12 drivers, and they work ok with 2D/3D DECCELERATION. 3D works but it’s extremely slow, maximizing a window takes 10secs, videos skip when played in fullscreen. Disabling Compiz doesn’t help much, in 2D mode, windows redraw slowly.

I’m trying to install the open radeonhd drivers, and so far, it’s booting into gnome, but it’s barely usable. There is no 2D acceleration (log says ShadowFB only) and glxinfo reports:

name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  135 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  16
  Current serial number in output stream:  16

I’m not really concerned with 3D performance, but video overlay acceleration and 2D desktop speed is important.

snips from Xorg.0.log


...
(II) RADEONHD(0): Found libdri 5.0.0.
(EE) RADEONHD(0): RHDDRIVersionCheck: drmOpen("radeon", "pci:0000:01:00.0") failed.
(WW) RADEONHD(0): RHDDRIPreInit: Version check failed. Disabling DRI.
(WW) RADEONHD(0): Falling back to ShadowFB acceleration
...
(WW) RADEONHD(0): RHDCSInit: CS for R600 requires DRI.

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "Screen0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option	    "Xinerama" "off"
EndSection

Section "Monitor"
	Identifier   "SyncMaster2343BW"
	Option	    "VendorName" "Samsung"
	Option	    "ModelName" "SyncMaster 2343BW"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	BusID       "PCI:1:0:0"
	Identifier  "RadeonHD3650"
	Driver      "radeonhd"
        Option      "AccelMethod" "exa" # default shadowfb
        Option      "DRI" "on"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "RadeonHD3650"
	Monitor    "SyncMaster2343BW"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Hello r8dhex
I’ve had the same problems with ATI and so, after a while working around with almost no success, I removed the ATI card and replaced it by a NVIDIA card;)…But I don’t know if you would like to do this, too…
There ar some good posts here in the forum abou ATI cards. Maybe you could try this one:
Generating catalyst 9.11 rpm’s on openSUSE 11.2 - openSUSE Forums
Perhaps this might solve your problem.
The other option could be to use the “older” driver, the ATI radeon?
Greetings ojio:)

I’d love to have an Nvidia card again, in fact I used to have a 6600GT on this system. However, my system is still on AGP and I couldn’t get any 2nd-hand nvidia card that is both a significant improvement to the 6600GT, and also didn’t cost too much.

I’ve already gone through the ATI Proprietary drivers, but they are horribly slow. Even 2D is slow. The opensource radeonhd drivers are not much faster, as of now. The older radeon drivers give me a black screen with a mouse cursor and nothing else.

As far as I understand it, lsmod doesn’t show me any drivers related to my card. Catalyst would have the fglrx kernel module, and the matching Xorg driver. Nvidia would have the nvidia-kernel, and nvidia-glx driver for Xorg. What’s the kernel driver for radeonhd?

Looks like you’re missing the DRI module… I think the fglrx installer removes it and doesn’t necessarily put it back once you get rid of fglrx. I had a similar problem when I switched to radeon from fglrx.

What I did to fix it was re-install the package “Mesa” through YaST. I would recommend that you should try the latest one by clicking here.

@r8hdex
same problem here before with ATI
maybe trying sax2 -r could be a solution? Booting the failsafe SUSE after installing radeon and running the sax2 -r in init3 solved my problem. Did you try this so far?