NNTP: Replied to a thread - got mailer daemon from Gmail

I just replied to a thread
https://forums.opensuse.org/showthread.php/507699-I-need-to-recover-generic-MBR-code-instead-of-grub-code/
The post didn’t appear on web interface. Later got mailer daemon with
contents,

Delivery to the following recipient failed permanently:

robin_listas@no-mx.forums.microfocus.com
<mailto:robin_listas@no-mx.forums.microfocus.com>

Technical details of permanent failure:
DNS Error: Address resolution of no-mx.forums.microfocus.com
<http://no-mx.forums.microfocus.com>. failed: Domain name not found

I’m using thunderbird as my newsreader app. I’ve also configured to read
gmail emails. My default smtp server is smtp.googlemail.com. The
openSUSE forum newsgroup is also configured to use it as smtp. Maybe
that’s reason for failure.

Earlier I had used my email id as email address for newsgroup. Now I’ve
changed it to vishy@no-mx.forums.microfocus.com
<mailto:robin_listas@no-mx.forums.microfocus.com>

What’s the problem with my settings? What should be smtp server.?


Akash Vishwakarma
openSUSE 13.2 KDE/MATE/xfce/enlightenment 19

On Wed, 27 May 2015 17:16:30 +0000, akash vishwakarma wrote:

> I just replied to a thread
> https://forums.opensuse.org/showthread.php/507699-I-need-to-recover-
generic-MBR-code-instead-of-grub-code/
> The post didn’t appear on web interface. Later got mailer daemon with
> contents,

Delivery to the following recipient failed permanently:
>
> robin_listas@no-mx.forums.microfocus.com
> <mailto:robin_listas@no-mx.forums.microfocus.com>
>
> Technical details of permanent failure:
> DNS Error: Address resolution of no-mx.forums.microfocus.com
> <http://no-mx.forums.microfocus.com>. failed: Domain name not
> found

>
> I’m using thunderbird as my newsreader app. I’ve also configured to read
> gmail emails. My default smtp server is smtp.googlemail.com. The
> openSUSE forum newsgroup is also configured to use it as smtp. Maybe
> that’s reason for failure.
>
> Earlier I had used my email id as email address for newsgroup. Now I’ve
> changed it to vishy@no-mx.forums.microfocus.com
> <mailto:robin_listas@no-mx.forums.microfocus.com>
>
> What’s the problem with my settings? What should be smtp server.?

NNTP doesn’t use an SMTP server. If you got an e-mail bounce, you did
your reply incorrectly - if I remember Thunderbird correctly, “reply”
does e-mail, and “follow-up” (or something like that) posts a reply in
the newsgroup.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 05/27/2015 11:21 AM, Jim Henderson wrote:
> NNTP doesn’t use an SMTP server. If you got an e-mail bounce, you did
> your reply incorrectly - if I remember Thunderbird correctly, “reply”
> does e-mail, and “follow-up” (or something like that) posts a reply in
> the newsgroup.

Yes, and the follow-up keyboard shortcut is Ctrl+r, so that’s nice.


Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…

On 2015-05-27 19:16, akash vishwakarma wrote:
> I just replied to a thread
> https://forums.opensuse.org/showthread.php/507699-I-need-to-recover-generic-MBR-code-instead-of-grub-code/
> The post didn’t appear on web interface. Later got mailer daemon with
> contents,

Delivery to the following recipient failed permanently:
>
> robin_listas@no-mx.forums.microfocus.com
> <mailto:robin_listas@no-mx.forums.microfocus.com>
>
> Technical details of permanent failure:
> DNS Error: Address resolution of no-mx.forums.microfocus.com
> <http://no-mx.forums.microfocus.com>. failed: Domain name not found

>
> I’m using thunderbird as my newsreader app. I’ve also configured to read
> gmail emails. My default smtp server is smtp.googlemail.com. The
> openSUSE forum newsgroup is also configured to use it as smtp. Maybe
> that’s reason for failure.

No, the reason is that you used “reply” instead of “follow up”. On
“news”, aka “nntp”, you can either reply only to the person that made
the post, via email (which is why the account config asks for an smtp
server), or to the nntp group, which is what you should use here.

Another “feature” of nntp is that the email address you give doesn’t
need to be real, it is not verified. On this nntp site we use addresses
(...@no-mx.forums.microfocus.com) that do not exist, but which are
recognized by the “gateway” (the thing that moves posts from/to
nntp/http sides) and does the correlation so that the forum member is
identified on the web side. If you use another type of address, the
gateway doesn’t identify it, and you get the entry “nntp user” (you can
see that on your posts you made with your real address).

On occasion some of us have used real email addresses. They work fine,
but they can be harvested by spammers, and they send you rubbish. And it
makes it impossible for web users to click on send private message on
the web forum.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On 2015-05-27 19:46, ab wrote:

> Yes, and the follow-up keyboard shortcut is Ctrl+r, so that’s nice.

Wow! That’s new to me :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On 05/28/2015 12:18 AM, Carlos E. R. wrote:
> No, the reason is that you used “reply” instead of “follow up”. On
> “news”, aka “nntp”, you can either reply only to the person that made
> the post, via email (which is why the account config asks for an smtp
> server), or to the nntp group, which is what you should use here.
OK. Using follow up. This is a test to verify settings.


Akash Vishwakarma
openSUSE 13.2 KDE/MATE/xfce/enlightenment 19

On 2015-05-28 10:29, akash vishwakarma wrote:
> On 05/28/2015 12:18 AM, Carlos E. R. wrote:
>> No, the reason is that you used “reply” instead of “follow up”. On
>> “news”, aka “nntp”, you can either reply only to the person that made
>> the post, via email (which is why the account config asks for an smtp
>> server), or to the nntp group, which is what you should use here.
> OK. Using follow up. This is a test to verify settings.

Worked :slight_smile:

You are using Thunderbird/31.6.0 :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On Thu 28 May 2015 08:29:20 AM CDT, akash vishwakarma wrote:

On 05/28/2015 12:18 AM, Carlos E. R. wrote:
> No, the reason is that you used “reply” instead of “follow up”. On
> “news”, aka “nntp”, you can either reply only to the person that made
> the post, via email (which is why the account config asks for an smtp
> server), or to the nntp group, which is what you should use here.
OK. Using follow up. This is a test to verify settings.

Hi
Change the email to vish_99@no-mx.forums.microfocus.com so it will log
your posts…


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

On 05/28/2015 08:14 PM, malcolmlewis wrote:
> Hi Change the email to vish_99@no-mx.forums.microfocus.com so it will
> log your posts…
Have got my userid changed by Kim to vishy so have set
vishy@no-mx.forums.microfocus.com as email address. Still vbulletin
doesn’t recognizes my nntp id.
<http://paste.opensuse.org/images/97207942.png>

Any other setting missing?
Sorry I’m using metered connection these days so I’ve limited my
internet use. Will be back in full swing in a week or two.


Akash Vishwakarma
openSUSE 13.2 KDE/MATE/xfce/enlightenment 19

On 05/29/2015 10:52 PM, akash vishwakarma wrote:
> have set vishy@no-mx.forums.microfocus.com as email address.
> Still vbulletin doesn’t recognizes my nntp id.
Now it does recognize my nntp setup. Two things.
Either I had made mistake in entering email id or I was following up in
html mode.
Q. Will following up in html cause problems.
Q. If I’m sending in text only mode, how will I attach
image/code/link/quote?


Akash Vishwakarma
openSUSE 13.2 KDE/MATE/xfce/enlightenment 19

Hi
Ok, you have to manually enter (In claws mail I have a template the automatically adds the quoting) quotes, code tags and URL BB wrappers.

On Fri, 29 May 2015 17:36:56 +0000, akash vishwakarma wrote:

> Q. Will following up in html cause problems.

Do not follow up using HTML. It’s considered bad form in general for
NNTP, and many readers do not render it.

> Q. If I’m sending in text only mode, how will I attach image/code/link/
quote?

Put the image on susepaste and link to it. Attachments do not traverse
the gateway IIRC, so attaching would not be a good idea.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On 2015-05-29 19:36, akash vishwakarma wrote:

> Q. Will following up in html cause problems.

You mean posting in html? Don’t.
It works in the sense that posts get through, but the people using web
can not see anything but the plain text equivalent. So it is pointless.

Only people using a capable nntp reader would see the extras.

Thus stick to plain text.

> Q. If I’m sending in text only mode, how will I attach
> image/code/link/quote?

You have to learn the tricks. For quotes, just let thunderbird do it.
like in this post. It does look a bit strange on the web side to them,
but they understand.

Code is done this way - sorry chaps, you only see this right via nntp :-p


This is a code section

http://This_is_a_web_link

http://This_is_an_image

There is a link somewhere with many more. Let me see if I have it…
Try this: https://forums.opensuse.org/misc.php?do=bbcode

Or this:

//youtu.be/eOUq4Z6R7xI


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2015-05-29 19:22, akash vishwakarma wrote:
> Sorry I’m using metered connection these days so I’ve limited my
> internet use.

In that case, you should consider using leafnode.

It gives you a local (slave) nntp server. You point Thunderbird to it,
so that all reading and posting is done entirely locally, not on
internet. When you finish writing, you connect to internet and call
“fetchnews” to send pending post, and fetch whatever is new.

It works very nicely, so much so that I use it even when having
unlimited internet: changing from message to message is instantaneous.
Also, you can tell Thunderbird not to cache messages.

It was designed about two decades ago, when people used modems.

Caveat: it is best to use reiserfs for its data, although will work on any.

Otherwise, if do not want to set it up, use thunderbird in offline mode.
You tell it to cache the posts, and disconnect. I don’t remember ho well
it works with nntp, but I was not happy with it (so I switched to leafnode).


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 05/30/2015 06:14 AM, Carlos E. R. wrote:
>
> Code is done this way - sorry chaps, you only see this right via nntp :-p
>
>


> This is a code section
> 

>
> http://This_is_a_web_link
>
> http://This_is_an_image
>
>
> There is a link somewhere with many more. Let me see if I have it…
> Try this: https://forums.opensuse.org/misc.php?do=bbcode
>
> Or this:
>
//youtu.be/eOUq4Z6R7xI

>
Found a
Thunderbird
Add-On: Custom-Buttons

It’s so versatile/customizable (difficult) that it’s better to type
bbcode tags than using it.
Basically it just provides a framework. You are required to a select
icon and provide additional code explaining how the icon should behave.

Composing a post is very easy.
Is it possible to write an addon for thunderbird such that
thunderbird renders the posts the same way as vbulletin does?


Akash Vishwakarma
openSUSE 13.2 KDE/MATE/xfce/enlightenment 19

On 2015-05-31 09:08, akash vishwakarma wrote:
> On 05/30/2015 06:14 AM, Carlos E. R. wrote:

> Found a
> Thunderbird
> Add-On: Custom-Buttons

> It’s so versatile/customizable (difficult) that it’s better to type
> bbcode tags than using it.
> Basically it just provides a framework. You are required to a select
> icon and provide additional code explaining how the icon should behave.

I was not aware of it.

> Composing a post is very easy.
> Is it possible to write an addon for thunderbird such that
> thunderbird renders the posts the same way as vbulletin does?

I’m not aware of one.

If the gateway could be improved, meaning, that Jim or somebody else had
more time or a volunteer helper with the proper skills to do it, then
there could be better translation of codes in both directions. That
would be the best thing.

But somethings, like your bold text above is difficult to pass. The
plain text method is using asterisks like bold. Thunderbird
understands it, and I hope other mailers do. The web side doesn’t, but I
suppose that people make up for that and /imagine/ the italics or bold
or_underline_.

Another problem is the smileys: some people simply do not understand
plain text, classic smileys, which are the only ones usable on the nntp
side.

Rendering most of the features of the web side forum require html on
nntp. This has several complications. One, as Jim said, is that it is
frown upon (with possible security issues), and that not all nntp
readers support it (thunderbird does). Another is that implementing
support on the gateway would probably be a nightmare.

So no, I don’t see it happening.
Maybe, if nntp users were not half a dozen, but a hundred or a thousand,
and on several forums, there would be some chance :wink:

nntp can be attractive to the people used to the mail lists at openSUSE.
Many of them do not like web forums at all, and say so… Thus when I
suggest there to come here, I try to suggest to use nntp, as a unique
feature of our forums.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On 2015-05-31 09:08, akash vishwakarma wrote:
> Composing a post is very easy.

You can add a filter in thunderbird to highlight the threads on which
you participate. First, copy to the clipboard your own address. Then,
select the parent of all groups, ie, the account. Go to tools, filters,
and add a new one, that triggers on from contains your address. As
actions, select “watch thread” and “mark as read”.

This makes that all threads in which you post are automatically marked
“watch”, which make them easy to find. Your own post is marked read, so
that the thread only appears underlined when there is a new post on the
thread, different from your own.

Of course, this means that you have to sort by date, and have thread
view active.

Other nntp readers have other methods, like for instance, scoring.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)