nm-applet temporarily not responding

I’ve sent this post a few hours ago but I can’t find it in the forum’s list. I suppose I made some mistake.
I’m sending it again. Sorry for any eventual inconvenience.

I run sddm and fvwm2 and on user login I launch nm-applet, to appear in stalonetray.
The applet appears immediately but it doesn’t respond to clicking. Network works OK,
only that the applet does not respond. After a minute or so, the applet menu invoked
by the clicking finally shows up.
Before upgrade to Tumbleweed, this problem was absent. nm-applet was responsive
from the very beginning.
Any ideas?

Been awhile since I’ve looked at this,
Ordinarily in most Desktops when NM is enabled, you should see <two> network applets that look identical.
One won’t respond to clicking, IIRC you might float over the applet to display some network information,
The other applet is actually the NM applet which you can click on to launch managing network connections.

The confusion might be that the same, identical icons are used for both applets.


Thanks for your answer. I’m afraid this is not the case. I have never seen two applets, not before upgrade,
nor after. If I don’t launch nm-applet myself, then there is no applet at all. I’ve also checked with ps alx that
there is always only one nm-applet running.
A remarkable thing is that the applet is only temporarily non responsive:

  1. It shows up immediately after launching
  2. I click on it once,
  3. Nothing happens for about a minute or so
  4. The response to the click on 2. appears
    Any help is welcome.

Asking you to verify…
You’re running TW/KDE-Plasma5 ?
With only default OSS repo or do you have any special repos configured?


I run sddm with fvwm2 with only default OSS repo.
Before upgrade to Tumbleweed I ran LEAP 42.2 with kdm and fvwm2
where this issue with nm-applet did not exist.

How are you configuring your window manager?

I’m checking now on a TW/KDE and when I installed fvwm2, it doesn’t show up as an option in “update-alternatives --config default-xsession.desktop”
So, unless you’re able to set fvwm2 as your window manager some other way, it may not be effective.

On a newly updated TW with the default sddm and plasma5 window manager configured,
Network Manager is now the default (not wicked) and only one network applet exists which properly launches the Network Manager connections


Thanks for spending time in this issue.

The short answer to your question is: I never configured it other than declaring fvwm2 as default in /etc/sysconfig/windowmanager

I have upgraded to TW “full standard” and downloaded the packages for fvwm2.
on /etc/sysconfig/displaymanager I have DISPLAYMANAGER=“sddm”
on /etc/sysconfig/windowmanager I have: DEFAULT_WM=“fvwm2”
update-alternatives --get-selections gave
default-xsession.desktop auto /usr/share/xsessions/fvwm2.desktop
On /usr/share/xsessions I have 11 different alternatives and the default points to fvwm2.desktop
However, when running update-alternatives --config default-xsession.desktop
it gives me only 3 alternatives, none of which is fvwm2. It also realizes that I’m running another windowmanager and changes
the default-xsession.desktop from “auto” to “manual”.

I’m checking now on a TW/KDE and when I installed fvwm2, it doesn’t show up as an option in “update-alternatives --config default-xsession.desktop”

Yes. It seems correct. update-alternatives gives only three choices although are many more options in /usr/share/xsessions/
I guess that /etc/sysconfig/windowmanager is setting the default to fvwm2, it is the only file I changed myself.

On a newly updated TW with the default sddm and plasma5 window manager configured,
Network Manager is now the default (not wicked) and only one network applet exists which properly launches the Network Manager connections

Yes, but it doesn’t apply to my case, I don’t run plasma5.


If you have fvwm2 properly configured, your Desktop should look like the following. If your Desktop looks like something else, then fvwm isn’t configured.

I found that even with fvwm2 configured, boot still attempted to configure Plasma. Only by disabling auto-login and then manually selecting fvwm on the sddm login screen was I able to properly enable fvwm.


I suspect that you aren’t actually using fvwm.

You’ll notice from my screenshot that there really isn’t a panel or taskbar, and there isn’t a network applet.
If you wanted to configure network connections, from my screenshot you’d have to click on the big openSUSE button, then select “openSUSE menu,” then “KDE System settings” and then finally “Network” and then “Connections.”


Thank you for taking your time with this. I’m afraid that the problem is not a mistake from my side but an unwanted consequence
of the upgrades. My guess would be that sddm takes some things for granted which clash with nm-applet. Nobody saw the problem before and it is undocumented so far. The issue was not present 10 days ago when I was still on LEAP42.2 running the same fvwm2 under kdm.

This is correct for the first time you access fvwm after upgrade and first reboot.

This is not correct, see below.

Yes, that was my first way in, but the suspicion is wrong. Once I was in and running fvwm, I manually changed
/etc/sysconfig/windowmanager to set DEFAULT_WM=“fvwm2”
I believe that as a consequence of this, update-alternatives --get-selections gave afterwards
default-xsession.desktop auto /usr/share/xsessions/fvwm2.desktop
(I didn’t perform this change myself, but so it is. If you further try to modify this default, update-alternatives realizes that fvwm was somehow unexpected there and changes “auto” to “manual”). From this point on, I always get fvwm, with autologin either disabled or enabled.

Fvwm2 is user-configurable. The system-wide configuration file /etc/X11/fvwm2/system.fvwm2rc is not used if the user has an own
~/.fvwm/config My configuration has a system tray (called stalonetray) and it subsequently launches nm-applet, which
appears on the system tray. The applet does work, but it is non-responsive for a minute or so. The applet shows up, but clicking on
it gives no result. After about a minute, it responds to clicking and works “as usual”. It is this minute that bothers me.
This issue was not present on 42.2 and kdm, in those times the applet was responsive immediately after launching. Among the possible culprits (changes in sddm, fvwm2 or nm-applet) I believe that sddm is to blame.

This is also correct, but it falls outside my issue.

It was and is still essential that you provide all relevant details if you ask for help, and in this case it’s more than just that you are using fvwm2, it’s also that you’re using a non-standard toolbar.

I won’t be able to dig deeper into your situation other than to note that perhaps your main fvwm config will be necessary for anyone to try to replicate your setup (I discovered quickly that the standard requirement to copy stalonetrayrc.sample to ~/.stalonetray.rc is insufficient)… and that there seems to be a TW bug related to how TW might select/enable a Window Manager (I’ve submitted the bug referenced below). Suffice to say that at the moment, the sysconfig method you’re currently doing is not supposed to work today.

Because of Tumbleweed’s own problems with how it’s supposed to manage the Window Manager,
I’d recommend that you wait until that’s resolved before you spend much time on the specific problem you’re experiencing.
You can submit a bug for your own problem, but make sure that it references the following bug report which likely should be addressed first



Thanks again for your help.

Of course. I had not understood that this way was non-standard since it was perfectly possible on LEAP 42.2. fvwm2 is meant
to be configured by the user.

OK. I agree.