Hello all, i am new to openSUSE. I have a fresh install of Tumbleweed. One of teh applications that I would like to use is Nitroshare. I took a look around and installed it (with the 1-click I believe). Ok, so it runs and my other computers see it on-line. Every time I try to send something to this computer, I receive the message “failed Host unreachable”. I tried a few different installs for nitroshare and one of them gave a message about a problem listening to port 40818. Honestly I cannot remember the exact message.

When i compare the Nitroshare settings between my other 2 linux machines (PCLinuxOS) and the openSUSE Nitroshare, the only difference that I see is on the other computers, the option “Allow local applications to interact with Nitroshare” is check but on the openSUSE Nitroshare, that option is greyed out.

Does anyone have any ideas? Any help would be useful. I have looked at the firewall in openSUSE but it is extremely confusing trying to figure out how to open a port of allow an application thru if that is the issue.

As a sidenote, i also tried installing Dukto. From the openSUSE i can send files but when it comes to receiving files, everything fails. So, seeing that 2 sharing apps always fail at sending anythig to the openSUSE computer, I have a feeling that there are some mystery settings that i do not know about. KDE Connect also does not see my tablet while the other two (PCLinuxOS) machines have no issue "out of the box.

Any info would be helpful

Thanks in advance

Please note, I have managed to set up Synergy. OpenSUSE is using the PCLinuxOS mouse and keyboard and I can see the samba shares from my openSUSE that are on the PClinuxOS machines so there is some sort of “connecting” happening

I really don’t recommend using 1 click installs because you can accidentally install a package for a different release just by clicking on the wrong link are you sure you installed a TW not a LEAP package?
check your repo list

zypper lr -d

and/or re-install nitroshare with zypper (or with yast)

zypper install -f nitroshare

nitroshare is available in the main TW repo and should work out of the box

another thing to consider is your firewall afaik TW uses firewalld so check the firewalld and nitroshare man pages about which ports need to be opened
there should be a yast module for firewalld that you can use to enable specific ports and/or services

Just to be sure, I uninstalled Nitroshare with Yast2 and re-installed it (Nitroshare and Nitroshare-KDE) from within yast2. Now I get the “unable to listen to port 40818” error when i launch the application. when i open the application and look at the settings, i still have the allow the local application to interact with Nitroshare option unchecked and greyed out.

I am looking in yast2 now for firewalld. here is what I am seeing.
firewalld - installed
firewalld-lang - installed
python3-firewall - installed
firewall-macros - FirewallD RPM macros - Not installed
firewalld-rpcbind-helper - Tool for static port assignment of NFSv3, ypserv, ypbind services - Not Installed
susefirewall2-to-firewalld - Basic SuSEfirewall2 to FirewallD migration script - Not Installed

I currently have no idea how to open ports or create exceptions in openSUSE.


I am in yast and the firewall settings. This is where I am lost. where does a person set an exception?


I went in the termanal
firewall-cmd --permanent --add-port=40818/tcp

firewall-cmd --reload

I can now send files from the other computers
I was looking into the firewall in yast but could not figure out where/how to open a port.