Nikon coolscan ed 40

Hi, I have a Nikon coolscan iv ed. It is an old scanner but still working and I want it to be recognized by OpenSUSE, I can see it in Yast when connected by USB.

What I see, after a scanner check, is:

USB scanner

Given that it appears as not configured yet, I tried some drivers, however no one works.
In fact, Nikon coolscan iv ed is not listed, there is iii and v.

Could you suggest me some repo configuration in order to find the right driver?


Please also post the complete output of:


Use Code-Tags:

localhost:~> lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 008: ID 05ac:828d Apple, Inc. Bluetooth USB Host Controller
Bus 001 Device 005: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 004: ID 05ac:8511 Apple, Inc. FaceTime HD Camera (Built-in)
Bus 001 Device 016: ID 04b0:4000 Nikon Corp. Coolscan LS 40 ED
Bus 001 Device 003: ID 1a2c:2094 China Resource Semico Co., Ltd USB Keyboard
Bus 001 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I already downloaded from that link the application, but the problem is to make the hardware recognized by OpenSuse.

Bus 001 Device 016: ID 04b0:4000 Nikon Corp. Coolscan LS 40 ED

Hardware is recocgnized, run Yast2-----Hardware-----Scanner

Should be supported by sane:

While that is basically true, the lsusb only shows that it connects through the USB and that it identifies itself with 04b0:4000, which is then translated using the on system tables with Nikon Corp. Coolscan LS 40 ED. IMO this dos not mean that it is recognized as a scanner device.

It is recognised as appropriate USB device. User needs to set it up.
Install Sane packages. Appropriate user may belong to “scanner” group.

It worked. Thanks to all for the support.