Nightmare after upgrading OpenSuse 11


I have been enjoying OpenSuse 11.0 RC for a month and some days. I installed it in an external disk of a Sony VAIO FZ31Z. As I had some good reasons to keep the default Vista installation, I decided to install the OpenSuse in a Lacie external USB disk. I installed Grub so I could choose whether to boot OpenSuse or Vista (which I’m using now to wrtie this, by the way…).
After the initial installation, the main trobules were installing the Nvidia drivers, but at last everything worked pretty well.

Then, as I was not very happy with the Gnome-terminal (resize was too slow), I decided to upgrade it, and after that, everything related to Gnome and GDM.
What I achieved was that I wasn’t able to log in normally in my upgraded OpenSuse, but I had to enter in Gnome-Safe mode to get into my Openwindows.
Well, I tried again upgrading the system. The next thing was that the Nvidia drivers were somehow disabled… so I didn’t had 3D acceleration anymore…

Well, I then decided that maybe it was time to make a full upgrade of the system, so I left the computer the whole night doing so (more than 4Gb in updates, including kernel). After some problems with YaST (writting the internal databases after upgrading), it seems that it got through and I finally had the new kernel (that I didn’t know it was an alpha release…).
So, after rebooting with my new OpenSuse 11.0.42, I was able to see that the X system was not even able to start…
I rebooted the system with no windows system (init 3), and I was able to log in, but that’s all, I’m not even given a prompt, and nothing can be done to repair the system (as far as I know).
I’m starting the backup operation of worthy files just before installing the whole thing again(OpenSuse 11 RC1, it is better the bad but known system…), so I’ll check in a while just to see if anybody has any suggestion.

So far, I’m pretty dissapointed with the upgrade system. I’ll keep it disabled in the next installation (over all everything related to the kernel!!!).

So let me get this straight - you had 11RC (Seeing as 11 has been out for a month, I can only imagine why) which you upgraded to 11.1 Alpha and it “sucks”.

Did it ever occur to you that maybe, just maybe, upgrading the system from development factory would be… a bad idea?

There are times when I wonder why I bother… really.

Well, I’m afraid that your answer doesn’t add anything new… :wink:

I had activated the development factory because there were some programs only available there, but I won’t do the same mistake again…
Indeed I only wanted to upgrade to 11.0, not the alpha. Maybe this was the problem.
Anyhow, I don’t know why I’m not able to log in or to get a prompt once I provide user/password. Any idea about that, or suggestion to solve it apart from reinstall all again?

(By the way, 11.0 RC1 proved very stable, I was pretty satisfied with it).

Hi isaac,
If I were you I would just do a clean install of the final 11.0 and take it up from there. Trying to revert back and get out of the problems may consume too much time and effort, I think the quickest way is a clean install.

I know isaac, it’s probably not what you’re after, but it may be the safest and quickest cure.

Well, I just had to ask before doing it all again from scratch… While we are talking I’m already downloading OpenSuse 11.0 (the stable release… although I have enjoyed pretty much with the release candidate :wink: ), and I’ll use another live CD to rescue some valuable information to try not to configure everything again…

My advice: do not try the new alpha 11.0.42 (64 bits), I cannot even log into the system…

Thanks anyway.

For the love of god.

With no offense meant - alpha software is targetted for people who have insight how the system works - not for people who are completely and utterly clueless whenever they’re exposed to a terminal.

Don’t blame the system if you don’t know what you’re doing.

Along these lines, do you have a separate /home partition?
Good chance that if you reinstall openSUSE 11.0 keeping your /home intact most apps and settings will work as they did before you tried the 11.1 alpha update…

If you don’t have a separate home you’ll probably want a backup of everything in the /home folders anyway.

Wishing you luck!

The forum doesn’t need someone as rude as you. It is here to help people and not cut them down.

I don’t think she was rude at all she just told it like it is and all true:cool: