NIC Speed and Duplex setting not staying

Hi all!

I am trying this forum for the first time and not sure if I am on the right place.

I installed SUSE 11.1 on a Dell Precision 380 that uses a NetXtreme BCM5751 Gigabit card. Every time I run ethtool eth0 I got my duplex: half.

Then I run: ethtool -s etho speed 100 duplex full autoneg off

The setting stays during my session but when I reboot the box, I need to put it back again.
Can someone tells me where I need to add this so it will stay every time I reboot the box?

Thank you in advance!

  • msilveira,

add the line to /etc/init.d/boot.local
If you are using ifup and not the Network Manager, you an also add the option to /etc/sysconfig/network/ifcfg-eth0 (ETHTOOL_OPTIONS)


Thank you! it works perfectly! I appreciate your help!