NIC card driver problem

Dear All,

I am installing linux for the first time. This is my first visit to the forum and my first post!
My NIC driver won’t work for me. I found a similar problem in this thread:

Makefile:65: *** Linux Kernel Source Not Found. Stop. - openSUSE Forums

I had the same makefile problem which my buddy was able to figure out, but we still can’t use the NIC to connect to the network. I even have the same NIC that the other person used, the Intel 82566.

I typed modprobe e1000 and checked the message file like ken_yap suggested and got something similar to what teresa said:

kernel: e1000: module not supported by Novell, setting U taint flag.
kernal: Intel(R) PRO/1000 Network Driver - version 8.0.6-NAPI
kernal: Copyright (c) 1999-2008 Intel Corporation.

But then the thread just ends and I don’t know how to install the driver. Here’s what I’m doing and maybe somebody can tell me what is wrong.

  1. I log in as root user.
  2. I goto control center and click Network Card
  3. I picked Traditional Method with ifup.
  4. The Network Card Configuration Overview window is empty, no cards listed. So I click the Add button.
  5. In the next screen I click select from list and pick the Intel PRO/1000.
  6. When I click ok, I go back to the screen where I clicked select from list. The Module name is e1000 so I think I’m on the right track. Do I need to put anything in the options like an IRQ? I don’t know what I should put so I simply click next.
  7. For the address I just want it to auto setup DHCP so I leave this part alone. In the general tab, I choose Device Activation: On Cable Connection. (YES the cable is plugged in, on both ends.) Then I click next.
  8. I now see my card in the Network Card Configuration Overview but on the bottom half it says:
    Intel PRO/1000 (not connected)
    Device Name: eth0
    Started automatically on cable connection
    IP address assigned using DHCP
    Then I click finish.

What am I doing wrong? Screen shots can be provided if you really need but its just a pain because I need a usb key and have to borrow from my neighbor.

I am at my wits end. Please help this n00b!


Some pieces of information you didn’t provide:

What version of OpenSUSE are you running?

It looks like you downloaded and built the latest version of e1000 from Sourceforge since this is even newer than OpenSUSE 11.0? Is it because you are running an old release of OpenSUSE and the Novell supplied driver doesn’t work?

You shouldn’t have to supply IRQ or that sort of thing, it is automatically assigned these days.

The question is is the driver finding the hardware? I don’t know if the driver will print out anything if suitable hardware is detected. Does the driver have some kind of debug option which will print more info? Do:

modinfo e1000

and it will return a lot of possible options that can be used. Look for something likely, maybe it’s called debug or something like that and add it to the modprobe line:

modprobe -r e1000    # to unload the current driver
modprobe e1000 debug=1

then look at /var/log/messages.

I am running SUSE Enterprise Linux Server 10 SP1.

I think you are right, it doesn’t seem as if suse is seeing the hardware. I think that is what the not connected means in the Network Card Configuration Overview. I installed solaris yesterday with no problems, all the hardware worked right away but found out that vmware doesn’t run on solaris. Which brings me to suse.

I tried the modinfo and you were right, it gave a ton of info including a debug var which had an option from 1 to 16. I tried all. I would unload, load with debug=1 and check var/log/message, and every time it would be the same message.

Unload, load with debug=2, check message, same message.

kernel: e1000: module not supported by Novell, setting U taint flag.
kernal: Intel(R) PRO/1000 Network Driver - version 8.0.6-NAPI
kernal: Copyright (c) 1999-2008 Intel Corporation.

The other options when I ran modinfo didn’t sound like they would help. I could be wrong!

I found the driver on the Intel website which I supposed would be the most current version. Should I try an older version from somewhere else if possible?

I don’t know if the novell supplied driver works or not, but my NIC isn’t being detected / configured by suse so I suspect the not.

Anybody have any other suggestions?
I’ll post funny pictures for whoever can help me connect to the network!
If you’re close I’ll even treat you to some beers!


I don’t think an older version would help.

Try identifying the NIC by finding the PCI IDs for the NIC in the output of lspci:

lspci -n

the latter to get the IDs (a pair of 4 hex numbers) after finding the appropriate line and then see if you can correlate that to a NIC model with a web search or searching Intel’s site. Could it be you don’t really have an e1000 but sone other NIC? Anyway this will give more info.

thanks ken!
I took the hex code and found out that I had the wrong driver, instead of e1000 I needed the e1000e. Go figure!

Anybody who has the same problem, make sure you have the e1000e driver from intel! Its a little digging to find it by the linux name but its there!

PS my hex code was 8086:10bd

Glad it’s worked out for you. There is an e1000e in OpenSUSE 11.0, maybe it’s too new for SLES10. Hopefully people running 11.0 will have it automatically detected.