NFS yast module and nfs have stopped working - no nfsidmap in repo

I found my nfs mounts has stopped working. Thought I would go to yast to check and could not open Yast>Network Services>NFS Client. I get a prompt to install nfsidmap but cannot install. When following the prompt. I get “Installing required packages failed” and warning of risk if I proceed. If I do proceed I find my NFS cannot be mounted.
Please can somebody advise?

Continuing to look into Yast>Network Services>NFS Client and opening nfs client configuration I find a bit of a contradiction. NFS Settings tells me the Firewall is not configurable, the the services are not available and that the services must be defined in order to configure the firewall.
It makes some sort of sense but is clearly designed to confuse simple souls like me. My /etc/fstab looks to me how it should:-

alastair@AJBR-W530:~> cat /etc/fstab
UUID=36192457-612b-452e-a846-745a83774812  /                       btrfs  defaults                      0  0
UUID=36192457-612b-452e-a846-745a83774812  /var                    btrfs  subvol=/@/var                 0  0
UUID=36192457-612b-452e-a846-745a83774812  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=36192457-612b-452e-a846-745a83774812  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=36192457-612b-452e-a846-745a83774812  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=36192457-612b-452e-a846-745a83774812  /root                   btrfs  subvol=/@/root                0  0
UUID=36192457-612b-452e-a846-745a83774812  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=28c73f4d-624d-478d-8d3f-3efd343b77b8  /home                   xfs    defaults                      0  0
UUID=36192457-612b-452e-a846-745a83774812  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=36192457-612b-452e-a846-745a83774812  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
192.168.169.130:/Multimedia                /home/alastair/NFS_multimedia  nfs    defaults                      0  0
alastair@AJBR-W530:~> 


Here is what I tried:-


alastair@AJBR-W530:~> sudo mount -t nfs 192.168.169.130:/Multimedia /home/alastair/NFS_multimedia
[sudo] password for root: 
Created symlink /run/systemd/system/remote-fs.target.wants/rpc-statd.service → /usr/lib/systemd/system/rpc-statd.service.
alastair@AJBR-W530:~>


This worked but no idea why firewall objected when using yast.