nfs weirdness with upgrade to 11.3

Hi Folks

just did an upgrade of my Sony Vaio laptop from 11.2 to 11.3
all seemed to be going smoothly
got to where it boots for the first time and it got to the splash screen and hung :stuck_out_tongue:
rebooted and tried the failsafe mode
it chugged along telling me each step it was going through till it said it was starting NFS Client Services
it hung, but the cursor was still blinking and the keyboard was still responsive so I waited
and I waited
and, well, you know
finally it said nfs connection timed out
and it hung again
yada, yada, yada
it timed out again
and hung again
the 11.2 system was auto-mounting 3 nfs shares so I waited some more
this took about 10 minutes but it eventually timed out and booted and ran fine
11.3 looks nice!
I removed the nfs shares and rebooted into regular run mode
no problems
re-created the nfs shares and tried to restart
and it hung
wait, wait, wait
finally started up
odd thing is, once it finally booted, the nfs shares are in fact mounted
anyway, that’s where I am now, just thought I’d post and see if anyone has ideas while I continue to investigate

Dave

One of the many reasons it is best to do a new install rather than an upgrade.

Reconfiguring a new install is usuall much faster then tracking down odd problems for old configurations.

I’ll probably end up doing a clean install
I’d never done an upgrade before and wanted to see how it went
all my stuff is backed up on those nfs shares
interestingly, I can remove the shares in the GUI thingy in Yast control center
then it boots fine
then I can mount them from the command line with no problem
strange

Dave

hmm

I did a clean install and still have the same problem
it seems to be trying to mount the network shares before the wireless is up and runing
it sits and waits till it times out
not sure what to do, this wasn’t a problem in 11.2

Dave

I assume you are connecting to the share by wireless???

Maybe the sequence of start up is changed. I’d consider this a bug and you should report it.

If you are connecting via a wireless network and have a network manager enabled, set up the network manager to allow connections for all users.
If you don’t do this, you will have problems with ldap authentication as well.

yea, it’s a wireless connection
I can watch the messages during boot and it looks like it tries to mount the shares to early
actually, if I shut the machine down with firefox running, when I reboot, it starts firefox automagically and firefox can’t load the pages I had been looking at
it doesn’t seem to start the wireless till after I login
let me investigate what whych said, maybe that makes it start wireless earlier

Dave

how do I “enable network manager”?
I’m just using the little tray icon thing that is there by default

Dave

Hi Dave!

I think we share the same problem. Did you already solved the problem?

After reading this thread I tried to change the order of the start/stop scripts for nfs in /etc/init.d/rc3.d and /etc/init.d/rc5.d by changing the number in the file name. The higher the number the later the script is started at boot time - at least I thought so. But even with S99nfs and K99nfs I could not get the right order.

Then I tried to change the options for nfs by editing the file /etc/nfsmount.conf. When I look in my dmesg output, I see that after launching nfs the systems halts/freezes for exactly 180 seconds or 3 minutes. I tried to adjust the options Retrans, Retry, Timeo in the config file but was also not successful.