NFS sharing OpenSuse to Ubuntu

Hi:

I’m having a problem setting up an nfs share. Here’s the situation:

I have two computers and a wireless router. Both computers hace static IPs and get connected through the router to each other and to the internet.

In the first computer I’m running OpenSuse 11.2, in the second I run Ubuntu 10.04.

On my Ubuntu box I set up a nfs share which works fine. I can read from and write to the directory without any problems.

Now, I’d like to share some of the stuff on my OpenSuse box to my Ubuntu box. I tried a similar configuration (/etc/exports) but from Ubuntu I can’t connect to my OpenSuse.

I tried allowing my localhost (Suse) to mount the share and it worked, but when I try from Ubuntu it doesn’t do anything (I don’t get anything in /var/log/messages) until I finally get an error “mount.nfs: mount system call failed”.

Any ideas will be appreciated :slight_smile:

On Thu, 07 Oct 2010 23:36:01 +0000, mchojrin wrote:

> Any ideas will be appreciated :slight_smile:

Check the firewall configuration on the openSUSE system and make sure
you’ve opened the ports for NFS. What you’re describing sounds like a
classic firewall configuration issue.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Yap, that seems to be the problem :slight_smile:

I just re checked my NFS server configuration from Yast and realized I didn’t check the ‘open firewall port’ checkbox :slight_smile:

Thanks!!

I have been having some of the same problems with openSUSE and Ubuntu. It seems like (which I like) that openSUSE has the firewall closed for a lot of things and you have to choose what to allow as to where Ubuntu alowws just about everything untill you turn them off.

I’m playing with samba.

It depends. Ubuntu comes with ufw which may or may not be turned on, and very few services are enabled by default. You even have to explicitly install openssh-server. However when you install a service, it automatically starts it and enables the port in the firewall, which may or may not be a good thing.