NFS Share not mounting at boot.

Subject says it all. Running mount -a works fine after boot. What am I missing. What further info should I supply?

fstab:


UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /                        btrfs  defaults                      0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /.snapshots              btrfs  subvol=/@/.snapshots          0  0
UUID=4a18005a-e7ac-4ba0-8fb7-dd44d49809a8  swap                     swap   defaults                      0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /var                     btrfs  subvol=/@/var                 0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /usr/local               btrfs  subvol=/@/usr/local           0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /tmp                     btrfs  subvol=/@/tmp                 0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /srv                     btrfs  subvol=/@/srv                 0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /root                    btrfs  subvol=/@/root                0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /opt                     btrfs  subvol=/@/opt                 0  0
UUID=90fcbd6a-253d-4792-a465-ef41753c4f7e  /home                    xfs    defaults                      0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /boot/grub2/x86_64-efi   btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=cb5eb899-013e-468f-b1da-35191dfb473c  /boot/grub2/i386-pc      btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=5D26-3EE0                              /boot/efi                                 vfat   defaults                      0  2
tower:/home/mmontz                         /home/mmontz/Tower/home  nfs     defaults                      0  0
tower:/mnt/raid                                   /home/mmontz/Tower/raid     nfs    defaults                      0  0

Ther are several threads about this. Alas no solution until now, but some blame it to Btrfs.

To be precise, those cases, while they are often called “does not mount on boot” in fact do mount, immediatly followd by an umount (see loging). Al very bewildering. Like you say, a mount -a then mounts them without an umount following automagicaly.

Are you using wicked or NetworkManager?

Network Manager.

With NM network interfaces are brought up asynchronously during boot. You will need to

systemctl enable NetworkManager-wait-online.service

and set suitable non-zero value for NM_ONLINE_TIMEOUT in /etc/sysconfig/network/config (default is 30 seconds, you may start with it). Suitable timeout depends on you environment, how fast interfaces come up. If it still does not work after this change, boot with systemd.log_level=debug on kernel command line and provide full output of “journalctl -b”.

This of course assumes you have configured system connection (or “available to all users”) and set connection to auto-connect.

Still not working.

Relevant /etc/sysconfig/network/config entry:

## Type:    int
## Default:    30
#
# When using NetworkManager you may define a timeout to wait for NetworkManager
# to connect in NetworkManager-wait-online.service.  Other network services
# may require the system to have a valid network setup in order to succeed.
#
# This variable has no effect if NetworkManager is disabled.
#
NM_ONLINE_TIMEOUT="60"

“journal -b” output

https://pastebin.com/kSwTxqri

Those are user logs. Please run journalctl as root.

My bad. Here you go:

https://drive.google.com/open?id=1M2hCRZLg5C7t9CUtAii8w78ddlSulrAw

Well, NetworkManager activates connection only after user logs in, which is strong indication that you are using per-user instead of system-wide connections. In this case it is not possible to use /etc/fstab to mount remote filesystems. Either use system-wide connection or use some other means to mount these filesystems (like automount).

Actually, I have already told you you need system connection …

I missed that in the earlier post. That fixed it.

Thanks for your help.