NFS share, automatic unmount

Hi there.
Hope i can explain my “problem”.
I created a NFS share from one thinclient i have, to other computers at home.
But, if i shut it down when having other computers connect( even then aren’t using the nfs share), it holds forever and forcing unmount gives almost all time “in use”.
I know that is a option like timeout, it is for this situations?

thanks in advance.

If you can get all the NFS client machines to use autofs, they will unmount after a period of idling. For example this is a line from the auto.mas map I use to mount from a NAS:

Music -rw nas:/raid/Music

In the auto.master file this is referred to with:

/nas /etc/auto.nas

Search around for an autofs tute.

Timeout parameter is for individual NFS operations, not mounting.

How are you so sure they are not using the NFS exported directory?

Thanks, will try. Seems what i want.
Have already found another similiar post, will stick to it.

What you mean?
I have the thinclient almost all time turned on.
If i have a pc with a nfs mounted via fstab (mounted at boot) and i’m not using the exported directory (acessing my regular home) when i’m going to shutdown it “hangs”.
I’m not usually in the exported directory (like /dados).


I have two openSUSE systems here. One exports a directory that is NFS mounted by the other. No automounter configuration. Both systems shutdown without any problems independent from the other.

Hi there.
Sorry, my hdd has gone…
As i sayed, using opensuse 11.1 client and connect to the server using CrunchBang 9.04 (ubuntu based, now 10) that exports a directory, using defaults settings.
If i shutdown the server, this client would hung…

Could it be a kind of issue so?