nfs server

hi

on a tumbleweed fresly installed (today) i try to setup a nfs server

in yast, when i go to nfs server:

i see in firewall not configurable section:

some firewalld service are not available

  • nfs-kernel-server (not available)

these services musddt be defined in order toc onfigure the firewall)

nfs service is started

nsfs kernel server is installed

any other thing to do?

Do you have /etc/exports with anything in it?

no don’t have this files

You can configure it manually using ‘man exports’, or using yast, https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.nfs.html. Without it you have the server serving nothing.

seem to have an issue with the ui

nfs kernel server is installed

but yast nfs server don’t seem to see it…

in

/etc/exports

i have

/home/bob/Downloads *(ro,root,_squash,sync,no_substree_check)

my server address is: 192.168.11.109

from my other computer (ip: 192.168.11.111) when i go in yast nfs: client and type

192.168.11.109

Error

No NFS server has been found on your network, this could be caused by a running firewall, which probably blocks the network scanning…

On my server

default zone is public: and nfs is checked, it,s also checked for internal

I don’t know whether * instead of IPaddr/IPaddr in “/home/bob/Downloads *(ro,root,_squash,sync,no_substree_check)” is valid. I’ve never tried any such syntax. Mine are all in the form 192.168.###.###/255.255.255.0. Why YaST says firefwall->nfs-kernel-server not configurable I have no idea. What does

systemctl status nfs-server.service

report?

showmount -e

on your server must produce output for any other computer to see its files.

systemctl status nfs-server.service
● nfs-server.service - NFS server and services
Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; enabled; vendor preset: d
Drop-In: /usr/lib/systemd/system/nfs-server.service.d
└─nfsserver.conf, options.conf
/run/systemd/generator/nfs-server.service.d
└─order-with-mounts.conf
Active: active (exited) since Mon 2018-04-02 19:01:04 EDT; 2h 35min ago
Process: 22396 ExecStopPost=/usr/sbin/exportfs -f (code=exited, status=0/SUCCESS)
Process: 22394 ExecStopPost=/usr/sbin/exportfs -au (code=exited, status=0/SUCCESS)
Process: 22392 ExecStop=/usr/sbin/rpc.nfsd 0 (code=exited, status=0/SUCCESS)
Process: 22402 ExecStart=/usr/sbin/rpc.nfsd $NFSD_OPTIONS (code=exited, status=0/SUCCE
Process: 22401 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)
Main PID: 22402 (code=exited, status=0/SUCCESS)

Apr 02 19:01:04 linux-e6zd systemd[1]: Starting NFS server and services…
Apr 02 19:01:04 linux-e6zd systemd[1]: Started NFS server and services.

showmount -e
clnt_create: RPC: Unknown host

When NFS is correctly configured, showmount -e output begins with

Export list for <hostname>:

Try replacing * with 192.168.11.109/255.255.255.0 in /etc/exports, then

systemctl restart nfs.server
showmount -e

or reboot.

Your systemctl status nfs.server.service output is much different, and longer, than mine, which only shows 3 SUCCESS lines, and does not have nfsv4 enabled.

I’ve only ever used nfs-server on PCs with fixed IP addresses. Servers usually don’t change IP addresses, more often providing the DHCP service that doles them out to clients. Maybe nfs-server works better (only?) on fixed IP and you should try reconfiguring your server to use it.