NFS Server on openSUSE 11 and client on openSUSE 10.3

Hi,

I have installed openSUSE 11 on mine server (name: srv), migrated also NFS server content. The server configuration has been performed using YaST and is:

  • no NFS v4
  • export is configured
    • Directory: /home/nfs/public
    • Host Wild Card: empty
    • options: rw,root_squash,sync

The client is running openSUSE 10.3 and the NFS is also configured using YaST:

  • Server: srv
  • Remote file system: /home/nfs/public
  • Mount point: /nfs/public
  • Options: defaults

The NFS is mounted ok. The users and groups are synchronized, means the UID and GID has the same meaning on both servers. I can read from the NFS but can’t delete or write new file. The command l on directory /nfs/public:

drwxrwxr-x 10 root    users      4096 2008-08-23 12:39 ./
drwxr-xr-x  7 root    root       4096 2008-05-06 09:58 ../
-rw-rw-r--  1 jmares  users      9022 2007-06-25 23:40 icon.xpm

the command: rm icon.xpm
rm: cannot remove `icon.xpm’: Permission denied

and command: echo a > a.txt
bash: a.txt: Permission denied

I think the configuration is okay …

Thanks a lot for any help.

Jirka

I am having similar troubles, and it does not matter if the client is 10.3 or 11.0. I configured the client using yast without the “NFSv4 Share” option. When I cd into the mount:

> touch test
touch: cannot touch `test': Read-only file system

My /etc/fstab line looks like this:

192.168.7.1:/home	/server1	nfs	defaults 0 0

and my server’s /etc/exports looks like this:

/home (rw,root_squash,sync,no_subtree_check)

The names, UIDs, and GIDs are all the same between systems.

On a side note, whenever I select the “NFSv4 Share” client option, I get a “Error Unable to mount the NFS entries from /etc/fstab.” message.

Disabling NFSv4 on the server side (in Yast) did not help.

On my 10.3 server, I can export /home and the 10.3 and 11.0 clients have no troubles reading an writing to the share.

Any help would be greatly appreciated. I have been trying every permutation that I can think of.

Same trouble here, but then I asked myself is NFS really necessary. Since it wasnt and I needed simple file sharing between laptop and desktop, I just configured samba, its easy and works OK.
My samba server was on 10.3 while client was 11.0

This problem could be because “root” owns the directory. Did you export with “no_root_squash” (if that was desired)?

Hi,

I tried no_root_splash but no change. Then I tried change the owner from root to jmares and still no change.

I missed mension that I’m trying it as user jmares.

Jirka

NFS can be a little difficult. I’ve recently completed a few NFS3 and NFS4 configurations for RHEL 5, openSUSE, and Mandriva.

NFS3 is difficult because of firewall issues. NFS3 requires a handful of ports that change each time the service is restarted. Each distribution is different in the means to lock ports. I’ve had troubles with RHEL 5 and lockd timeouts. I could not determine cause and used NFS4.

NFS4’s firewall is easier because it requires only two ports: portmap and nfs. However, with NFS4, you need

  • /etc/idmapd.conf must have a common domain.
  • For server, all exports must be rooted from a common directory (e.g., /export). Use the bind option to mount to mount a directory within the /export tree
  • The top level directory must have an “fsid=0” option

However, since your mount completes, do the following:

  • On server: I’ve had better success with kernel NFS server rather than the user space daemon
  • On server: “exportfs -v” to verify settings.
  • On client: “showmount -e server” to make sure client sees
  • On client: “cat /proc/mounts” to ensure the mount was done rw.

Hi, thank for your help:

So I enabled NFS v4 on server. Created one root export, eg. /home/nfs with fsid=0 and it contains other 3 exports where one of them is /home/nfs/public. In /etc/idmapd.conf is specified domain.

I think I use kernel daemon, but don’t know howto check. the command “exportfs -e” is not working for me (no exportfs binary available).

On client “showmount -e server” shows:
Export list for server:
/home/nfs <anon clnt>

/home/nfs/public <anon clnt>

and “cat /proc/mounts” contains:

ids:/home/nfs/public /nfs/public nfs rw,vers=2,rsize=8192,wsize=8192,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=ids 0 0

The server root directory /home/nfs is not mounted on client.

I think everything looks ok, but there is file (i’m user jmares in group users):

from server:

l /home/nfs/public/icon.xpm
-rw-rw-r-- 1 jmares users 9022 2007-06-25 23:40 /home/nfs/public/icon.xpm

from client:

l /nfs/public/icon.xpm
-rw-rw-r-- 1 jmares users 9022 2007-06-25 23:40 /nfs/public/icon.xpm

and

touch /nfs/public/icon.xpm
touch: setting times of `/nfs/public/icon.xpm’: Permission denied

Jirka

If you’re connecting to Suse’s share from another machine, you should configure the firewall settings to allow NFS.

Yast2 > (search for Firewall) > Allowed Services > Add …

  1. NFS Client
  2. NFS Server

I added both just in case. Before doing this, I couldn’t access my Suse NFS share from my crunchbang netbook (debian-based). I’d configured it to be NFS version 3, btw.

Cheers!

(I posted this reply in another related thread)

Some mentions of nfs3 on clients but no mention of whether the corresponding servers are running nfs3 or nfs4, they have to match

Someone thought they were using nfs kernel daemon on an nfs4 server, I think nfs3 uses kernel daemon not nfs4

Firewall, on the server allow Nfs Server, on the client allow Nfs Client

Why such old versions of opensuse? I don’t think OS 11.0 is supported anymore and OS 10.3 hasn’t been for quite some time

Yes, you’re right, Ecky. By default, the Firewall ‘Internal Zone’ allows many services (maybe all. I’m not sure, I’m new to OpenSuse). There are 3 zones i.e. Internal, External, Demilitarized.

Maybe it’s because NFS server is considered as External. Those settings I’d mentioned earlier should be set under ‘External Zones’ i.e. NFS Server, NFS Client (btw, the NFS Client work without this setting, maybe it’s under Internal Zone)

I think there’s some kind of settings to be done to allocate what services or devices is under which of the three zones in the file /etc/sysconfig/SuSefirewall2

Maybe someone can enlighten us?

You can view which services are allowed for which zone in Yast > Security and Users > Firewall, if memory serves there is a drop-down box on the allowed services screen which allows you to change which zone you are looking at

On 07/14/2011 07:06 PM, mamasboy wrote:
>
> (I posted this reply in another related thread)

but, why oh WHY are you posting an ‘answer’ to a 3 year old question
relating to versions of openSUSE which are no longer available or
supported??

please be aware of the dates of post you wish to add information to and
politely refrain from digging up the dead.

thanks.


DD
Caveat-Hardware-Software
openSUSE®, the BMW® of operating systems!

I didn’t notice the dates and there I was asking why such old versions lol