nfs server on opensuse 11.2


Twice in the past two months, I’ve tried to get an opensuse box I have to share a directory via NFS. I’ve failed each time, but I thought that the third time, I’d enlist some help from the forums, if I could.

A question you could well ask, is how do I know that the nfs server and not the client is the problem? Short answer is: I don’t!
That’s why nfs (and many netwrk problems) are laborious, you’re troubleshooting needs to take place at both source and desitination.

Next question, what do I have set up so far? Well, I did download the nfs server kernel stuff (two months back) and /etc/init.d/nfsserver start seems to get set up OK. No errors and the daemons nfsd, idmapd, mountd area all running. So, I think that part is OK.

I have the share set up properly in /etc/exportfs and have “exportfs -r” it.

OK, now onto the trickier stuff: the client and iptables.
On the client pinging to the nfserver box is perfect, and I have rpcbind running. the reported error is
“mount.nfs: mount system call failed”
though from experience nfs errors don’t mean a whole lot.
However, I will go off and check now and see if I need a mountd running on client-side too.

Then there’s iptables … ouch, that could be a long and painful trek. I don’t see any specific ports being blocked, and it’s the iptables that the default v11.2 opensuse came with. I did turn them off and the problem was the same, so whether wishfl thinking or not, I’m hoping it’s not an iptables issue.

So after the first post I was goign back and checking some things. Back to that question, how do I know that my nfs client is not causing the problems? Well in /var/log/messages I get
“rpcbind: server <nfsserverbox> not responding, timed out”
when I try and mount the share.
that’s no guarantee of course, but I have to assume something, so I reckon, the nfsserver’s rpc service is being contacted but is not replying.

That’s waht makes me think it’s not the client.

My question: why did you not use YaST to start the nfs server and to configure your exports. YaST is then clever enough to see after your firewall (if you use it).

Edit: and /etc/init.d/nfsserver start will only start, it will not set up anything. Thus after a boot you have to do it again. YaST would have looked after that also.

hcvv is right, Yast is the place for it.

First install yast-nfs-server if you haven’t yet, then configure things from there. On the clients too, use Yast. If you meet trouble there, look for solutions in undoing things you already tried.

thanks for the suggestions.

In terms of yast (and pls note I use the ncurses yast* … I’m assuming it has the same functionality as the GUI yast), I did give it a try.

Under “Network services” though the NFS client was to be found as well as other servers, I couldn’t find anything relevant for nfsserver. even in “Network Services(xinetd)” a ton of other services are mentioned but no nfsserver.

Mention of it only seems to occur in “System|System Services(Runlevel)” where it is show to be activated. It can only be disabled … there is no configuration or settings possible … from what I can see.

So, so I really should check the GUI Yast. I tried Yast2 and I get ncurses again. Hmm… I don’t seem to have a very well-configured system.

SO those are the sum total of my efforts with yast. I think what I may do is go through the nfsserver script and see what configuration it’s referring to, and may be use that line of attack.

Please note the bold part, I made a typo, it should be ‘yast2-nfs-server’. Install that package, start the Yast Control Centre, and you will find a new icon for NFS-server.

Basically there’s no difference between the ncurses and Qt/GTK version of yast apps. Almost anything can be done from the ncurses version, at least the things you need.

It should not make a difference which interface you use with YaST.

But it was you who said that you started (even “seem to get set up”) using /etc/init.d/nfsserver start. When you now say you did it using YaST > System services (Runlevel) that is a new fact. Also I did not mention the innstallation of yast2-nfs-server (because I first want to know what is thh important reasoin not to use YaST), but like Knurpht says, you need that one also top have YaST > Network Services > NFS Server.

I am afraid it is very difficult to help you when you do not tell us what you are using, etc. We (Knurpht and I and others) have the experience that using YaST for starting/configuring NFS server functionality is OK. Thus our advice to undo any changes “done manualy”, and start anew using YaST (GUI or ncurses).

Knurpht and hcvv,

I have to thank you for assisting me here, replies are very prompt … thanks alot.

I also see that I skipped the “yast” part of having nfs-server. I realise now that yast does need to have that nfs-server functionality added.

I went ahead and did that, and though I am stil getting the same problem, your comment “We (Knurpht and I and others) have the experience that using YaST for starting/configuring NFS server functionality is OK.”

goes a long way towards reassuring me that the nfsserver now is mostly correct.

I did undo my manual changes, and now I see that yast-nfs-server has overwritten my /etc/exports, though not touched my hosts.allow nor hosts.deny. But, it would seem I need to concentrate on the nfs-client on the other box now, as the server-side has been taken care of.


OK, got it working (pity I can’t set this thread to solved).

So, for anyone floating in here from google or whatever: as Knurpht and and hvcc said. NFS can be set up via Yast.

You do need both nfs-server and the corresponding module in yast (yast-nfs-server), and you do need to be concerned about your firewall.

Despite the fact that I did flush out my iptables and still did not get it working is something I can’t explain, but - and here is the critical thing - make sure you enter the “Firewall Details” of the yast-nfs-server module.

My problem was that the firewall was only letting nfs play on one of my two interfaces.

I was overly complacent of that fact, and never bothered checking the “firewall details” section.

Thanks to hvcc and Knurpht for the clues!

You are welcome. Nice you have it working.

Also thanks for making the final statement so that people finding this, have a complete story.

Standing next to Henk, agreeing.

Are you serious? Holy, moly. Just how crazy obtuse must stuff like this be made? I’ve spent hours on this Googling and following directions and it turns out that because I’ve got an openSuSE installation, I have to know of some weirdo special package that UNIX normally does straight out of the box. I’ve fiddled /etc/exports and /etc/init.d/nfs config files and struggled mightily to occasionally get it working, only to have it shut down on the next boot. Turns out I needed a magic YAST package. That is dumb. :frowning: At least now I’ve got that weirdo package installed and NFS services are now published. It was too hard to find this.

Sorry for ranting. I’ve fiddled UNIX for decades and never had so much trouble setting up NFS. Yes, this is the first time I needed it under SuSE.

You certainly don’t need to use this package but it’s just easier this way especially if You’re a beginner. You can configure nfs using vi only under openSUSE without any problems.

Best regards,