NFS mounts fails at boot

opensuse 12.3 (although this was a problem in 11.4 also)
linux v3.7.10-1.16-desktop x86_64

I have read the thread for “mounting nfs not working at boot.” It is a bit dated and the conclusion was to use a deprecated method (sysvinit) instead of systemd. Also the reference to an ArchLinux article no longer contains the information indicated.

As shown in the message log below, RPCBind is started but the NFS mount does not wait for it to complete before trying to mount the filesystems.

I tried adding the “B” option to rpcbind in “YaST::System Services (Runlevel)”. I presume that encourages rpcbind to start earlier. And it does. However, the boot hangs at a certain point, it appears to be a deadlock; see the second code section below.

Starting in FailSafe mode makes no difference.

Any suggestions for having it all?

Boot proceeds okay but NFS does not load:

2013-08-18T15:24:38.889382-07:00 sma-server3 kernel:    19.192450] RPC: Registered named UNIX socket transport module.
2013-08-18T15:24:38.889506-07:00 sma-server3 kernel:    19.192452] RPC: Registered udp transport module.
2013-08-18T15:24:38.889508-07:00 sma-server3 kernel:    19.192452] RPC: Registered tcp transport module.
2013-08-18T15:24:38.889509-07:00 sma-server3 kernel:    19.192453] RPC: Registered tcp NFSv4.1 backchannel transport module.
2013-08-18T15:24:38.890662-07:00 sma-server3 nfs[1275]: Starting NFS client services:portmap/rpcbind is not running
2013-08-18T15:24:38.891004-07:00 sma-server3 nfs[1275]: ..missing
2013-08-18T15:24:38.931269-07:00 sma-server3 systemd[1]: Starting /etc/init.d/boot.local Compatibility...
2013-08-18T15:24:38.956233-07:00 sma-server3 systemd[1]: nfs.service: control process exited, code=exited status=3
2013-08-18T15:24:38.973375-07:00 sma-server3 kernel:    19.256733] Installing knfsd (copyright (C) 1996
2013-08-18T15:24:38.973805-07:00 sma-server3 systemd[1]: Failed to start LSB: NFS client services.
2013-08-18T15:24:38.973843-07:00 sma-server3 systemd[1]: Unit nfs.service entered failed state
2013-08-18T15:24:39.001500-07:00 sma-server3 systemd[1]: Started /etc/init.d/boot.local Compatibility.
2013-08-18T15:24:39.145415-07:00 sma-server3 kernel:    19.455333] ip_tables: (C) 2000-2006 Netfilter Core Team
2013-08-18T15:24:39.300412-07:00 sma-server3 kernel:    19.610291] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
2013-08-18T15:24:39.886920-07:00 sma-server3 systemd[1]: Starting RPC Bind...
2013-08-18T15:24:39.914796-07:00 sma-server3 systemd[1]: Started RPC Bind.

Boot hangs when rpcbind loads early:

2013-08-18T15:15:03.395193-07:00 sma-server3 rpc.mountd[1350]: Version 1.2.7 starting
2013-08-18T15:15:03.400975-07:00 sma-server3 rpc.statd[1353]: Version 1.2.7 starting
2013-08-18T15:15:03.401422-07:00 sma-server3 rpc.statd[1353]: Flags: TI-RPC
2013-08-18T15:15:03.450326-07:00 sma-server3 kernel:    21.738396] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
2013-08-18T15:15:03.736569-07:00 sma-server3 webmin[1229]: Webmin starting
2013-08-18T15:15:03.816031-07:00 sma-server3 nfs[1271]: Starting NFS client services: sm-notify idmapd..done
2013-08-18T15:15:03.829335-07:00 sma-server3 kernel:    22.117944] NFSD: starting 90-second grace period
2013-08-18T15:15:03.830210-07:00 sma-server3 sm-notify[1382]: Version 1.2.7 starting
2013-08-18T15:15:03.830544-07:00 sma-server3 sm-notify[1382]: Already notifying clients; Exiting!
2013-08-18T15:15:03.830678-07:00 sma-server3 nfsserver[1266]: Starting kernel based NFS server: idmapd mountd statd nfsd sm-notify..done
2013-08-18T15:15:03.831124-07:00 sma-server3 systemd[1]: Started LSB: Start the kernel based NFS daemon.
2013-08-18T15:15:05.203361-07:00 sma-server3 kernel:    23.490538] r8169 0000:03:00.0 eth0: link up
2013-08-18T15:15:05.203410-07:00 sma-server3 kernel:    23.490557] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
2013-08-18T15:15:05.472196-07:00 sma-server3 systemd[1]: PID file /var/run/ not readable (yet?) after start.
2013-08-18T15:15:05.637043-07:00 sma-server3 systemd[1]: Started apache.
2013-08-18T15:15:06.201983-07:00 sma-server3 systemd[1]: Started LSB: Start or stop the Webmin server.
2013-08-18T15:15:06.525624-07:00 sma-server3 avahi-daemon[665]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::224:8cff:fe9a:f4f4.
2013-08-18T15:15:06.526823-07:00 sma-server3 avahi-daemon[665]: New relevant interface eth0.IPv6 for mDNS.
2013-08-18T15:15:06.527639-07:00 sma-server3 avahi-daemon[665]: Registering new address record for fe80::224:8cff:fe9a:f4f4 on eth0.*.
2013-08-18T15:15:34.902410-07:00 sma-server3 kernel:    53.145405] audit_printk_skb: 81 callbacks suppressed
2013-08-18T15:15:34.902459-07:00 sma-server3 kernel:    53.145410] type=1400 audit(1376864134.901:39): apparmor="DENIED" operation="open" parent=1 profile="/usr/sbin/nscd" name="/proc/sys/vm/overcommit_memory" pid=706 comm="nscd" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
2013-08-18T15:15:36.159761-07:00 sma-server3 nfs[1271]: Mounting network file systems ...mount.nfs: Failed to resolve server System error

---hangs here forever--- (forever is at least 3 minutes) 

Yes, rpcbind was converted to use socket activation (when service is started on demand) but nfs initscript still expects old style sequential activation. Hmm … care to open bug report and post number here? This warrants update but for a 12.3 it requires bug report to be accepted.

I tried adding the “B” option to rpcbind in “YaST::System Services (Runlevel)”.

Do not use YaST for it. It was not adapted to systemd services and in any case use Boot runlevel in this case is completely wrong.

However, the boot hangs at a certain point, it appears to be a deadlock

Well, as obvious from your output it cannot resolve what I presume to be NFS server name. Probably network is not up at this point. It is impossible to tell without more information than couple of log lines out of context.

Bug 835549