NFS mounts fail since Kernel 5.14.21-150500.55.59.1

Hi all,

my nfs mounts in openSUSE leap 15.5 fail since the kernel update to 5.14.21-150500.55.59.1. I wanted to wait for the next kernel version last. But the problem also occours with the current kernel version 5.14.21-150500.55.62.2.

The mounts fail at boot. The /var/boot.log says:

[FAILED] Failed to mount /mnt/***.
See 'systemctl status mnt-***.mount' for details.
[DEPEND] Dependency failed for Remote File Systems.

systemctl status mnt-***.mount says:

× mnt-***.mount - /mnt/***
     Loaded: loaded (/etc/fstab; generated)
     Active: failed (Result: exit-code) since Tue 2024-05-21 11:26:01 CEST; 55s ago
      Where: /mnt/***
       What: ***:/***
       Docs: man:fstab(5)
             man:systemd-fstab-generator(8)

Mai 21 11:26:01 *** systemd[1]: Mounting /mnt/***...
Mai 21 11:26:01 *** systemd[1]: mnt-***.mount: Mount process exited, code=exited, status=255/EXCEPTION
Mai 21 11:26:01 *** systemd[1]: mnt-***.mount: Failed with result 'exit-code'.
Mai 21 11:26:01 *** systemd[1]: Failed to mount /mnt/***.

/etc/fstab says:

UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /                       btrfs  defaults                      0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /var                    btrfs  subvol=/@/var                 0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /tmp                    btrfs  subvol=/@/tmp                 0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /root                   btrfs  subvol=/@/root                0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /home                   btrfs  subvol=/@/home                0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=5fd641d4-f956-4c09-a2b3-ffe37a32387e  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=42f79e63-0ba8-4f9c-bbfb-05dcfb190505  swap                    swap   defaults                      0  0
UUID=376A-3497                             /boot/efi               vfat   utf8                          0  2
***:/***          /mnt/***   nfs   defaults,sec=krb5p,rw 0 0
***:/***           /mnt/***         nfs   defaults,sec=krb5p,rw 0 0
***:/***           /mnt/***         nfs   defaults,sec=krb5p,rw 0 0
***:/***           /mnt/***         nfs   defaults,sec=krb5p,rw 0 0
***:/***          /mnt/***        nfs   defaults,rw 0 0

The mounts also fail if I manually try to mount using the following command:

mount -v -t nfs4 ***:/*** /mnt/***

The output looks like this.

mount.nfs4: timeout set for Tue May 21 11:34:25 2024
mount.nfs4: trying text-based options 'vers=4.2,addr=***,clientaddr=***'

It does not time out. It stays like this forever.

If I boot into the old kernel 5.14.21-150500.55.52.1 evereything works fine.

I saw some older posts with the same topic. They suggest to add the nfs version in fstab. I tried this but nothing changed. Another idea was a link to kerberos. We also have one un encrypted mount. This also does not work.

Do you have any idea, how i could solve this issue?

Thanks a lot.

Best regards

Not direct help. But as far as I know I had no problems before todays update session. After the update:

henk@beneden:~> uname -r
5.14.21-150500.55.62-default
henk@beneden:~> 

and still no problem with my NFS mount.

@hcvv Thanks for your reply. Are there major differences in your fstab from mine?

Yes there are:

mgi@beneden:~> grep nfs /etc/fstab
boven.henm.xs4all.nl:/home/wij             /home/wij  nfs   noauto,nofail,x-systemd.automount,x-systemd.mount-timeout=10,x-systemd.idle-timeout=5min  0  0
mgi@beneden:~>

I am using systemd automount as you see. But I do not think that is really connected to the problem, because you say that a “manual” mount command has the same problem.

=====
Please we love it to see computer output as complete as possible. Thus you do not say things like “/etc/fstab says:”, but you include that line with your copy/paste, like my example above. And while it is OK to obscure security sensitive information in such text, please keep to to a minimum to avoid that people do not trust your output anymore.

Thanks for your hint regarding the form. I will keep that in mind for my next post.

Only NFS with kerb is affected
https://bugzilla.opensuse.org/show_bug.cgi?id=1224340

1 Like

@hui Thanks a lot for the link. This is exactly my issue.

Note: As described by other affected users also non kerberized mounts are affected by this bug

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.